
ELMI Workshop 
 
The presentation and a PDF version of the workshop are available at  
https://downloads.openmicroscopy.org/presentations/2019/ELMI 

Software versions used for this workshop: 
● OMERO: 5.4.10 
● OMERO.iviewer: 0.7.0 
● OMERO.figure: 4.0.2 
● OMERO.mapr 0.2.3 
● OMERO.parade: 0.1.1 
● OMERO.FPBioimage: 0.3.0 
● OMERO training scripts: 0.6.0 
● OMERO training notebooks: 0.4.1 
● OMERO-downloader: 0.1.5 
● Bio-Formats: 5.9.2 
● Fiji/ImageJ: 2.0.0-rc-68/1.52e 
● CellProfiler: 3.1.3 

 

Content 
● Introductory talk about OMERO 
● OMERO core concepts  

○ Data Management 
○ Metadata 
○ Search 

● Visualization 
○ Viewer 
○ 3D Viewer 

● Fiji as 3rd party tool for OMERO 
● OMERO.parade 
● OMERO.figure 

 

Import via desktop client and CLI  (for your information only) 
Description 
In this first part, we first show how to import data by yourself and for yourself into OMERO using 
various import strategies. This will be mainly done using the OMERO.insight desktop client.  

https://downloads.openmicroscopy.org/presentations/2019/ELMI


Second part of this import section will show how to import data for another user, using 
OMERO.insight and Command Line Interface (CLI). The user importing the data needs to have 
some admin (or restricted-admin) privileges.​ ​More information about restricted privileges can be 
found at ​https://docs.openmicroscopy.org/latest/omero/sysadmins/restricted-admins.html 

The import for yourself will be done by the OMERO user you have been allocated. The import 
for another user will be done only as demo since the user requires to have specific privileges. 
We will use the user ​importer1 ​e.g.​ ​a facility manager​.  

 

Setup 
● The Desktop client OMERO.insight​ ​has been installed on the local machine. The 

installation instructions can be found at 
http://help.openmicroscopy.org/getting-started-5.html#installing​.  

● Client libraries from the OMERO.server have to be installed on the client to import 
images using CLI. The installation instructions can be found at 
https://docs.openmicroscopy.org/latest/omero/users/cli/installation.html​. 

 

Desktop client Import 

1. Open OMERO.insight and in the login dialog, click on the spanner icon . This will open a 
list of servers to which you can connect. By default, only “localhost” is listed. Click on the 
plus​ icon to add a new line to the list and type into the line the server address 
outreach.openmicroscopy.org 

 
2. When done, click ​Apply.  
3. Log in using the username and password provided. 

4. In OMERO.insight, click on the Importer Icon in the toolbar. 

https://docs.openmicroscopy.org/latest/omero/sysadmins/restricted-admins.html
http://help.openmicroscopy.org/getting-started-5.html#installing
https://docs.openmicroscopy.org/latest/omero/users/cli/installation.html


5. Browse your local hierarchy in the left-hand pane of the importer, select single images or 

whole folders and add these to the Queue by clicking on the ​arrow icon. 
6. In the ​Import Location ​window, select the target Project and Dataset (existing or create a 

new one) to import to.  
7. Note: If no Dataset is selected or created, a new Dataset will be automatically created 

and named after the folder containing the images to be imported.  
8. Optional: Go to the ​Options​ tab  

a. Click on  to bring the Tag selection dialog. 
b. Select the tag(s) on the left-hand side or create a new one. 

c. Click  to move the tag(s) to the right-hand side. 
d. Click ​Save. 

9. Click on the​ Import ​button in the bottom-right corner of the Importer window. You should 
see two progress bars for every image imported,  ​Upload ​ and ​Processing​. 

10. Note: The import of the next image in the queue starts immediately after the ​Upload ​of 
the previous one is finished. The ​Processing​ phase of the import is done on the 
OMERO.server only, and can be finished while the next image(s) is/are being uploaded 
to the server. 

11. Once imports are finished, go back to the OMERO.insight main window and click the 

Refresh​ button  above the right-hand pane. This will display the imported images 
inside the Dataset and/or Project you specified previously in the ​Import Location ​window. 

12. (demo only step) Now, the demonstrator will log out from OMERO.insight and log in 
again, this time as some other user and will show the import process again, this time 
importing a different set of images. After this import, the two sets of images (belonging to 
two different users) will be shown in the webclient.  

 

OMERO core concepts 
Description:  
We introduce some key features of the OMERO platform using the webclient. 
 

Data setup and ownership, usernames 
All images for this workshop have been pre-imported for you into the OMERO.server. For 
training purposes, we prepared 50 users on the OMERO.server. ​Each ​of these 50 users has 
their own set of images.​ These sets consist of i​mages of the same name, size, shape, form 
and quality for each user.​ Thus, the data of each user appears the same but, in actual fact, 
are different and totally independent sets. Thus, small discrepancies and differences between 
the users are completely possible. Further, if one user deletes their own data in OMERO 



(​please do not delete anything​ on our server), this will not have any bearing on the other 49 
sets of images belonging to the 49 other users. 
The ​login names​ of the 50 users are  “user-x” where x goes from 1 to 50, We have given to 
each of the 50 users in OMERO a unique first name and surname which we picked from a list of 
50 famous scientists e.g. Ada Lovelace or Francis Crick. This is the name (“your” name) which 
you will see in the top-right corner of the OMERO webclient after you log in with your loginname. 
In the OMERO webclient the default view shows only your own images. The beginning of the 
Browse images​ section below explains how to navigate to other users’ data. 

Browse Images 
1. In your web browser, go to ​https://outreach.openmicroscopy.org/  
2. Log in using the username and password provided. 
3. OMERO offers various levels of permissions for groups and users. Depending on the 

permissions level of each group, a given user might be able to view, annotate or edit 
data belonging to other users. Permissions are managed by users with admin privileges. 
For this training session, we will work in a “Read-Annotate” group. This implies that 
users can view and annotate each other’s data but ​cannot​ delete other people’s data. 

4. To see other people’s data, click on the ​Lab1​ group name in the top-left corner of the 
webclient. Then use the menu to select the name of the user whose data you wish to 
see.  

 
5. You can browse ‘folders’ in the left-hand pane: ​Image​ folders are called ​Datasets​ and 

they are within ​Projects​. 

https://outreach.openmicroscopy.org/


6. When a Dataset is selected, Image thumbnails are shown in the centre panel.

 
7. These represent imported Images. The original Images are stored on the server and the 

generated thumbnails allow us to browse them. 
8. Bio-Formats, ​https://www.openmicroscopy.org/bio-formats/​, is used to read the 

pixel-data and metadata from over ​150​ different image formats, including multi-z 
timelapse images with many channels, they are referenced as 5D Images. Large 
pathology and medical images are also supported. 

9. Select an Image. In the right-hand pane, metadata read by Bio-Formats and stored in a 
relational database is displayed: 

a. core metadata in the ​General​ tab 
b. additional metadata in the ​Acquisition​ tab. All the metadata read by Bio-Formats 

can be downloaded at any time. 
10. In the ​Preview​ tab in the right-hand panel, you can also view the Image. 
11. For multi-plane images, sliders allow you to move through Z or Time dimensions. 
12. Viewing Images ​DOES NOT ​download the whole Image to the client. Only the viewed 

Image plane is rendered from the original Image file on the server and sent back to the 
client. 

13. You can adjust the rendering settings for each channel e.g. turn on/off the channels, 
adjust color settings, look-up tables, etc.. 

14. The rendering settings can be saved to the server. This ​NEVER ​changes the original 
Image data and can be reverted at any time. 

15. The rendering settings can also be copied and pasted between Images. To modify the 
rendering settings in batch, click on the ​Save to All​ button to apply the same settings to, 
for example, all Images in a given Dataset. 

16. You can use the settings which other users saved on your Images and apply them for 
your own Image. These settings are highlighted as thumbnails in the lower part of the 

https://www.openmicroscopy.org/bio-formats/


Preview​ pane.                                        .

 
17. Your own settings are highlighted in blue. 
18. You can revert to the original settings for an Image or Dataset. For example, using the 

context menu for a Dataset in the tree, select ​Rendering Settings​ > ​Set Imported and 
Save​. 

View Images 

1. Double-click on an Image thumbnail, or click the ​Full Viewer​ button in the 
right-hand pane to open an Image in a larger viewer called OMERO.iviewer. It is a Web 
app developed and released independently from the webclient. The OMERO.web 
framework can be extended with multiple apps to view data in different ways.  

2. We can adjust the rendering settings and scroll through Z or T.

 

3. Click the ​Crosshairs​ icon  at the top-right of the viewer to enable the pixel intensity 
display for the mouse pointer. Then mouse over the Image to see the pixel intensities 



for the channels turned on. 

  

4. The ROIs tab includes tools for viewing and drawing ROIs on the Image. 
These are saved back to the OMERO server. Select the ​arrow tool​ in the right-hand 

pane  and draw an arrow on the Image, using Click-Move-Click (not drag), 

pointing to a feature in the Image and save it using the ​Save button  located in 
the upper part of the right-hand pane. Draw also a couple of other ROIs on different Z 
planes.  

a. Dragging on the Image is used for panning the image.  
b. Shift-drag​ rotates the image (using selection tool) or draws “freehand” (polygon, 

polyline, rectangle and ellipse).

 



5. Clicking onto the ROIs in the right-hand pane table brings the viewport to the position 
where the selected ROI is in the middle of it and navigates the viewport to the timepoint 
the ROI is associated with.  

 
6. Select several ROIs from different Z planes. You can select in the table (​Shift-click​ to 

select a range) but also in the image itself using ​Cmd-drag​ to select multiple ROIs. 
7. Export the Intensities, areas and line lengths into Excel. Select, in the top-left corner 

ROIs > Export (Excel). ​This will export the values from the selected ROIs. 
8. Save the viewport by selecting in the top-left corner ​File > Save Viewport as PNG. 
9. Compare the two channels of one of the Images in multi-image view: 

a. Double-click on the thumbnail of the already opened Image in the left-hand 
pane of the viewer. This will open the Image again in a new window.  

b. Select one of the windows and in the right-hand pane switch the green channel 
off.  

c. On the other window, switch the blue channel off. 

 
10. We can synchronize the viewers by adding them both to the same sync Group.  

a. Click the ​sync icon  in the top-left corner and select the first option in the 
dropdown menu.  

b. Repeat for the other viewer.  



c. Now both Images have the ​Z/T​ and ​View​ (zoom and position of viewport) 

synchronized.                   . 
11. Click on ​Info​ tab in iviewer now, and find, in the right-hand pane, the link to ​Dataset: 

. Click on that link. This will bring you back 
to the webclient. 

12. Adjust the channel names:  

a. Select any image inside that Dataset and click on the ​pencil​  icon in the 
right-hand pane next to Channels. 

b. Input ​“DAPI”​ instead of channel ​“457”​  and ​“GFP”​, ​“Aurora-B”​ and ​“CY-6​” for 
the other channels. 

c. Click the ​Apply to All ​button  and confirm by clicking ​Continue​. 
13. Go to data of trainer-1. Open an image from the Dataset ​mouse-14-days ​in a 3D 

viewer: OMERO.FPBioimage.  
a. First select the Image. 
b. Right-click menu on the image in the left panel, or use the ​Open with... ​icon on 

top of the right-hand pane to open the image with FPBioimage. 
c. Click ​Start​ in the new viewer window. 

14.  

 

Add Annotations, Filtering and Searching 

1. Let’s now add annotations to Images in the webclient. We will add Tags to indicate 
Metaphase stages of these cells. 



2. Select one or more Images of cells which appear to be in metaphase. 
3. Choose the ​Tag ​option in the right-hand General tab and click ​[ + ] ​to launch the Tag 

dialog. 
4. Choose the existing ​Metaphase​ from the list of Tags (to filter, type above the list). 
5. Click > to move it to the right column, then click OK. 
6. Select an Image from the Dataset​ ​and in the right-hand ​General​ tab, click the 

harmonica ​Key-Value Pairs​. 

 

 

7. The ​Key-Value Pairs ​allow you to add lab-book-like additional metadata for the Image. 
These ​Key-Value​ ​Pairs ​are also specifically searchable. 

8. It is also possible to add Comment, Attachment and Rating to selected Images. 
9. Enter ​mitomycin-A​ ​into the search box in the top right corner of the webclient 

  and press Enter. 
10. The search results will show any objects e.g. Images or Datasets which have anywhere 

the string ​mitomycin-A​.​ Several images should be found, from at least 2 different 
datasets. 

11.  Refine the search now for only ​Key-Value Pairs​ which have the key ​mitomycin-A​ and 
value ​0mM​ by entering ​mitomycin-A:0mM​ ​into the search box and pressing Enter. 
Now you should find only 21 images. Select 2 images from two different datasets in the 
Results (you can judge by the thumbnails which images are from which dataset). Click 
onto the ​Open with​ icon in the right-hand pane and select OMERO.iviewer. 

12. Go back to the Search results tab. Click on the ​Browse​ link in one search 
result line of the last image (in the right-hand part of the centre pane) to navigate back 
to the main webclient. 

13. Images can also be filtered by Tag or Rating in the centre pane, using the ​Add filter 
chooser above the thumbnails. 



14. For example, choose Tag and then select ​Metaphase​ from the list of Tags to show the 
images we tagged earlier. 

15. Review the filtered Images, choose a favourite Image and under the ​Rating​ section in 
the right-hand pane, click on the 5th star to add a rating of 5

 
16. Now we can remove the filtering by Tag and instead filter by ​Rating of 5​ to show only 

our favourite images.  

Analysis with Fiji 
Description 
Fiji is a free open-source ​image processing package based on ImageJ​. 

We show how to analyze a batch of images stored in OMERO using the scripting facility in Fiji, 
the results of the analysis will be stored as a CSV and OMERO.table, 

If analyzing other users data, the user analyzing the data needs to have admin privileges. 

More information about restricted privileges can be found at 
https://docs.openmicroscopy.org/latest/omero/sysadmins/restricted-admins.html​. 

 

Setup 
● Fiji has been installed on the local machine with the OMERO.insight-ij plugin. The 

installation instructions can be found at 
http://help.openmicroscopy.org/imagej.html#plugins​. 

● Installing the OMERO.plugin also adds the dependencies required to connect to 
OMERO using the Script Editor of Fiji. 

● The OMERO.script 
https://github.com/ome/training-scripts/blob/v0.6.0/practical/python/server/batch_roi_exp
ort_to_table.py​ has been uploaded to the server. 

 

Fiji Manual simple workflow: Draw ROI 

1. Launch Fiji. 
2. Go to ​Plugins​ > ​OMERO​ > ​Connect To OMERO.​ This will show a login screen where 

you can enter the name of the server to connect to, the username and password. The 
OMERO plugin will allow you to browse your data in a similar manner to the webclient. 

https://docs.openmicroscopy.org/latest/omero/sysadmins/restricted-admins.html
http://help.openmicroscopy.org/imagej.html#plugins
https://github.com/ome/training-scripts/blob/v0.6.0/practical/python/server/batch_roi_export_to_table.py
https://github.com/ome/training-scripts/blob/v0.6.0/practical/python/server/batch_roi_export_to_table.py


 

3. Select the ​A-Fiji-dataset​ Dataset. 
4. Double-click on a thumbnail or on an Image in the left-hand tree to open an Image in 

ImageJ. 
5. Go to ​Analyze > Tools > ROI Manager… 
6. Draw a shape using for example the Freehand selection tool. 
7. In the ROI manager, click the button ​Add [t]​ to add the shape to the Manager. 

 

8. Move to another channel, using the ​c​ slider. 
9. Draw other shapes if desired. Add drawing a shape. Click ​Add [t] ​to add it to the 

Manager. 
10. When done with the drawing, click the button ​Measure ​in the ROI Manager 
11. A dialog with measurements for each shape pops up. 



12. To save the ROI and the measurement back to OMERO, go to ​Plugins​ > ​OMERO​ > 
Save ROIs To OMERO. 

13. In the dialog popping up, under the ​Save​ section select ​ROI​ and ​Measurements​. 
14. The measurements are saved as a CSV file. 

 

15. Go back to the webclient, in the right-hand panel, check that there is a new CSV file 
under the ​Attachments​ harmonica. 

16. Open the image in iviewer to see the ROIs and make sure that you can interact with 
them. 

Fiji Manual simple workflow: Crop Image 
1. This time we will crop an Image stored in OMERO and saved the cropped Image back to 

OMERO as OME-TIFF. 
2. Select the ​A-Fiji-dataset​ Dataset. 
3. Double-click on a thumbnail or on an Image in the left-hand tree to open an Image in 

ImageJ. 
4. In the Bio-formats dialog, check that you have “Hyperstack” selected and click OK. 



 
5. Note: You can also select ​Split channels​ checkbox in the Bio-formats dialog above, and 

do the following crop workflow on single channel images. 
6. The image will open in Fiji. 
7. Note: You can now use Image > Duplicate in Fiji and do the workflow on the duplicate. 
8. Draw a Rectangle on the Image. 
9. Select ​Image > Crop 
10. A new Image will be displayed in a Fiji window 
11. Go to ​Plugins​ > ​OMERO​ > ​Save Image(s) To OMERO 
12. An Import dialog (specific to Fiji plugin) will pop up. 



 
13. Check that the option​ Add Image from current window​ is selected 
14. Select where to import the cropped Image e.g. ​A-Fiji-dataset​ Dataset. 
15. Click ​Add to the Queue​ button 
16. Then click ​Import. ​The import will start 
17. When the import is done, go back to the Tree view in the Fiji plugin or Web client. 

Refresh. Check the new Image. 
 

Fiji Manual workflow 
1. Launch Fiji. 
2. To open an image stored in OMERO, Go to ​Plugins​ > ​OMERO​ > ​Connect To OMERO ​if 

necessary. 

3. In the OMERO login dialog, click the wrench icon  and then add the server address in 
the dialog i.e. ​outreach.openmicroscopy.org​. Click ​Apply​. 



 
4. Enter your ​Username​ and ​Password​ and click ​Login​. 
5. Browse to the Project ​idr0021​, open any Dataset and double-click once on an Image to 

open it in Fiji. Bio-Formats is used to view the Image. 
○ Make sure to select ​View stack with: Hyperstack​ in the ​Bio-Formats Import 

Options ​dialog. 
○ Note that each plane will be transferred from the server to the client machine so 

this may take a few moments. 
6. To open the recorder, go ​Plugins > Macros > Record…​, select ​JavaScript​ to record the 

actions. The steps will then be used in the Scripting workflow below. 
7. Convert floating-point pixel-type to 8-bit using ​Image > Type > 8-bit. 
8. Go to ​Image > Adjust > Auto Threshold​, to open the ​Auto Threshold ​dialog: 

○ Select ​MaxEntropy​ for the ​Method ​parameter. 
○ Check the checkbox ​Stack. 

 
9. Click OK. 



10. Then open ​Analyze > Analyze Particles…. 
11. In the dialog 

○ Set ​Size​ to ​10-Infinity ​and check ​Pixel units. 
○ Check the following checkboxes: 

i. Display results 
ii. Clear results 
iii. Add to Manager 

○ Click ​OK​ then ​Yes​ in the popup dialog indicating asking to ​Process all 3 images?​. 

 
 

12. To save the thresholded Image back to OMERO with the generated ROIs and the 
measurements:  

○ Select ​Plugins​ > ​OMERO​ > ​Save Image(s) to OMERO.  
○ Create a New Dataset for the image 

i. Click​ ​the ​New…​ button next to the selection box on the Dataset row. 
ii. In the dialog that pops up, enter a name and a description (optional). 
iii. Click ​Create. 

○ The newly created Dataset will automatically be selected. 
○ C​lick​ ​Add to the Queue​ then ​Import​.  
○ Go to the webclient and check that the measurements have been saved in a CSV 

file and attached to the Images. The attachment can then be downloaded at any 
time. 

Fiji Scripting workflow  
We will now repeat the manual analysis on a Dataset using the scripting facility available in Fiji.  
Let’s go over the scripts to understand the logic and see how it matches the UI steps. 
This script explores the JAVA API using groovy. See 
https://docs.openmicroscopy.org/latest/omero/developers/Java.html​, 
 

1. Go to ​https://outreach.openmicroscopy.org/​. 

https://docs.openmicroscopy.org/latest/omero/developers/Java.html
https://outreach.openmicroscopy.org/


2. Log in using the credentials provided 
3. Make sure you are selecting your own data. Select the Dataset ​A-​Fiji-dataset​.  
4. Launch Fiji. (relaunch if opened). 
5. Go to ​File > New > Script…. 
6. A dialog pops up. In the ​Language​ menu select ​Groovy. 
7. Copy the content of the script 

https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/groovy/analyse_d
ataset_save_rois_and_summary_table.groovy​ into the text script editor of Fiji. 

8. Edit the following parameters: dataset_id, USERNAME, PASSWORD. 

 
9. The script will process all the Images in the specified Dataset, applying threshold, 

analyzing particles and saving ROIs back in OMERO i.e. we reproduce in a script the 
manual steps recorded above. Further, it will create a CSV and OMERO.table to be 
attached to that Dataset in OMERO. Both are not necessary when analysing data, this is 
mainly to show how it we 

10. Click ​Run. 
11. Return to the webclient and open an Image from this Dataset in OMERO.iviewer. 
12. Click the ​ROIs​ tab to see the added ROIs. Note that the ROIs have been assigned a 

Channel index to indicate which Channel they were derived from. 

https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/groovy/analyse_dataset_save_rois_and_summary_table.groovy
https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/groovy/analyse_dataset_save_rois_and_summary_table.groovy


13. In the ​Settings​ tab, turning channels on/off will also show/hide ROIs assigned to those 
channels. 

14. Open the image in OMERO.figure for a quick publication by going to ​Info​ tab in iviewer 

and clicking on ​OMERO.figure ​in the ​Open with ​line.  
15. This script was used previously to run on the whole ​idr0021 ​Project and produced the 

resulting CSV file. We can now download this file from OMERO and open it in Microsoft 
Excel. 

16. In Excel, select the Dataset column and the column bounding_box and then click on 

Insert > X Y Scatter > ​Scatter . ​Depending on the version of Excel you are using, 
this option might not be available. 

  .  
17. This will create a scatter plot. Right-click into the Chart now and select ​Change chart 

type > Statistical > Box and Whisker.  
 

1. Click the ​ROIs​ tab to see the added ROIs. Note that the ROIs have been assigned a 
Channel index to indicate which Channel they were derived from. 

2. In the ​Settings​ tab, turning channels on/off will also show/hide ROIs assigned to those 
channels. 

3. Open the image in OMERO.figure for a quick publication by going to ​Info​ tab in iviewer 

and clicking on ​OMERO.figure ​in the ​Open with ​line. . 

 

OMERO.parade and OMERO.figure 

Analyze metadata using OMERO.parade 
 

1. Select the Project ​idr0021​. 
2. Choose the ​Parade​ option in the centre panel dropdown menu. 
3. Expand all Datasets by clicking on the ​Open All​ button. 

a. All the Datasets will be expanded in the left-hand tree. 



b. The Thumbnails will be loaded in the centre panel. This allows to browse a full 
Project. 

c. Note that if you collapse a Dataset in the tree, the Thumbnails will be removed 
from the centre panel. 

4. In the ​Add filter... ​selection box, select the ​Key_Value ​item. 
a. When the Map Annotations are loaded, pick the Key ​Gene Symbol​ and enter the 

Value ​CEP ​to show all ​CEP​ genes and then ​CEP120​ to show only images with 
that gene. 

b. To remove this last filter, hover over the filter and click the ​X​ button that shows on 
hover. 

5. In the ​Add filter... ​selection box, select the ​ROI_Count ​item.  
a. Enter a Value ​> 20. ​When you hover over the area used to enter the value, the 

range is indicated in the tooltip. 
b. Then enter < 3 or 4. 

6. Remove all filters by clicking the X button showing on hover. 
7. Select several images in the dataset, and in the right-hand pane add a comment to them 

saying “poor staining”. Refresh, using the refresh button  above the left-hand 
pane. 

8. In the ​Add filer…​ selection box, select the ​Comment ​item.  
a. Enter a text “poor staining” 

9. Note that you can use the selected images in right panel to annotate or ​Open with...​.  
10. Choose​ Open with Figure… 

 
 
Let’s look at the analytical results generated using the ​Analyze particles​ plugin in Fiji 
 
 

1. Select the first dataset of Project ​idr0021​, expand it and click on any image. 
2. You can see the values stored in the OMERO.table produced by the Fiji script for that 

image in the right-hand pane under ​Tables ​harmonica. Note that these values are used 
by OMERO.parade to perform the filtering shown below. 



3.  
4. Collapse all datasets inside the Project ​idr0021.​. 
5. Select the Project ​idr0021​. 
6. Choose the ​Parade​ option in the centre panel dropdown menu. 
7. Expand all Datasets by clicking on the ​Open All​ button. 
8. In the ​Add filter... ​selection box, select the ​Table ​item so we can find using the analytical 

results generated previously:. Choose the ​Bounding_Box​ item and drag the slider to filter 
the Images. Note that ​PCNT​ has the largest number of Images with large ROIs. 

i.  
9.  

i.  

10. Switch to Table layout (middle button)  .  
11. In the selection box​ Add table data​…, select 

a. Table_Bounding_Box 
b. Table_Total_Area 
c. Table_Image 
d. Note that it is currently not possible to remove a column. 

12. Click on the name of a column to sort it. 
13. Uncheck ​Show Datasets​ to sort all Images together e.g. by ROI count. 

14.  



15. Check the checkbox in each column to show the ​Heatmap​. Note the corresponding 
pattern in the Heatmap. 

16. Switch now to the Plot Layout (third button) 
17. It takes the table data loaded and plot the values. 
18. Filters can be added to plot the relevant results. 
19. Try plotting by different Axis values. 
20. Closing a Dataset in the left-hand tree removes the values from the plot. 
21. Drag to select several outliers. 
22. Note that you can use the selected images in right panel to annotate or ​Open with...​.  
23. Choose​ Open with Figure… 

 
Let’s now look at the results generated by CellProfiler 
 

1. Return to the webclient and select the Plate named 
plate1_1_013_previously_analyzed​. 

2. Select a Well and open the ​Tables​ pane in the General tab in the right-hand panel. This 
will show all the CellProfiler values for this Well. 

3. In the ​Thumbnails​ chooser at the top-right of the centre panel, select the ​Parade​ plugin. 
4. At the top-left of the centre panel choose ​Add filter…​ -> ​Table ​to filter Wells by the data 

from CellProfiler. 
5. Change the filter from ​ImageNumber ​to ​Cell_Count​ (at the bottom of the list). 
6. Now you can use slider to filter Wells by Cell Count.

 

 
 

OMERO.figure: Use metadata in figure creation 
1. In the webclient, select the ​idr0021​ Project, filter by e.g. Bounding Box and select 

several filtered images. 



2. In the right-hand panel, click the ​Open with... ​button and choose ​OMERO.figure​: 

 
3. This will open these images in OMERO.figure in a new browser Tab. 

4. Drag to arrange the Images into two rows, select all and click the ​snap to grid​ button 
at the top of the page. 

5. Select all Images and Zoom in around ~300% 
6. Go to the ​Labels​ tab, select all Images and add a Scalebar of 1 μm and adjust the size 

of the Label to 12. 
7. Add label from Dataset name: ​color=white position=top-left 
8. Select one image. In the ​Labels​ tab, click the ​Edit​ button for ROIs. 
9. Load ROIs from OMERO and mouse over the list to pick the largest ones. 
10. Click to add it to the image and click ​OK​. 
11. Return to the webclient tab, select the ​siRNAi-HeLa​ Dataset and filter by Rating of 5 

stars. 

12. Select 3 images and in the right-hand panel click the link icon then copy the link. 
13. Return to the OMERO.figure tab, click ​Add Image​ button and paste the link into dialog. 

Click OK. 
14. Arrange the 3 images into a vertical column, select all and click ​snap to grid​ button. 
15. Copy the 3 images and paste (keyboard shortcut or ​Edit > Copy/Paste​) 3 times to create 

3 more columns. 
16. Select the panels in the first column and adjust the rendering settings: Turn only the first 

channel on and set the color to white. 
17. Repeat for the next 2 columns: 1 channel turned on for each column, adjusting the levels 

if desired, leaving the 4th column as ​‘merged’​ with multiple channels on. 
18. Select all panels and zoom a little. Then select a row and drag the image in the ​Preview 

tab to pan. 
19. Copy and paste the ​‘merged’​ column again to create a 5th column. Zoom in to approx 

500%. 
20. Select the ​Labels​ tab, select the ‘​merged’​ and ​zoomed​ columns and click ​Show 

Scalebar button. 
21. Click the ​Label​ checkbox to add label to the scalebar. Select only the zoomed-in panels 

and change the scalebar to 1 micron. 
22. Select the top-left panel and enter a label text in the ​Add Labels​ form. 
23. Choose the label size, position (left vertical) and color and click ​Add​ to create label. 
24. Now undo this (​Ctrl-Z​ or ​Edit > Undo​) and instead create labels from Tags: 



25. Select the first column of panels and choose ​Tags​ from the label text-field drop-down 
options. Click Add. 

26. Select the first row of panels and create the labels in the ‘top’ position using the 
Channels​ option. 

27. Edit the created labels located at the bottom of the ​Info​ tab to rename the green labels to 
GFP-INCENP​. 

28. Select just the first ‘​merged​’ image and click the ROIs ​Edit​ button in the ​Labels​ tab. 
29. Draw arrows or other shapes on the image, or load ROIs from OMERO. Click ​OK​. 
30. Click ​Copy​ ROIs in the ​Labels​ tab, select the other panels in the same row and click 

Paste​ to add ROIs to these panels. 
31. To create a Rectangle ROI indicating the region of the zoomed-in image, select the 

zoomed-in image on the first row and click ​Copy​ of the cropped region at the bottom of 
the ​Preview​ tab. 

32. Now select the zoomed-out ​‘merged’​ panel, and paste this region as an ROI by clicking 
Paste​ under ROIs section of the ​Labels​ tab. 

33. Repeat for other rows of the figure. 
 

 
34. Go to ​File​ > ​Paper Setup…​ and in the dialog that pops up choose ​Pages: 2.​ Click ​OK​. 
35. Finally return to the webclient, select ‘Big’ images from the ​svs​ Dataset, copy the link to 

them and paste it into the ​Add Image​ dialog in OMERO.figure. 
36. Move the big images to the 2nd page. 
37. In the header, click on the ​Save ​button to save the Figure as “Figure 1”. 
38. To open other saved files, go ​File > Open… 
39. We can view figures from our collaborators here and filter by name or Owner. 



40. Open the ​Aurora-B figure 2​ from trainer-2. 
41. Select a panel and click on the ​Webclient​ link in the ​Info​ tab to show the image in the 

webclient. 
42. Back in OMERO.figure, go to ​File > Open...​ to choose the “Figure 1” file saved above. 
43. Click on ​Export PDF ​to export it as PDF. 
44. Download the PDF and open it. If opened in a suitable application e.g. Illustrator, the 

elements on the page will still be editable. 
 
 
 


