Software versions used for this workshop:

- OMERO: 5.4.10
- OMERO.iviewer: 0.7.0
- OMERO.figure: 4.0.2
- OMERO.mapr 0.2.3
- OMERO.parade: 0.1.2
- OMERO.FPBioimage: 0.3.0
- OMERO training scripts: 0.6.0
- OMERO training notebooks: 0.4.1
- OMERO-downloader: 0.1.5
- Bio-Formats: 5.9.2
- Fiji/ImageJ: 2.0.0-rc-68/1.52e
- CellProfiler: 3.1.3

Content

- Introductory talk about OMERO
- Import
  - Cover the various import options
- OMERO core concepts
  - Data Management
  - Metadata
  - Search
- Visualization
  - Viewer
  - 3D Viewer
- Image Export
  - Client export
- OMERO.parade
- OMERO.figure
  - How to use figure
  - How to extend figure
- IDR
Import via desktop client and CLI

Description

In this first part, we first show how to import data by yourself and for yourself into OMERO using various import strategies. This will be mainly done using the OMERO.insight desktop client.

Second part of this import section will show how to import data for another user, using OMERO.insight and Command Line Interface (CLI). The user importing the data needs to have some admin (or restricted-admin) privileges. More information about restricted privileges can be found at https://docs.openmicroscopy.org/latest/omero/sysadmins/restricted-admins.html

The import for yourself will be done by the OMERO user you have been allocated. The import for another user will be done only as demo since the user requires to have specific privileges. We will use the user importer1 e.g. a facility manager.

Setup

- The Desktop client OMERO.insight has been installed on the local machine. The installation instructions can be found at http://help.openmicroscopy.org/getting-started-5.html#installing.
- Client libraries from the OMERO.server have to be installed on the client to import images using CLI. The installation instructions can be found at https://docs.openmicroscopy.org/latest/omero/users/cli/installation.html.

Desktop client Import

1. Open OMERO.insight and in the login dialog, click on the spanner icon . This will open a list of servers to which you can connect. By default, only “localhost” is listed. Click on the plus icon to add a new line to the list and type into the line the server address outreach.openmicroscopy.org.
2. When done, click **Apply**.

3. Log in using the username and password provided.

4. In OMERO.insight, click on the Importer Icon in the toolbar.

5. Browse your local hierarchy in the left-hand pane of the importer, select single images or whole folders and add these to the Queue by clicking on the **arrow** icon.

6. In the *Import Location* window, select the target Project and Dataset (existing or create a new one) to import to.

7. Note: If no Dataset is selected or created, a new Dataset will be automatically created and named after the folder containing the images to be imported.

8. Optional: Go to the **Options** tab
   
   a. Click on **Add tag to images** to bring the Tag selection dialog.
   b. Select the tag(s) on the left-hand side or create a new one.
   c. Click **to move the tag(s) to the right-hand side.
   d. Click **Save**.

9. Click on the **Import** button in the bottom-right corner of the Importer window. You should see two progress bars for every image imported, **Upload** and **Processing**.

10. Note: The import of the next image in the queue starts immediately after the **Upload** of the previous one is finished. The **Processing** phase of the import is done on the OMERO.server only, and can be finished while the next image(s) is/are being uploaded to the server.

11. Once imports are finished, go back to the OMERO.insight main window and click the **Refresh** button above the right-hand pane. This will display the imported images inside the Dataset and/or Project you specified previously in the *Import Location* window.

12. (Demo only step) Now, the demonstrator will log out from OMERO.insight and log in again, this time as some other user and will show the import process again, this time importing a different set of images. After this import, the two sets of images (belonging to two different users) will be shown in the webclient.

### Import for another user (demo only)

In this example, we show how to import data for another user. A facility manager **importer1** with restricted admin privileges imports the data for **user-1**. The facility manager has been given the ability to import for others.
Desktop client

The steps are the same as before for the normal import, but as *importer1* has the permission to import for another user there are two drop down menus for selecting the user and group to import for:

- Select Group: ‘Lab1’
- Select User: ‘Francis Crick’ (user-1)
- Continue import workflow as usual.

A restriction of Insight is that the user *importer1* needs to be a member of the groups he wants to import for. This restriction does not hold for the CLI import command.

CLI

1. Open a terminal and connect to the server as *importer1* using ssh.
2. We’re going to import an image from /OMERO/in-place-import/FRAP
   ```bash
   $ ls /OMERO/in-place-import/FRAP
   ```
3. Go to $ cd /opt/omero/server/OMERO.server/bin
4. The *importer1* user logs in as user-1:
   a. $ ./omero --sudo importer1 -u user-1 login
5. Create a Dataset **import_one** as user-1:
   a. $ DID=$(./omero obj new Dataset name=import_one)
6. Import the data in the newly created Dataset:
   a. $ ./omero import -d $DID
      /OMERO/in-place-import/FRAP/U20S-RCC1.10_R3D_FRAP.dv
7. Check that the image is successfully imported.

In-place Import CLI (demo only)

Instead of being copied into OMERO’s managed repository, the image files stay at their original place and are just linked into the repository.

It’s only available for the CLI importer, using the argument **--transfer=ln_s**.
Advantages:
- All in-place import scenarios provide non-copying benefit. Data that is too large to exist in multiple places, or which is accessed too frequently in its original form to be renamed, remains where it was originally acquired.

Limitations:
- Only available on the OMERO server system itself.
- Do not edit or move the files after an in-place import. OMERO may no longer be able to access them if you do.
Important:
Someone wanting to perform an in-place import **MUST** have:

- a regular OMERO account
- an OS-account with access to `bin/omero`
- read access to the location of the data
- **write** access to the ManagedRepository or one of its subdirectories. More information about the ManagedRepository can be found at [https://docs.openmicroscopy.org/latest/omero/developers/Server/FS.html](https://docs.openmicroscopy.org/latest/omero/developers/Server/FS.html)

**Unix machine with installed OMERO.server**

- We are still in the omero server directory: `/opt/omero/server/OMERO.server/bin`
- Log in again:
  
  ```
  $ ./omero --sudo importer1 -u user-1 login
  ```
- ‘In place’ import a large SVS file into the same dataset as before:
  ```
  $ ./omero import -d $DID --transfer=ln_s /OMERO/in-place-import/svs/77917.svs
  ```
- Check that the image is successfully imported.
- Click on the paths icon to show the difference between the normal and `ln_s` imported images.

**Bulk Import CLI (demo only)**

In this example, we show how to combine several import strategies using a configuration file. This is a strategy heavily used to import data to [https://idr.openmicroscopy.org/](https://idr.openmicroscopy.org/).
We import two folders named *siRNA-HeLa* and *condensation*. For this training, the path to the OMERO.server is `/opt/omero/server`.

1. Open a terminal and connect to the server as `importer1` using ssh.
2. Description of the files used to set up the import, the files are in the directory `/OMERO/in-place-import`. You can access the files on [https://github.com/ome/training-scripts/tree/v0.6.0/practical/other](https://github.com/ome/training-scripts/tree/v0.6.0/practical/other) (see also [https://docs.openmicroscopy.org/omero/5.4.10/users/cli/import-bulk.html#bulk-imports](https://docs.openmicroscopy.org/omero/5.4.10/users/cli/import-bulk.html#bulk-imports) for further details).
   a. `import-paths.csv`: this file has at least two columns. In this case (.csv, comma-separated values) the columns are separated by commas. The first column is the name of the target Dataset and the second one is the path to the folder to import. We will import two folders (the `import-paths.csv` has two rows).
   b. `bulk.yml`: this file defines the various import options: transfer option, checksum algorithm, format of the `.csv` file, etc. Note that setting the `dry_run` option to true allows to first run an import in `dry_run` mode and copy the output to an external file. This is useful when running an import in parallel.
3. Go to `/OMERO/in-place-import` i.e. `cd /OMERO/in-place-import`
4. The `importer1` (Facility Manager with ability to import for others) user logs in as `user-1`:
   a. `$ bin/omero --sudo importer1 -u user-1 login`
5. Import the data using the `--bulk` command:
   a. `$ bin/omero import --bulk bulk.yml`
6. Go to the webclient during the import process to show the newly created dataset. The new datasets in OMERO are named *Experiment1-HeLa* and *Experiment2-condensation*. This was specified in the first column of the `import-paths.csv` file.
7. Select an image.
8. In the right-hand panel, select the *General* tab to validate:
   a. Click on `...` to show the import details.
   b. Validate that In-place import is indicated.

Advantages:
- Large amount of data imported using one import command.
- Reproducible import.

Limitations:
- Preparation of the `.csv` or `.tsv` file.
More information about import options using the CLI import can be found at

OMERO core concepts

**Description:**
We introduce some key features of the OMERO platform using the webclient.

**Data setup and ownership, usernames**

All images for this workshop have been pre-imported for you into the OMERO.server. For training purposes, we prepared 50 users on the OMERO.server. **Each** of these 50 users has their own set of images. These sets consist of images of the same name, size, shape, form and quality for each user. Thus, the data of each user appears the same but, in actual fact, are different and totally independent sets. Thus, small discrepancies and differences between the users are completely possible. Further, if one user deletes their own data in OMERO (please do not delete anything on our server), this will not have any bearing on the other 49 sets of images belonging to the 49 other users.

The **login names** of the 50 users are “user-x” where x goes from 1 to 50, We have given to each of the 50 users in OMERO a unique first name and surname which we picked from a list of 50 famous scientists e.g. Ada Lovelace or Francis Crick. This is the name (“your” name) which you will see in the top-right corner of the OMERO webclient after you log in with your loginname.

In the OMERO webclient the default view shows only your own images. The beginning of the **Browse images** section below explains how to navigate to other users’ data.

**Browse Images**

1. In your web browser, go to https://outreach.openmicroscopy.org/
2. Log in using the username and password provided.
3. OMERO offers various levels of permissions for groups and users. Depending on the permissions level of each group, a given user might be able to view, annotate or edit data belonging to other users. Permissions are managed by users with admin privileges. For this training session, we will work in a “Read-Annotate” group. This implies that users can view and annotate each other’s data but cannot delete other people’s data.
4. To see other people’s data, click on the *Lab1* group name in the top-left corner of the webclient. Then use the menu to select the name of the user whose data you wish to see.
5. You can browse ‘folders’ in the left-hand pane: *Image* folders are called *Datasets* and they are within *Projects*.

6. When a Dataset is selected, Image thumbnails are shown in the centre panel.

7. These represent imported Images. The original Images are stored on the server and the generated thumbnails allow us to browse them.

8. Bio-Formats, [https://www.openmicroscopy.org/bio-formats/](https://www.openmicroscopy.org/bio-formats/), is used to read the pixel-data and metadata from over 150 different image formats, including multi-z timelapse images with many channels, they are referenced as 5D Images. Large pathology and medical images are also supported.

9. Select an Image. In the right-hand pane, metadata read by Bio-Formats and stored in a relational database is displayed:
   a. core metadata in the *General* tab
b. additional metadata in the *Acquisition* tab. All the metadata read by Bio-Formats can be downloaded at any time.

10. In the *Preview* tab in the right-hand panel, you can also view the Image.
11. For multi-plane images, sliders allow you to move through Z or Time dimensions.

12. Viewing Images **DOES NOT** download the whole Image to the client. Only the viewed Image plane is rendered from the original Image file on the server and sent back to the client.

13. You can adjust the rendering settings for each channel e.g. turn on/off the channels, adjust color settings, look-up tables, etc..

14. The rendering settings can be saved to the server. This **NEVER** changes the original Image data and can be reverted at any time.

15. The rendering settings can also be copied and pasted between Images. To modify the rendering settings in batch, click on the *Save to All* button to apply the same settings to, for example, all Images in a given Dataset.

16. You can use the settings which other users saved on your Images and apply them for your own Image. These settings are highlighted as thumbnails in the lower part of the *Preview* pane.

17. Your own settings are highlighted in blue.

18. You can revert to the original settings for an Image or Dataset. For example, using the context menu for a Dataset in the tree, select *Rendering Settings > Set Imported and Save*.

**View Images**

1. Double-click on an Image thumbnail, or click the *Full Viewer* button in the right-hand pane to open an Image in a larger viewer called OMERO.iviewer. It is a Web app developed and released independently from the webclient. The OMERO.web framework can be extended with multiple apps to view data in different ways.
2. We can adjust the rendering settings and scroll through Z or T.

3. Click the Crosshairs icon at the top-right of the viewer to enable the pixel intensity display for the mouse pointer. Then mouse over the Image to see the pixel intensities for the channels turned on.

4. The ROIs tab includes tools for viewing and drawing ROIs on the Image. These are saved back to the OMERO server. Select the arrow tool in the right-hand pane and draw an arrow on the Image, using Click-Move-Click (not drag), pointing to a feature in the Image and save it using the Save button located in the upper part of the right-hand pane. Draw also a couple of other ROIs on different Z planes.
a. Dragging on the Image is used for panning the image.
b. *Shift-drag* rotates the image (using selection tool) or draws “freehand” (polygon, polyline, rectangle and ellipse).

![Image](image.png)

5. Clicking onto the ROIs in the right-hand pane table brings the viewport to the position where the selected ROI is in the middle of it and navigates the viewport to the timepoint the ROI is associated with.

<table>
<thead>
<tr>
<th>Show</th>
<th>Z</th>
<th>T</th>
<th>C</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>☑️</td>
<td>✓</td>
<td>1</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>☑️</td>
<td></td>
<td>1</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>☑️</td>
<td></td>
<td>1</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>☑️</td>
<td></td>
<td>1</td>
<td>11</td>
<td></td>
</tr>
<tr>
<td>☑️</td>
<td></td>
<td>1</td>
<td>15</td>
<td></td>
</tr>
</tbody>
</table>

6. Select several ROIs from different Z planes. You can select in the table (*Shift-click* to select a range) but also in the image itself using *Cmd-drag* to select multiple ROIs.

7. Export the Intensities, areas and line lengths into Excel. Select, in the top-left corner *ROIs > Export (Excel)*. This will export the values from the selected ROIs.

8. Save the viewport by selecting in the top-left corner *File > Save Viewport as PNG*.

9. Compare the two channels of one of the Images in multi-image view:
   a. Double-click on the thumbnail of the already opened Image in the left-hand pane of the viewer. This will open the Image again in a new window.
   b. Select one of the windows and in the right-hand pane switch the green channel off.
c. On the other window, switch the blue channel off.

10. We can synchronize the viewers by adding them both to the same sync Group.

   a. Click the sync icon in the top-left corner and select the first option in the dropdown menu.
   b. Repeat for the other viewer.
   c. Now both Images have the Z/T and View (zoom and position of viewport) synchronized.

11. Click on Info tab in iviewer now, and find, in the right-hand pane, the link to Dataset:

    Dataset: siRNAi-HeLa. Click on that link. This will bring you back to the webclient.

12. Adjust the channel names:

    a. Select any image inside that Dataset and click on the pencil icon in the right-hand pane next to Channels.
    b. Input “DAPI” instead of channel “457” and “GFP”, “Aurora-B” and “CY-6” for the other channels.
    c. Click the Apply to All button and confirm by clicking Continue.

13. Open an image from the Dataset siRNAi-HeLa with multiple Z-sections e.g. VRAQ_01.r3d_D3D.dv in a 3D viewer: OMERO.FPBioimage.

   a. First select the Image.
   b. In the Preview tab, switch off all channels except FITC and the GFP-INCENP channel.
   c. Save the new rendering settings.
d. Right-click menu on the image in the left panel, or use the Open with... icon on top of the right-hand pane to open the image with FPBioimage.

e. Click Start in the new viewer window.

f. We can see that the centromeres are well aligned on the metaphase plate on the selected Image, whereas the centromeres are located in and around the spheroid on the IN_02.r3d Image for example.

Add Annotations, Filtering and Searching

1. Let’s now add annotations to Images in the webclient. We will add Tags to indicate Metaphase stages of these cells.

2. Select one or more Images of cells which appear to be in metaphase.

3. Choose the Tag option in the right-hand General tab and click + to launch the Tag dialog.

4. Choose the existing Metaphase from the list of Tags (to filter, type above the list).

5. Click > to move it to the right column, then click OK.

6. Select an Image from the Dataset and in the right-hand General tab, click the harmonica Key-Value Pairs.
7. The **Key-Value Pairs** allow you to add lab-book-like additional metadata for the Image. These **Key-Value Pairs** are also specifically searchable.

8. It is also possible to add Comment, Attachment and Rating to selected Images.

9. Enter **mitomycin-A** into the search box in the top right corner of the webclient and press Enter.

10. The search results will show any objects e.g. Images or Datasets which have anywhere the string **mitomycin-A**. Several images should be found, from 2 different datasets.

11. Refine the search now for only **Key-Value Pairs** which have the key **mitomycin-A** and value **0mM** by entering **mitomycin-A:0mM** into the search box and pressing Enter.

   Now you should find only 21 images. Click on the **Browse** link in one search result line of the last image (in the right-hand part of the centre pane) to navigate back to the main webclient.

12. Images can also be filtered by Tag or Rating in the centre pane, using the **Add filter** chooser above the thumbnails.

13. For example, choose Tag and then select **Metaphase** from the list of Tags to show the images we tagged earlier.

14. Review the filtered Images, choose a favourite Image and under the **Rating** section in the right-hand pane, click on the 5th star to add a rating of 5

15. Now we can remove the filtering by Tag and instead filter by **Rating of 5** to show only our favourite images.
Image export

Image export can be achieved using any of the three main clients for OMERO (OMERO.insight, OMERO.web or command line interface). Further, we have developed an “omero-downloader”, a command-line application dedicated specifically to the downloading and exporting of images and annotations from OMERO.

1. In OMERO.web, select one or more images you want to download. Then, find in the top of the right-hand pane the download icon , click on it and select the desired action, for example Download, which downloads the data in original format.
2. Open the downloaded file(s) in the software of your choice.
3. To export images in a different format such as PNG, TIFF or OME-TIFF, we can use a script on the server to build a zip for download. Select images, click on the script icon and click on “export scripts” and then choose “Batch Image Export…” . You can choose to export individual channels and/or the “merged” image (current rendering settings). It is also possible to export multiple Z and T sections. The image Format can also be specified. If OME-TIFF is chosen, the Channels and Z/T sections are ignored and the entire image is exported as an OME-TIFF image.
4. Click Run Script to generate the zip on the server. When the script completes, the Activities panel will display the result. Click the Download button to download the zip.

5. Open one image in iviewer and draw several ROIs. Back in webclient, add several Tags onto the same image. Using the download icon in the right-hand pane, export the image as OME-TIFF.
6. Reimport the OME-TIFF again into OMERO and verify the imported image still has the ROIs and Tags, same as the original image prior to export. Note: This workflow can be used to transfer the image with its metadata into another OMERO.server if available.

Image export using omero-downloader (demo only)

Setup:
● omero-downloader was installed by downloading and unzipping of the release artifact https://github.com/ome/omero-downloader/releases/download/v0.1.5/OMERO.download-0.1.5-release.zip
● omero-downloader works on Mac, Windows and Linux

1. Open a CLI terminal on your machine and go into the directory where omero-downloader is installed.
2. To download a single image, run the following command. It assumes that the target directory already exists e.g. /tmp/repo
   a. On Mac or Linux
      i. Note: Copy the following command from https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/bash/downloader-commands
      ii. $ ./download.sh -b /tmp/repo -s <server host> -u <user name> -w <password> -f binary Image:<image ID>
   b. On Windows
      i. Note: Copy the following command from https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/bash/downloader-commands
      ii. $ download.bat -b /tmp/repo -s <server host> -u <user name> -w <password> -f binary Image:<image ID>
3. To download all images in a Dataset, run
   a. Note: Copy the following command from https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/bash/downloader-commands into your Terminal.
   b. $ ./download.sh -b /tmp/repo -s <server host> -u <user name> -w <password> -f binary Dataset:<Dataset ID>
   c. Note that you will be able to deduce what tags and annotations the downloaded images were annotated with.
   d. Go to OMERO.web and Tag several images from two datasets with a tag “your-name”. Then, go back to the command line and run
      i. Note: Copy the following command from https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/bash/downloader-commands into your Terminal.
      ii. $ ./download.sh -b /tmp/repo -s outreach.openmicroscopy.org -u <user name> -w <password> -f ome-xml Dataset:$ID2,$ID1
      iii. This will download the xml metadata for images in those two datasets (Note: we could download all the images as well, but we can do it at any later point, as downloader “remembers” what is downloaded already and does not re-download it twice.)
   e. Note: Copy the grep command from https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/bash/downloader-commands into your Terminal.
This will find the IDs of all the images from the two datasets tagged with “your-name” tag.

OMERO.parade and OMERO.figure

Analyze metadata using OMERO.parade

1. Select the Project **idr0021**.
2. Choose the *Parade* option in the centre panel dropdown menu.
3. Expand all Datasets by clicking on the *Open All* button.
   a. All the Datasets will be expanded in the left-hand tree.
   b. The Thumbnails will be loaded in the centre panel. This allows to browse a full Project.
   c. Note that if you collapse a Dataset in the tree, the Thumbnails will be removed from the centre panel.
4. In the *Add filter*… selection box, select the **Key_Value** item.
   a. When the Map Annotations are loaded, pick the Key *Gene Symbol* and enter the Value *CEP* to show all *CEP* genes and then *CEP120* to show only images with that gene.
   b. To remove this last filter, hover over the filter and click the *X* button that shows on hover.
5. In the *Add filter*… selection box, select the **ROI_Count** item.
   a. Enter a Value > 20. When you hover over the area used to enter the value, the range is indicated in the tooltip.
   b. Then enter < 3 or 4.
6. Remove all filters by clicking the X button showing on hover.
7. Select several images in the dataset, and in the right-hand pane add a comment to them saying “poor staining”. Refresh, using the refresh button above the left-hand pane.
8. In the *Add filter*… selection box, select the **Comment** item.
   a. Enter a text “poor staining”.
9. Note that you can use the selected images in right panel to annotate or *Open with*…
10. Choose *Open with Figure*…
OMERO.figure: Use metadata in figure creation

1. In the webclient, select the idr0021 Project, filter by e.g. Bounding Box and select several filtered images.
2. In the right-hand panel, click the Open with... button and choose OMERO.figure:

3. This will open these images in OMERO.figure in a new browser Tab.
4. Drag to arrange the Images into two rows, select all and click the snap to grid button at the top of the page.
5. Select all Images and Zoom in around ~300%
6. Go to the Labels tab, select all Images and add a Scalebar of 1 μm and adjust the size of the Label to 12.
7. Add label from Dataset name: color=white position=top-left
8. Select one image. In the Labels tab, click the Edit button for ROIs.
9. Load ROIs from OMERO and mouse over the list to pick the largest ones.
10. Click to add it to the image and click OK.
11. Return to the webclient tab, select the siRNAi-HeLa Dataset and filter by Rating of 5 stars.
12. Select 3 images and in the right-hand panel click the link icon then copy the link.
13. Return to the OMERO.figure tab, click Add Image button and paste the link into dialog. Click OK.
14. Arrange the 3 images into a vertical column, select all and click snap to grid button.
15. Copy the 3 images and paste (keyboard shortcut or Edit > Copy/Paste) 3 times to create 3 more columns.
16. Select the panels in the first column and adjust the rendering settings: Turn only the first channel on and set the color to white.
17. Repeat for the next 2 columns: 1 channel turned on for each column, adjusting the levels if desired, leaving the 4th column as ‘merged’ with multiple channels on.
18. Select all panels and zoom a little. Then select a row and drag the image in the Preview tab to pan.
19. Copy and paste the ‘merged’ column again to create a 5th column. Zoom in to approx 500%.
20. Select the Labels tab, select the ‘merged’ and zoomed columns and click Show Scalebar button.
21. Click the **Label** checkbox to add label to the scalebar. Select only the zoomed-in panels and change the scalebar to 1 micron.

22. Select the top-left panel and enter a label text in the *Add Labels* form.

23. Choose the label size, position (left vertical) and color and click *Add* to create label.

24. Now undo this (**Ctrl-Z** or **Edit > Undo**) and instead create labels from Tags:

25. Select the first column of panels and choose *Tags* from the label text-field drop-down options. Click *Add*.

26. Select the first row of panels and create the labels in the ‘top’ position using the *Channels* option.

27. Edit the created labels located at the bottom of the *Info* tab to rename the green labels to **GFP-INCENP**.

28. Select just the first ‘merged’ image and click the ROIs *Edit* button in the *Labels* tab.

29. Draw arrows or other shapes on the image, or load ROIs from OMERO. Click *OK*.

30. Click *Copy* ROIs in the *Labels* tab, select the other panels in the same row and click *Paste* to add ROIs to these panels.

31. To create a Rectangle ROI indicating the region of the zoomed-in image, select the zoomed-in image on the first row and click *Copy* of the cropped region at the bottom of the *Preview* tab.

32. Now select the zoomed-out ‘merged’ panel, and paste this region as an ROI by clicking *Paste* under ROIs section of the *Labels* tab.

33. Repeat for other rows of the figure.

34. Go to **File > Paper Setup**… and in the dialog that pops up choose **Pages: 2**. Click *OK*. 
35. Finally return to the webclient, select ‘Big’ images from the svs Dataset, copy the link to them and paste it into the Add Image dialog in OMERO.figure.

36. Move the big images to the 2nd page.

37. In the header, click on the Save button to save the Figure as “Figure 1”.

38. To open other saved files, go File > Open…

39. We can view figures from our collaborators here and filter by name or Owner.

40. Open the Aurora-B figure 2 from trainer-2.

41. Select a panel and click on the Webclient link in the Info tab to show the image in the webclient.

42. Back in OMERO.figure, go to File > Open… to choose the “Figure 1” file saved above.

43. Click on Export PDF to export it as PDF.

44. Download the PDF and open it. If opened in a suitable application e.g. Illustrator, the elements on the page will still be editable.

**OMERO.figure scripting**

We can use JavaScript in the browser console to script changes to a figure. This is an experimental feature and not documented. To see the data model for the current file, go to File > Export as JSON.…

The `figureModel` variable is accessible in the console. We can use AJAX to load JSON data. In this example we will load the FRAP intensities from the Map Annotations on these images.

1. Create a Figure with the first 2 images in the FRAP Dataset belonging to trainer-1.
2. Make each image into a row of multiple time-points.
3. Open the browser console by right-click > Inspect Element (Firefox) or right-click > Inspect (Chrome) and click on the Console tab.
4. Copy the code from [https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/javascript/figure_frap_mapannotation_label.js](https://raw.githubusercontent.com/ome/training-scripts/v0.6.0/practical/javascript/figure_frap_mapannotation_label.js)
5. Drag to select the FRAP movie images in the figure.
6. Paste the code into the console. **Do not hit enter yet.**
7. Inspect the code. It will iterate through each of the selected panels, an AJAX call is made to load the map annotations with the namespace that we created from FRAP values above.
8. The FRAP values are a list of [key, value] pairs and we can get the value for the current T index of the panel with `values[theT][1]` and use this to create a label.
9. Edit the ‘position’ of the label to ‘bottomleft’ (can change size and color too if desired) and hit Enter to run the code on selected panels.
10. The labels should be added. Note that you can undo and redo these changes in the UI as normal.
11. Try out other examples in [https://github.com/ome/training-scripts/tree/v0.6.0/practical/javascript](https://github.com/ome/training-scripts/tree/v0.6.0/practical/javascript)
Image Data Resource (IDR)

1. Open a new tab in your browser and go to https://idr.openmicroscopy.org.
2. Click on Take a look at the data button.
3. Now you are in an OMERO webclient which was customized for the Image Data Resource.
4. Browse the Screens and Projects in the left-hand tree to inspect the IDR Studies.
5. Note: The number of each study is encapsulated in the names of the Screens or Projects e.g. idr0021-lawo-pericentriolarmaterial/experimentA
6. Inspect both the image data and metadata in the right-hand pane Note: the Key-Value Pairs harmonica is called Attributes in the IDR.
7. Select a single image, then find the Gene Key-Value pair group and in the line Gene identifier click on the small icon to the right which brings you to this particular gene in a biomolecular resource database e.g. Ensembl.
8. Now, back to IDR, click on a Gene symbol. This will bring you to the Genes tab in the IDR webclient, where you can explore OMERO.mapr in the way highlighted in the previous chapter.

Demo of IDR analysis possibilities, including R

2. In the top-right corner, expand the Analysis menu and select IMAGE TOOLS RESOURCE (ITR).
3. Find the Fiji/ImageJ line in the table and in the right-most column (Data and Results) click on any of the yellow circles.
4. In the following window, click on the Notebook in the idr0021 line. This will bring you to a Jupyter Notebook that provides a script used to analyzed in Fiji idr0021 hosted server on the https://idr.openmicroscopy.org server. It is not currently possible to run the script directly in the Notebook only the analysis steps are described. Nevertheless, a CSV file with the results of the analysis is available and is then used to analyze the measurements further in the statistical package programme R.
5. Select the first Step and click on the Run button to execute each step in turn.
6. The first step is to find the CSV sheet previously produced by the Fiji analysis. The CSV sheet was stored on the jupyter server. We load the sheet as R dataframe.
7. Then plot the data. Only the protein names against the Bounding Box parameter are plotted. The Bounding box is an estimate of the toroid diameter parameter used in the original paper. First, the extreme values of the observed parameter (Bounding Box) are discarded. Then, the proteins are ordered from lowest to highest Bounding Box (to match the figure in the paper).
8. Check if there is a significant difference between the Proteins with respect to the 
*Bounding_Box*. This is done as one-way analysis of variance. The value of 2e-16 
indicates that there is a difference. One-way analysis of variance is questionable 
because it assumes normal distributed data and similar variances between the groups 
(this is not given, see plot). Therefore also do a ‘Mann-Whitney’ test to check the 
differences between each possible pairwise combination of Proteins. -> There is a 
significant difference between most of the groups, not for some of the groups. 
The results show a similar picture as the paper, but the details are different, because we 
used a simpler approach to estimate the toroid diameter, whereas the authors of the 
paper used a more accurate method to measure the toroid diameter.