Presentation is available at

https://downloads.openmicroscopy.org/presentations/2018/Users-Meeting/Workshops/Metadata

-Analysis/slides/index.html

This is the second part of the three parts Metadata workshop held at the Annual Users meeting:

Part 1
https://downloads.openmicroscopy.org/presentations/2018/Users-Meeting/\Workshops/M

etadata-Import/import.pdf

Part 3
https://downloads.openmicroscopy.org/presentations/2018/Users-Meeting/\Workshops/M

etadata-Handling/handling.pdf

Raw Data Analysis

Description

In the second part, we show how to analyze a batch of images stored in OMERO using the
scripting facility in Fiji, the results of the analysis will be stored as an OMERO.table, then
analyze the images using an OMERO script server-side, the results will this time be stored as a

map annotation.

The user analyzing the data needs to have admin privileges.

More information about restricted privileges can be found at
https://docs.openmicroscopy.org/latest/omero/sysadmins/restricted-admins.html.

Setup

Fiji has been installed on the local machine with the OMERO.insight-ij plugin. The
installation instructions can be found at
http://help.openmicroscopy.org/imagej.html#plugins.

Installing the OMERO.plugin also adds the dependencies required to connect to
OMERO using the Script Editor of Fiji.

The OMERO.script
https://github.com/ome/training-scripts/blob/v0.1.0/practical/python/server/batch_roi_exp
ort_to_table.py has been uploaded to the server.

Fiji Manual workflow

1.
2.

Launch Fiji.
To open an image stored in OMERO, Go to Plugins > OMERO > Connect To OMERO.
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3. In the OMERO login dialog, click the wrench icon > and then add the server address in
the dialog i.e. outreach.openmicroscopy.org. Click Apply.
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Enter your Username and Password and click Login.
Browse to Project idr0021, open any Dataset and double-click once on an Image to
open it in Fiji. Bio-Formats is used to view the Image.

a. Make sure to select View stack with: Hyperstack in the Bio-Formats Import

Options dialog.

b. Note that each plane will be transferred from the server to the client machine so

this may take a few moments.

To open the recorder, go Plugins > Macros > Record..., select JavaScript to record the
actions. The steps will then be used in the Scripting workflow below.
Convert floating-point pixel-type to 8-bit using Image > Type > 8-bit.
Go to Image > Adjust > Auto Threshold, to open the Auto Threshold dialog:
a. Select MaxEntropy for the Method parameter.

b. Check the checkbox Stack.



@ Auto Threshold

Auto Threshold v1.16.4

Method = MaxEntro B
i ﬁ @ @ Centrin_ PCNT_Cep215_201...
1/3 (c:1/3 - Centrin_PCNT_Cep215_2011

Ignore black Ignore white
White objects on black background
SetThreshold instead of Threshold (single images)
Show threshold values in log window
Stack
Use stack histogram a-

The thresholded result of 8 & 16 bit images is shown
in white [255] in 8 bits.

For 16 bit images, results of 'Try all' and single slices
of a stack are shown in white [65535] in 16 bits.
Unsuccessfully thresholded images are left unchanged.

Cancel OK
9. =
10. Click OK.
11. Then open Analyze > Analyze Particles....
12. In the dialog
a. Set Size to 10-Infinity and check Pixel units.
b. Check the following checkboxes:
i.  Display results
ii.  Clear results
iii. ~ Add to Manager
c. Click OK then Yes in the popup dialog indicating asking to Process all 3 images?.
[ ] Analyze Particles l

r

Size (micronA2): 10-Infinity
Pixel units

Circularity: 0.00-1.00

Show: Nothing ﬁ
|
Display results Exclude on edges :
Clear results Include holes
Summarize Record starts
Add to Manager In situ Show
Help Cancel OK
13.. J

14. To save the thresholded image back to OMERO with the generated ROls and the
measurements:
a. select Plugins > OMEROQO > Save Image(s) to OMERO.
b. Create a New Dataset for the image



i.  Click New... button next to the selection box on the Dataset row.
ii. Inthe dialog that pops up, enter a name and description (optional).
iii. Click Create.
c. The newly created dataset will automatically be selected.
d. Click Add to the Queue then Import.
e. Go to OMERO.web and check that the measurements have been saved in a
CSV file and attached to the images. The attachment can then be downloaded at
any time.

Fiji Scripting workflow
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We will now repeat the manual analysis on a Dataset using the scripting facility available
in Fiji.

Go to http://outreach.openmicroscopy.org/.

Log in

Select the Project idr0021 and first Dataset CDK5RAP2-C.

Note its ID on the right-hand panel, it will be used below.

Launch Fiji. (relaunch if opened).

Go to File > New > Script....

A dialog pops up. In the Language menu select Python.

Copy the content of the script
https://github.com/ome/training-scripts/blob/v0.1.0/practical/jython/analyse_particles_for

another_user.jy into the text editor.

10. Edit the following parameters: dataset_id, USERNAME, PASSWORD.

‘200 *New_.py (Running)
File Edit Language Templates Run Tools Tabs |

*New_.py

62 # Setup

63 #f =====

| »

64

65 # OMERO Server details

66 HOST = "outreach.openmicroscopy.org”
67 PORT = 4064

68 group_id = “-1"

69 # parameters to edit

70 dataset_id = "1@22"

71 USERNAME = "username"

72 PASSWORD = "passwhrd"

73

74 def open_image_plus (HOST, USERNAME, PASSWORD, PORT, group_id, image_id):
75 "Open the image using the Bio-Formats Importer®

options = ""
78 options += "location=[OMERO] open=[omero:server="
79 options += HOST
: options += "\nuser="
options += USERNAME o
options += "\nport=" -
Gl | Show Errors Clear
Started Hew_.py at Thu Nov 30 11:28:33 GMT 2017 -
2732 2=
P-TRE 10 _R3D D3D.dv.ome.tiff
uploading. ..
imported
2733 L
P-TRE 11 R3D D3D.dv.ome.tiff
uploading. ..
imported

Done
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11. Click Run.


http://outreach.openmicroscopy.org/
https://github.com/ome/training-scripts/blob/master/practical/jython/analyse_particles_for_another_user.jy
https://github.com/ome/training-scripts/blob/master/practical/jython/analyse_particles_for_another_user.jy

12. The script will process all Images in the specified Dataset, applying threshold, analyzing

particles and saving ROls back to the Images in OMERO i.e. we reproduce in a script
the manual steps recorded above.

Inspecting and exporting ROIs in OMERO.iviewer

1.
2.

10.

11

Return to OMERO.web and open an Image from this Dataset in OMERO.iviewer.
Click the ROls tab to see the added ROIls. Note that the ROIs have been assigned a
Channel index to indicate which Channel they were derived from.

In the Settings tab, turning channels on/off will also show/hide ROls assigned to those
channels.

On the left-hand side in OMERO.iviewer, double-click on the image currently opened.
This will switch to the multi-view mode.

Turn the Red channel on for the first image, and the Green for the second one.

Lock the windows by clicking on the lock icon . Zoom in and out.

Try opening multiple viewers and browsing through a Dataset. Then close all but the first
image to return to the single view mode.

Go to the Info tab and note the link indicating that the image can be opened with
Polygons and Polylines in OMERO..figure.

In the Info tab, note the name of the Dataset. The Channel with the same name is the
one we want to analyze for this image.

Turn on just this Channel (channel 3 for CDK5SRAP2-C Dataset).

. Select all ROIs either from the right-hand pane table or selecting them in the view.
12.

In the header, go to ROIs > Export (CSV). Download the output and open it in Excel to
show data for ROI shapes.

Analysis workflow Server side

1.

We will now analyse ROIs created on the Images above, getting the pixel intensity and
area (points) of ROIs and creating a summary of the ROIs on each image.

Go to http://outreach.openmicroscopy.org/ and login.

Select Project idr0021 and first Dataset CDK5RAP2-C.

Click the Script button in the top-right of the pagen.

Under omero > export_scripts > Batch_ROI_Export... we can see a new script released
with OMERO 5.4.6 to export ROIs from multiple images.

We will use a customised version of this script.

In the script menu, go back... to the top of the menu, then select users_meeting > batch
roi export to table....

In the dialog that pops up, click on View Script to view the Python code.

Search for “idr” to find the code block that selects the filter_channel based on Dataset
and Channel names.


http://outreach.openmicroscopy.org/

10. Scroll to the bottom of the script to see where the input parameters are defined, such as

Data_Type and IDs. Notice how these appear in the script dialog and are auto-populated
with the currently-selected Datasets or Images.
61 (0] RAun Batch ROI Export.py

@ localhost:4080/webclient/script_ui/108099/7Dataset=25

e ||

Batch ROl Export.py

Export ROI intensities for selected Images.
Authors: William Moore, OME Team
Contact: ome-users@lists.openmicroscopy.org.uk

Data Type: " Dataset ﬁ
IDs: *@ 25008
Filter Shapes By Channel:
Channels: @ 1254
Export All Planes:”
Export CSV: &
File Name: roi_intensities.csv

Save As Key-Value:@

Create Table: @ |
11 View Script Cancel| Run Seript | |
12. The script will process all the Images in the selected Dataset and data can be:
a. Exported as CSV file, with one table row per Shape/Channel.
b. Added as Key-Value pairs (Map Annotations) to Images. ROIs summarised as
min/max/mean per Image.
c. Added as an OMERO Table to the parent Project, with one row per Image.
13. Uncheck the Create Table option, since we have previously created a Table by running
this script on ALL the Datasets in the idr0021 Project.
14. Click Run Script.
15. The status of the processing is displayed in the Activities dialog E
16. When the script has completed, it will show in the the Activities dialog and allow you to
download the CSV file. Download this and open in e.g. Excel to see the output data for
all the shapes.
17. You will also be able to view the Key-Value Pairs (Map Annotations) in the right-hand
panel of each Image that summarise all the ROls on each image.
Notebook R

For this section, we will use a notebook since the setup is a bit more complex. It is necessary to
install several dependencies. We use JupyterLab, a dedicated computational environment.

In the following example, we will generate a plot in R and some basic statistics from the output
of the batch roi export to table script. The plot will be uploaded back to OMERO.

1.
2.
3.

Go to https://idr-analysis.openmicroscopy.org/training/hub/tmplogin
In the Files > notebooks > R folder, select the notebook idr0021_rois.ipynb.
Set the ‘username’ and ‘password’ in the first code cell.



https://idr-analysis.openmicroscopy.org/training/hub/tmplogin

4. Use the play button to move through the cells (for code cells wait until the * changes to a
number, i.e. the execution finished).

5. Run the first code cell to connect to the server.

6. The first step is to find the idr0021 project, the attached table and load the image and
max_points data directly as R dataframe. (Right-click -> Enable Scrolling for output, to
collapse the long output)

7. Prepare the R dataframe: Reformat the image column to only contain the image ID.
Iterate through the datasets to get the Image <-> Protein (dataset name) relation.
Estimate the toroid parameter from the area (max_points).

8. Then plot the data. First the datasets (Proteins) are ordered from lowest to highest mean
diameter (to match the figure in the paper).

9. Check if there is a significant difference between the Proteins with respect to the toroid
diameter. This is done as one-way analysis of variance. The value of 2e-16 indicates
that there is a difference. One-way analysis of variance is questionable because it
assumes normal distributed data and similar variances between the groups (this is not
given, see plot). Therefore also do a ‘Mann-Whitney’ test to check the differences
between each possible pairwise combination of Proteins. -> There is a significant
difference between most of the groups, not for some of the groups (e. g. CDKS5RAP2-C
vs CEP192-M vs TUBG1-N , which can be seen on the plot as well).

The results show a similar picture as the paper, but the details are different, because we
used a simpler approach to estimate the toroid diameter, whereas the authors of the
paper used a more accurate method to measure the toroid diameter.

10. Finally the plot and results are saved back to OMERO and attached to the dataset.



