
 

 

OMERO overview: View, Annotate, Measure, Create Figure 

 

Description 

We will demonstrate a number of features of the OMERO platform using an OMERO server based in 

Dundee, U.K. You can connect to the same server using login details provided to try the software for 

yourselves. 

Browsing and Viewing Images 

For this workshop, images have already been imported into OMERO. The import instructions can be 

found at http://help.openmicroscopy.org/importing-data-5.html 

1. Log in to the webclient at http://outreach.openmicroscopy.org with the Username and 

Password provided.  

2. You can browse the hierarchy of Projects (blue) > Datasets (green) > Images in the left-

hand pane. Selecting a Dataset will show images in the centre pane. 

3. OMERO can handle images of many different file formats and sizes using Bio-Formats. In 

the Dataset SVS there are images of size 96999 x 45667 pixels. We will use smaller 

timelapse images for this workflow. 

4. Open the Dataset named Condensation. 

5. Select images to view details in the right-hand pane. Image metadata such as width, height, 

number of Z sections or Timepoints, Channels and Pixel size is shown here. 

 
6. Channel names in the right-hand pane

 can be edited by clicking on the 

pencil icon and the new name can be saved for all images in the Dataset. 

http://help.openmicroscopy.org/importing-data-5.html
http://outreach.openmicroscopy.org/


   

 

 

7. The Preview tab at the top-right of the page will show a small image viewer.

 

8. Play the video by clicking the arrow in the box  to the right-hand side of the T slidebar 

under the image viewer. In this way, you will be able to see whether or not there is a mitotic 

event in this particular image. You can select another image thumbnail in the central pane 

and continue playing the quick videos (eventually for the whole Dataset). 

9. The image rendering settings can also be adjusted, such as turning channels on and off, 

adjusting levels and channel colors.

 
10. Saving the settings does not change the original pixel data for the image. 

11. Click the Save to All  button to apply the current settings to all other images in 

the Dataset. 



   

 

 

12. In the left-hand pane tree, right-click on the Dataset  Condensation and choose Rendering 

Settings > Set Imported and Save to revert to the original settings.

 

13. Double-click on an image thumbnail, or click the Full Viewer button in the right-

hand pane to open an image in a larger viewer (called OMERO.iviewer). 

 

14. We can adjust the rendering settings and scroll through T and Z if it is a Z-stack image. 

15. Click the Crosshairs icon  at the top right of the viewer to enable pixel intensity display 

for the mouse pointer. Then mouse over the image to see pixel intensities for enabled 

channels. 



   

 

 

16.  

17. The ROIs tab includes tools for viewing and drawing ROIs on the Image. 

These are saved back to the OMERO server. Select the arrow tool in the right-hand pane 

 and draw an arrow on the image, using Click-Release-Drag, pointing to a feature in 

the image, which will be later used by OMERO.figure and save it using the Save button

 located in the upper part of the right-hand pane. Draw also a couple of other ROIs 

on different T planes. 

18. Clicking onto the ROIs in the right-hand pane table brings the viewport to the position 

where the selected ROI is in the middle of it and navigates the viewport to the timepoint the 

ROI is associated with.  

19.  
20. Save the viewport by selecting in the top-left corner File > Save Viewport as PNG 

21. Compare the two channels of one of the images in multi-image view. Double-click on the 

thumbnail of the already opened image in the left-hand pane of the viewer. This will open 

the image again in a new window. Select one of the windows and in the right-hand pane 

switch the green channel off.  



   

 

 

 

22. We can synchronize the viewers by adding them both to the same sync Group. Click the 

sync icon  in the top-left corner and select the first option in the dropdown menu. 

Repeat for the other viewer. Now both images have the Z, T and View (zoom and position 

of viewport) synchronized . 

23. Select the red channel image (DNA staining) and play the timelapse by clicking onto the 

arrow at the bottom of the image window. After you have identified a mitotic cell, zoom in 

onto it by scrolling the mousewheel or expand the cog icon in the top bar of the window and 

click on plus sign. Pan the viewport so that the mitotic cell is in the centre. The green 

channel (nuclear envelope staining) window will mimic all the actions as well. 

24.  
Use Tags to earmark images for analysis/publication 



   

 

 

25. Go back to the webclient. We want to find the image A1.pattern1.tif. Select the Dataset 

Condensation again and in the Add filter menu above the centre pane 

select Name to filter by name. Then type into the box A1.pattern1 

.This should filter out all the 

thumbnails in the centre pane except one. Note: the A1.pattern1.tif timelapse has a mitotic 

cell, which seems to undergo apoptosis as well. 

26. Select the A1.pattern1.tif image and select the General tab. Expand the Tags harmonica in 

the right-hand pane.  

27. A tag named Mitosis was added prior to this workshop to 6 images. These 6 images, which 

include A1.pattern1.tif, will be used later in the  Analysis with Fiji: Scripted workflow (see 

below). 

28. Click on the plus icon. In the Tag Selection window select an existing tag Apoptosis. Click 

on the arrow  to move the tag into the Selected Tags area. If desired, new tags can be 

created using the Add a new tag… dialog  at the 

bottom of the Tag Selection window. Enter name of the tag to create and click Add button 

to the right. 

29. Click Save button  in the bottom-right corner. 

30. Clear the text of the Name filter text to show all images. 

31. Choose to Filter by Tag and select the Mitosis Tag to show images that we will analyse in 

the next step. 

Analysis with ImageJ/Fiji: Manual workflow (not presented, for information only) 

32. We will not demonstrate this manual workflow, this chapter is just for information, to show 

the same steps that will be performed by the scripted analysis. Please go to the section 

below Analysis with Fiji: Scripted workflow (demo only) if you want to follow the 

demonstration.  

33. In this Manual workflow paragraph ImageJ/Fiji, connecting to OMERO, to analyse images. 

Instructions on how to install the OMERO plugin for ImageJ can be found at 

http://help.openmicroscopy.org/imagej.html but we are unlikely to have time to install this 

for all users during this workshop. 

34. Go to Plugins > OMERO > Connect To OMERO. This will show a login screen where you 

can enter the name of the server to connect to, the username and password. The OMERO 

plugin will allow you to browse your data in a similar manner to the webclient and open 

images by double-clicking. 

35. We will analyse cells by thresholding and segmenting the image. Go to Image > Adjust > 

Threshold. 

36. The Threshold dialog will pop up, click Apply.  

http://help.openmicroscopy.org/imagej.html


   

 

 

37. Another window Convert Stack to Binary will pop up. 

38. Select the following parameters: 

a. Method: Default, Background: Light and Calculate threshold for each Image. 

b. Click OK.  

c. Close the Threshold dialog if you want. 

39.  
40. Select Analyze > Analyze Particles 

41. In the Analyze Particles dialog, select the following parameters 

a. with Size: 50-infinity 

b. Show: Outlines 

c. Check: Display results, and Add to Manager.  

42. Click OK. 

43.  
44. A dialog pops up asking to Process all 46 images? Click Yes. 

45. ROIs and Results table will be generated. 

46. Go to Plugins > OMERO > Save ROIs to OMERO to save these ROIs to the Image in 

OMERO. 

Analysis with Fiji: Scripted workflow (demo only) 

47. We will use a script in the Jython language to perform the same processing steps as above, 

including saving of ROIs to OMERO. This will analyse images within a Dataset that are 

tagged with a specified Tag. The tag Mitosis will be used which was added to 6 images in 

previous steps above. 



   

 

 

48. Setup: Just for your information, the script used here also needs the OMERO plugin for 

ImageJ/Fiji. Instructions on how to install the OMERO plugin for ImageJ/Fiji can be found at 

http://help.openmicroscopy.org/imagej.html but we are unlikely to have time to install this 

for all users during this workshop. 

49. In Fiji, go to File > New > Script. 

50. A dialog pops up. In the Language menu select Python. 

51. Copy the content of the script https://github.com/jburel/omero-example-

scripts/blob/cambridge-training/jython_scripts/analyse_particles_from_dataset.py  into 

the text editor. 

52. Edit the following parameters: dataset_id, tag_text, USERNAME, PASSWORD. 

53. Click Run. 

54. Back in the webclient, open one of the images tagged with Mitosis so that you can see the 

ROIs generated in Fiji saved to OMERO.  

55. Each of the ROIs created by the script in Fiji are associated to a certain T and Channel, 

which can be seen in OMERO.iviewer. 

56. Finally, we can export the pixel intensity for ROIs using iviewer. Select the ROIs to export 

using Shift-click to select a range of ROIs in the table. Then ROIs > Export (CSV). 

57.  
Adding Annotations, Filtering and Searching 

58. Return to the main webclient. 

59. We can add annotations to images in the right-hand pane General tab. 

60. Select one or more images from Dataset Condensation and click the harmonica Key-Value 

Pairs in the right-hand pane.  

http://help.openmicroscopy.org/imagej.html
https://github.com/jburel/omero-example-scripts/blob/cambridge-training/jython_scripts/analyse_particles_from_dataset.py
https://github.com/jburel/omero-example-scripts/blob/cambridge-training/jython_scripts/analyse_particles_from_dataset.py


   

 

 

61. You should see a table or tables, depending on the number of selected images:

 
62. The Key-Value Pairs allow you to add lab-book like additional metadata for the image. 

These Key-Value Pairs are also specifically searchable. 

63. Type mitomycin-A into the search box in the top right of the weblicent 

  and press Enter. 

64. The search results will show any objects e.g. images or datasets which have anywhere the 

string mitomycin-A. 32 images should be found. 

65.  Refine the search now for only Key-Value Pairs which have the key mitomycin-A and value 

0mM by typing mitomycin-A:0mM into the search box and pressing enter. Now you should 

find only 10 images. Click on the Browse link in one search result line, (in the right-

hand part of the centre pane) to navigate back to the main webclient. 

66. Images can be filtered by Tag or Rating in the centre pane, using the Add filter chooser 

above the thumbnails,.  

67. Choose the Tag option and then choose the Mitosis from the list of tags. As mentioned 

already, the Mitosis tag was added to 6 images before this workshop. 

68. Review the filtered images, choose a favourite image and under the Rating section in the 

right-hand pane, click on the 5th star to add a rating of 5 

69.  
70. Repeat this to add a rating of 5 to the Apoptosis-tagged image. 

71. Now we can remove the filtering by Tag and instead filter by Rating of 5 to show only our 

favourite images.  

Creating a Figure 

72. Select these 2 images and use the context menu on the images in the left-hand side tree to 

Open With > OMERO.figure. This will open the OMERO.figure app in a new tab. 

73. Select panels by clicking or dragging a select region. Arrange panels by dragging and 

resizing them. 

74. Duplicate both panels by selecting them, Edit > Copy and Paste, or use keyboard shortcuts. 

75. Use the Align > Width & Height toolbar to ensure selected panels are all the same size.  



   

 

 

76.  

77. Arrange the 4 panels in a single column and snap selected panels to a grid with the  

button. 

78. In the Preview panel you can adjust the Time position and the rendering settings of selected 

panels. 

79. Toggle channels on and off to show a ‘split-view’ of each image. 

80.  
81. Select all 4 panels, set the T-position to the start of Mitosis, e.g. position 8 (~35 minutes). 

Copy and Paste to create a new column. 

82. With these new panels still selected, increment T by clicking the > button one or more times. 

83. Copy, Paste and increment T-index two or three more times to create a timelapse figure. 

84. Select the lower panels for the second image and use the Down Arrow key to nudge them 

down to create a space between them and the upper panels. 

85. With ALL panels selected, use the Zoom slider to zoom in to approximately 200%. 

86. Then select all the upper panels and in the Preview panel pan the image to show the cell of 

interest. Repeat for all the lower panels. 



   

 

 

87.  
88. Click on the Labels tab to add a scalebar and labels to selected images. 

89. Select one of the Apoptosis images that we previously edited in OMERO.iviewer and click 

the Edit button under the ROIs section.  

90. In the Edit ROIs dialog you can draw shapes on the Image using the toolbar buttons. 

Instead, we will click Load ROIs to retrieve ROIs from OMERO (if we have saved some on 

this image) 

91.  
92. A list of ROIs will be displayed. N.B.: Polygons and Polylines are not yet supported in 

OMERO.figure, but will be supported in the next release. 

93. Clicking on each row of the list will show the image plane that the shape is saved on. 

Clicking the Add button will add the shape to the image. Click OK to close. 



   

 

 

94. Use Shift-click to select just two panels (the last red panel for each image). Under the 

Scalebar section, click on Show to display a scalebar created from the pixel-size metadata 

for each image. 

95. Change the scalebar length to 20 μm and check the Label checkbox to show a label. 

96. In the Add Labels form, the drop-down list of the text input field can be used to create labels 

from existing image metadata such as timestamps, channel names or tags. 

97. Alternatively you can manually enter label text. 

98. Select 4 images in the first column of the figure. From the Add Labels drop-down list, 

choose Channels, select Left Vertical from the label position chooser and click Add. 

99.  
100. Select all the image panels showing the Green channel, using Shift-drag selection. 

Choose [time-mins] in the Add Labels input, Top right position and color: white. Click Add. 

101. Finally, select the two Green images in the first column and add labels from Tags 

metadata to the Top position of each panel. This will create labels for Mitosis and 

Apoptosis. N.B.: if unwanted labels are created from tags, they can be removed or edited in 

the Edit Labels section 

102.  
103. Save the figure and check that the URL updates to a new URL for this figure which 

can be shared with colleagues. File > Open can be used to open your own figures or those 

of colleagues. 

104. Click Export PDF and when complete, click the Download button. Open the 

downloaded pdf in any suitable program and find the second page of the pdf. Click on the 

link to the image and see that you are navigated back to OMERO in your browser and the 

appropriate image, which was used in the Figure, is highlighted. 
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