
 

Presentation is available at 
http://downloads.openmicroscopy.org/presentations/2017/Cambridge-Training/Day1-Cambridge
2017-Introduction.pdf 
 

Workflow 1 
 

Description 

Determine protein staining intensities and distances in mitotic apparatus in z-stack intensity images, 
which were stained for the inner-centromere protein INCENP, and compare the results qualitatively 
and quantitatively. Share the results with colleagues using quick visualisation in OMERO.figure. 

Setup 

For this workshop, images have already been imported into OMERO. The import instructions can be 
found at http://help.openmicroscopy.org/importing-data-5.html 

1. Login to the webclient at http://outreach.openmicroscopy.org with the Username and 
Password provided. Browse hierarchy of Project “images” and Dataset “siRNAi-HeLa” to 
find images. 

2. Several control images in the Dataset have "scram" in their name. Other images are named 
with siRNAi targets “IN” for INCENP and other names for minor INCENP variants. 

3. Zoom the thumbnails (using the slider below thumbnails) and select multiple images that 
appear to be in Metaphase (one or two single lines appear in each cell on the image as 
opposed to one or several round blobs, see screenshot below for the pre-selected images 
in rows 2 and 3). Use Shift+click or Ctrl+click to multi-select the thumbnails. 

4.  

5. In the right-hand panel, expand the Tags pane and click to add tags to all the selected 
images. 

 

http://downloads.openmicroscopy.org/presentations/2017/Cambridge-Training/Day1-Cambridge2017-Introduction.pdf
http://downloads.openmicroscopy.org/presentations/2017/Cambridge-Training/Day1-Cambridge2017-Introduction.pdf
http://help.openmicroscopy.org/importing-data-5.html
http://outreach.openmicroscopy.org/
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6. In the “Tags Selection” dialog, you can select available Tags from the list on the left 

(filtering if needed). Find the “Metaphase” Tag and click on the button  to move it into 
the right-hand list then click “Save”. 

7. Add another Tag to the selected images: This time, create a new tag that is likely unique to 
you (see bottom left of Tag dialog) e.g. could be the name of your favourite gene or simply 
“Bob likes this”. 

8. Click the newly-added Metaphase Tag:  in the right-hand panel. This will 
browse by Tags to show all Images with this Tag, be those your images or images of your 
colleagues. NB: notice at the top-left of the page that we are now browing data belonging to 
Trainer-1, the owner of the Metaphase tag. 

9. Click on Tag Search:  link at the top of the webclient. Start typing tag names to 

search for data by tag:   .  
10. First start typing "Metaphase", then add your own tag to filter by both tags. Filtering by your 

unique tag will remove the images of your colleagues from the results of the Tag Search, 
highlighting only your own images. 

11. Click Browse:  for one of the images in the table to return to the Dataset. 
12. Above the thumbnails, click Add Filter > Name and enter “scram” to filter for all control 

images in this RNAi experiment. 
13. Select an image, click the Preview tab of the right panel and Turn off channels 1 and 4. 
14. Adjust the intensity levels of the green channel which is INCENP, and channel 3 which is 

Aurora-B. Use Histogram feature:   to help you with the adjustments. 
We want to compare levels of these targets across all images in the Dataset. Click Save to 
All.  

15. Thumbnails will be updated with new rendering settings, allowing comparison across the 
Dataset. Thumbnails can be zoomed using the slider below. 

16. In the left panel hierarchy, right-click on the siRNAi-HeLa Dataset and choose Rendering 
Settings… > Set Imported and Save to return to original settings. 

17. Filter images by Name “VRAQ D3D” and select the first image “VRAQ_01.r3d_D3D.dv”.  
18. In the General tab of the right-hand panel, expand the Ratings panel and click the stars to 

give this image a rating of 5. 
19. Filter images by Name “IN 02 D3D”, select the first image “IN_02.r3d_D3D.dv” and add a 

rating of 5. 
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Session 2 

20. Now, clear the filtering by Name and instead, filter images by Rating of 5 to show only the 2 
images we have just rated. 

21. Select both images, right click on the selected images in the tree and choose Open with... > 

OMERO.iviewer. You can also find the Open with option at the top of the right panel  . 
22. In iviewer, we want to measure distance between Centromeres, stained with ACA in the 4th 

Channel. Turn on ONLY the 4th channel and open the ROIs tab to the right. 
23. Try to identify centromere pairs, select the Line tool and draw a line between the centres of 

the centromeres. In the ROIs table, in the Comments column, click the 3 dots in the column 
header and choose to Show Area/Length. 

24.  
25. Click Save to Save ROIs. 
26. You can also use Z-Projection which might help find outlying centromeres. 
27. Once done with drawing ROIs, click Save again. 

28. Click on the Select tool:   
29. To export statistics, we first need to select all the ROIs using Cmd-drag to select a region in 

the viewer (if ROIs are spread across multiple Z-sections, we can show them all at once 
using Z-projection). The selected ROIs will be highlighted blue on the image. 

30. To export lengths and intensities of ONLY the 3rd channel (Aurora-B) turn on only this 
channel on the Settings tab of the right-hand pane 

31. Check the Pixel Intensity checkbox. 
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32. Right-click on selected ROIs in the viewer and choose Export Roi Measurements (Excel). 
33. Open the downloaded table in Excel or similar tool to see the lengths and intensity 

measurements for the ROIs. 
34. We want to check alignment of the metaphase plate in a 3D viewer. The FPBioImage 

viewer will use the saved rendering settings. Still in OMERO.iviewer, turn on just channels 
2 and 4, adjusting levels if needed, and Save the rendering settings (do this one-by-one on 
the two images you have loaded in OMERO.iviewer). 

35. Back in the webclient window, select these images (but do this one image at a time) in the 
tree (left-hand panel), right-click on Open with… > FPBioImage. Click Start in the new 
viewer window. 

36. We can see that the centromeres are well aligned on the metaphase plate on the “VRAQ…” 
image, whereas the centromeres are located in and around the spheroid on the “IN…” 
image. 

37.  
38. Again, select both 5-rated images in the webclient, right-click and select Open with… -> 

OMERO.figure. 
39. Drag the images to place one above the other, select both and click the Grid layout button

. Resize to make the figure smaller. Copy both images and paste twice to make a 
grid with 2 rows with 3 columns. 

40. Select both panels from each column in turn and toggle on a different channel for each 
column. Adjust Z index and try Z-projections (see screenshot on next page). 
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41.  
42. Select the 2 panels in the left column, click on the Labels tab in the right panel and under 

Add Labels choose [image-name] from the drop-down menu. Click on the position chooser 
and choose Left from the options. Click Add. 

43.  
44. Save the figure and see that the URL updates to a new URL for this figure which can be 

shared with colleagues. File > Open can be used to open your own figures or those of 
colleagues. 

45. Click Export PDF and then when complete, click the Download button. Open the 
downloaded pdf in any suitable program and find the second page of the pdf. Click on the 
link to the image and see that you are navigated back to OMERO in your browser and the 
appropriate image, which was used in the Figure, is highlighted. 

46. Click File > Open, then click on Owner button to select a figure of other users 
(your colleagues). Select and open other users’ figures and study them. 

47. With another user’s figure open, select File > Save a Copy to save your own copy of your 
colleague’s figure. Note that you cannot directly save changes on their figure. 

48.  OMERO.Figure will be revisited in the afternoon in Workflow 2. 
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Workflow 2  
 

Session 3: Description 

Manual analysis of OMERO images using Fiji 

Setup 

For this workshop, Fiji has already been installed with the OMERO.insight-ij plugin. The installation 
instructions can be found at http://help.openmicroscopy.org/imagej.html#plugins 

1. Login to webclient as before. 
2. Search for mitomycin-A in the Search field at the top right of webclient. This should find six 

images. To search for key-value pairs, we can use the search string key: value. To narrow 
down the search, search again for mitomycin-A:0mM This should find just the 
“C4.pattern.tif”  image in the Dataset “chromatin-condensation” containing six timelapse 
images. Click on Browse to get back to this image in webclient.  

3. Adjust channel names: Click on the pen:   icon in the right-hand pane next to Channels. 
Input “Cy3” (instead of channel “0”)  and “eGFP” (instead of channel “1”). Click “Apply to all” 

button:   and confirm by clicking Continue. 
4. Open the “C4.pattern.tif” Image with OMERO.iviewer, use the Time-slider below the image 

to move through time and play the video. 
5. Start the Fiji app and use the OMERO plugin to browse data in OMERO i.e. Plugins > 

OMERO > Connect To OMERO 

6. In the OMERO login dialog, click the wrench icon  and then add the server address 
(outreach.openmicroscopy.org) in the dialog. Click Apply.

 
7. Find and open the same image from above “C4.pattern.tif” from Dataset 

“chromatin-condensation” (double-click on the thumbnail). 

http://help.openmicroscopy.org/imagej.html#plugins
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8. Select Image > Adjust > Threshold 
9. The Threshold dialog will pop up, click Apply.  
10. Another window Convert Stack to Binary will pop up 
11. Select the following parameters: 

a. Method: Default, Background: Light and Calculate threshold for each Image 
b. Click OK.  
c. Close the Threshold dialog if you want 

 

12. Select Analyze > Analyze Particles 
13. In the Analyze Particles dialog, select the following parameters 

a. with Size: 50-infinity 
b. Show: Outlines 
c. Check: Display results, Clear results, Summarize and Add to Manager.  

14. Click OK. 

15.  
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16. A dialog pops up asking to Process all 46 images? Click Yes 
17. ROIs, Results table, and the mask timelapse with outlines will be generated.  

18.  
19. Select the Results table and Menu Results > Distribution > OK 
20. To Import images to OMERO, select: Plugins > OMERO > Save Image(s) to OMERO.  
21. In the selection dialog, Choose Project and Dataset (You can click on New button to create 

new Project and Dataset or import into existing ones). Check Add Images from all image 
windows. Click Add to Queue then Import. 

22.  



  8 
 

23.  
24. In Fiji, select the original image showing ROIs. Plugins > OMERO > Save ROIs to OMERO.  
25. We want to Save ROI and Measurements, which will attach the results as a CSV 

attachment (to open for example in Excel) to the image in OMERO.  
26. Enter a File Name and click Save (Note: There is also a manual workflow which you could 

have used to attach the Excel sheets resulting from Workflow1 to OMERO.) 

27. .   
28. Return to the webclient and open the original image in OMERO.iviewer and inspect the 

newly created ROIs. Notice that you have ROIs for each channel on all timeplanes.  
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Session 4 - OMERO.figure 

1. Select the original C4.pattern.tif image, the ROIs image and distribution plot. Click on Open 
with… OMERO.figure. 

2. Copy and paste the original image using the Edit menu or keyboard shortcuts to duplicate it. 
3. Adjust the rendering settings in this image in the right panel, to turn off the Green channel 

and enhance the Red. 
4. Arrange these 2 images in a column with the ROIs image below, resizing as needed. 

5.  
6. Select the 3 panels and use the Align > Width & Height toolbar to ensure these panels are 

all the same size.  

7.    
8. Then click the Grid layout button in the same toolbar to snap the panels to a grid. 
9. Copy the 3 panels and paste several times to create 3 new columns of 3 panels. 
10. Select just the upper 2 image panels from each new column in turn and in the right panel, 

drag the T-slider to set the time to index, e.g. 5 (20 mins), then 6 (25 mins) then 9 (40 
mins). 

11.  
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12. NB: the ROIs image is actually a Z-stack so we have to choose the frame using the 
Z-slider. There are 46 planes in the Z stack, from 2 channels x 23 time points. To pick 
time-frames that correspond to the 4 images above, set the Z-index for the 4 ROI images to 
1, 9, 11 and 17 respectively. 

13. Select all the 12 panels in the grid and use the Zoom slider to zoom in. 
14. Pan the images by dragging in the right-hand panel Preview image. 

15.  
16. Select just the first row of images, click on the Labels tab in the right-hand panel. Under 

Add Labels choose Time (hrs:mins:secs) from the drop-down menu. Choose label color 
(white), position (top-left) and font-size (12) then click Add.

 
17. Click Save to save your figure. 
18. To export your figure as PDF, click the Export PDF button at the top-right of the screen and 

wait for the PDF to be created on the server and the Download button to appear. Click to 
download the PDF and import to a PDF editor. You can post-process the PDF in Inkscape 
or Adobe Illustrator/Photoshop for example. 

 

 


