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What is Imaged? (& what is Fiji?)

Image Analysis with ImageJ

Imaged with OMERO



What is Imaged?

o Atool for scientific image analysis
o Free, Open Source software

o Rich ecosystem: thousands of plugins

o Easy to extend and easy to contribute; large community



The main ImagedJ window
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File Edit Image Process  Analyze Plugins Window Help|

Tools |8 Q||| ~<| £ | AN |A|Q @] |®
Image] 1.43mjJava 1.6.0_16 [22-bit] (616 commands, 27 macros)
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Fiji Is Just ImageJ

o Based on ImageJ
o Comes with plugins useful for the Life Sciences
o Has an updater and many optional update sites

o Has additional developer features (easier to write scripts,

develop new plugins)



Help: finding commands & updates

8 Fiji File Edit Image Process Analyze Plugins Window BGLL:

e 00 (Fiji Is Just) Image) :
— ' Image) Website...
B OIC|O| A& | 4N |A| QO Pjswjur] /] 4 | \mage) News...

ext tool (double-click to configure) Documentation...

Installation...

ommand Finder
AAA8 - Mailing List...
Search: |
Command Menu Path Class File Dev. Resources...
Load Particles (.tif file - fast) File>Import>QuickPALM QuickPALM.Load_particles_table... /Applic... ,
Open VirtualStack File>Import> QuickPALM QuickPALM.Run_MyMacro("Fast_... /Applic... P“"gms"'
Save Particles (.tif file - fast) File>Import>QuickPALM QuickPALM.Save_particles_table... /Applic... Macros...
*recent commands Plugins> Shortcuts fiji.util.LRecent_Commands .
/Users/pwalczysko/Desktop/Ba... File>0Open Recent Macro Functions...
/Users/pwalczysko/Desktop/Sc... File>Open Recent Examples >
/Users/pwalczysko/Downloads/... File>Open Recent
/Users /pwalczysko/Downloads/... File>Open Recent Update Image)...

/Users/pwalczysko/Downloads/... File>Open Recent

/Users/pwalczysko/Downloads/... File>Open Recent Refresh Menus

16 colors Image>Lookup Tables
16-bit Image>Type ij.plugin.Converter("16-bit") About Plugins >
2D Histogram Plugins>Analyze util.Histogram_2D /Applic...
2D Stitching Plugins > Stitching>deprecated Stitching_2D /Applic... About Image)...
3-3-2 RGB Image>Lookup Tables ij.plugin.LutLoader("3-3-2 RGB")
32-bit Image>Type ij.plugin.Converter("32-bit") Report a Bug
3D OC Options Analyze _3D_0OC_Options /Applic... He|p on Menu ltem
3D Objects Counter Analyze _3D_objects_counter /Applic... Licenses
[ ] Close window after running command Switch to Modern Mode
| Run | | Source | | Close | | Help | Fiji Wiki
Update Fiji

o Ctrl + 1 (“look up” command)

Upload Sample Image

o or Help » Search » Type into the box
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Opening data (and Bio-Formats)

Drag and Drop
File > Open

File > Import > Bio-Formats

Plugins > Bio-Formats > Bio-Formats Importer

Stack viewing

View stack with:  Hyperstack
Stack order: XYCZT
Dataset organization

(") Group files with similar names
[} Open files individually
[ Swap dimensions

7 Open all series

[ Concatenate series when compatible
[ Stitch tiles
Color options
Color mode: Default

[ Autoscale

~
v

<

(a3l

Bio-Formats Import Options

Metadata viewing
2 Display metadata

Display OME-XML metadata

| Display ROIs Bia data

Mem
~| Use virtual stack

[ Specify range for each series
~) Crop on import .

Big planes
Split into separate windows

"~ Split channels
| Split focal planes

I Split timepoints

Information

Display metadata - Reads metadata that may be
contained within the file format and displays it.
You can save it as a text file or copy it from the
File and Edit menus specific to the "Original
Metadata” window. Readability depends upon the
manner in which metadata is formatted in the
data source. The metadata can also be displayed
by pressing "i" (Image > Show Info) when the
imported image is active.




Pixel Types

File Edit Image Process  Analyze Plugins Window Help
Q) | e < et suwr| 8| 4 (8] | >
x=1316, y=7 Adjust j;g:g::

Show Info... Ctri+| d

Properties...  Ctrl+Shift+P —|8-hit Color

Eallit ~ RCB Color

Stacks -~ _|RGB Stack

Hyperstacks ~ _|HSB Stack

Crop Ctri+Shift+3

Duplicate... Ctri+Shift+D

Rename...

Scale... Ctrl+E

Transform

Zoom

Owverlay

Lookup Tables

Annotate
Drawing
Selection
Yideo Editing
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Channels Tool

O Channels

Crayscale

@] Channel 1
¥ Channel 2
¥ Channel 3

More »

Switch Channels on and off, adjust Brightness and Contrast
File » Open Samples » Hel a

Image » Color » Channels Tool (Shift + Z) » Grayscale
Switch to Color, then switch to Composite

More » Properties » Convert to RGB for publication or output



Adjust Brightness and Contrast

O B&C

Minimum

o Image > Adjust > Brightness and Contrast S—

o (how measured intensities are mapped to Brightness

display intensities) Contrast
Auto | Reset |

| Set | | Apply |




Histogram

o Analyze > Histogram

o i.e. frequency/count for each intensity level

[ MON Histogram of boats
300x240 pixels; RGB; 281K

B 1]
255

=

Count: 414720 Min: 103
Mean: 217.211 Max: 255
StdDev: 46.434 Mode: 255 (112692)

List Copy Log Live
;..




Profile Plots

o Use any Line tool
o Analyze > Plot Profile

o E.g. estimate signal-to-noise for feature tracking

@ @ Rat_Hippocampal_Neuron.tif (300%)

1/5; 81.92x81.92 pm (512x512); 16-bit; 2.5MB 0@ (Fiji Is Just) ImageJ

ERTERE PR NN RPN

++y
++y

" x=188, y=183, z=0, value=644

- TR .
"N NON ) Plot of Rat_Hippocampal_Neuron
(1| 13.38x882.58 pixels (530x255); 8-bit; 132K

T T T T T T T — T T T —T

1200

Gray Value

1000

800

Distance (um)

List Save... More » Live



Regions of Interest (ROI)

. o [ ] (Fiji Is Just) ImageJ
o File » Open Samples » HeLa Ooc|e <|4|:~|ala|a]s] o

Freehand selections

swjurl o] ]a] |»

o Image » Color » Split Channels
o Selections: e.g. Freehand selection tool

o How can a blue channel nucleus selection be copied to the red channel?

[ ] C3-hela-cells.tif
34.60x26.36 pm (672x512); 16-bit; 672K

Press "I' (Image>Show Info) for information



The ROl Manager: a “clipboard” for ROIs

, @® ROI Manager
0124-0070 Add [t]

34.60x26.36 um (672x512); 16-bit; 672K

ec® = C8-hela-cels.tif
34.60x26.36 um (672x512); 16-bit; 672K

Update
Delete
Rename...
Measure
Deselect
Properties...

Flatten [F]

Press "I' (Image>Show Info) for information

More »

Press "I' (Image>Show Info) for information

Show All
Labels

o Select the image with a ROI
o Press “T”key — or Analyze » Tools » ROI Manager
o Select other image

o Click ROl in manager — or Edit » Selection » Restore Selection



Segmentation (by intensity threshold)
o Image » Adjust » Threshold... (Shift + T)

o Image » Adjust » Auto Threshold... (Shift + T)

[ NON ) blobs.gif (150%)
256x254 pixels; 8-bit; 64K

O Threshold
ll‘ ‘lllllllllll'
3421%
126
255
| Default s | Red xa]

™ Dark background | | Stack histogram

' Auto | | Apply | | Reset | | Set |

@ Auto Threshold

Auto Threshold v1.16.1
Method Mean A

| | Ignore black | | Ignore white
™ White objects on black background
| | SetThreshold instead of Threshold (single images)

|| Show threshold values in log window

The thresholded result of 8 & 16 bit images is shown
in white [255] in 8 bits.

For 16 bit images, results of 'Try all' and single slices
of a stack are shown in white [65535] in 16 bits.
Unsuccessfully thresholded images are left unchanged.

| Cancel | | OK |




ldentifying, labeling & measuring objects

256x254 pixels; 8-bit; 64K

L N

0001-0015
0002-0006
0003-0014

O Analyze Particles

Size (pixelA2): 0-Infinity
Circularity: 0.00-1.00

Show: | Nothing —

™ Display results
@ Clear results

Exclude on edges

Include holes

0 | 0010-0027
@ @ 0011-0034
0012-0041

Summarize Record starts
¥ Add to Manager In situ Show . 4 0013-0045
% Q N 0014-0048
Help Cancel OK % @ 0015-0055
0016-0059
a3 501,;,. 0017-0057

0018-0073

NN1I0. _NN7N

o Image » Adjust »Auto Threshold

o Analyze » Analyze Particles...

Display results checkbox is checked -> Results table appears

ROl Manager

Add [t]

Update

Delete
Rename...
Measure
Deselect
Properties...
Flatten [F]

More »

™ Show All

™ Labels



Results table

@ 0@ Rol Manager

0001-0015 Add [t ‘ .

0002-0006 | (t] | [ NN . Results
0003-0014 ' Update | Area |Mean |Min |Max
0004-0012 1 488 255 255 255
0005-0015 | Delete [l 5 513 255 255 255
0006-0016

P | Remame.. | 3 709 255 255 255
0008-0026 | Measure || 4 477 255 255 255
0009-0028 5 501 255 255 255
0010-0027 | Deselect | g 357 255 255 255
0012-0041 ' Properties... | 7 105 255 255 255
V150045 *awen || 8 268 255 255 255
0014-0048 9 316 255 255 255
0015-0055 | More» | 10 45 255 255 25§
0016-0059

0017-0057 ™ Show All

0018-0073 & Labels

o Populated by analysis functions, e.q. Analyze particles or
o Analyze » Measure (shortcut key: ‘m’ for measure)

o Configure whatis measured : Analyze » Set Measurements

16




Benefits of Scripting

Facilitates reproducible science:

o Automate analysis
o Document your work

o Share workflows

[ JoN | *Macro.ijm.ijm

1

open("/Users/pwalczysko/Desktop/CMP03.png");

2 //run("Brightness/Contrast...");

3

0~ o U

=]

10
11
12
13
14
15
16
17
18

run("Auto Threshold");

run("16-bit");

run("Auto Threshold", "method=Mean white");
run("Analyze Particles...", "display clear add");
run("Summarize");

run("Set Measurements...",
setOption("BlackBackground", false);
run("Dilate");
run("Analyze Particles...
run("Select All");
run("Auto Crop");
setTool("rectangle");
makeRectangle(412, 140, 216, 220);
makeRectangle(514, 243, 269, 201);
run("Crop");

run("Script...");

, "display clear add");

19]

"area mean standard min center bounding shape integrated skewness area_fra¢

Run | Kill

| Show Errors

| | Clear |

the Fiji Script Editor

17




Macros are easy in ImageJ

o Plugins » Macros » Record...

o Execute a commands sequence, then click Create
[ NON Recorder

Record:| Macro +| Name: Macro.ijm | Create | | ? |

open("/Users/pwalczysko/Desktop/CMP03.png");
//run("Brightness/Contrast...");

run("Auto Threshold");

run("16-bit");

run{"Auto Threshold", "method=Mean white");

run("Analyze Particles...", "display clear add");
run("Summarize");

run("Set Measurements...", "area mean standard min center bounding shape
integrated skewness area_fraction redirect=None decimal=3");
setOption("BlackBackground", false);

run("Dilate");

run("Analyze Particles...", "display clear add");
run("Select All");

run("Auto Crop");

setTool("rectangle");

18



FIJI-OMERO Workflow Outline

o Setup OMEROIJ Plugin

o Manual Workflow:

ROl's and
Segmentation Results sent

using FlJI back to
OMERO

Fetch all o n—
. through Processed
Imageld’s T T Some T
/i in a P Analysis %

Images in back to
FlJI OMERO

\

Dataset

19



OMEROIJ Plugin : Setup

Dependency : OMERO 1) Plugin

OMERDO 5.2.0 Downloads

Clients | Plugins | Additional | Servers | API | Python | Java | Code | Components | Previous versions

o Information on this release of OMERO is in the release announcement

« Full documentation is available as web documentation or PDF documentation and there are user guides for the clients
on our Help website

o A standard OMERO user just needs to download the client package with the same major version as their institutional
server e.g. 5.0 clients with the 5.0 server

 If you do not have an institutional server, you can apply for an account on our Demo server or 1 the Virtual
Appliance to install your own version locally.

OMERUO client downloads
Client Size File Name Checksum
25 Windows ¥ s302ms oSO et v
B macosx §) wom umosmsizes D

e OMERO.web is part of the server package, so individual users do not need to install it locally.

o Full instructions for installing the client are on the Help website: Getting Started with OMERO.insight Version 5.2.0

OMERQO plugin downloads
Plugins Size File Name Checksum
i 19 OMERO.insight—ij-5.2.0-ice35- 4ae3f188
__d i ImageJ /Fiji 5 TS28MB )01 2ip (SHAL)
4\ Matiab I{/ 21.14 MB E)Il\glszg.ma|[ab-5.1.0-icc35. 9fdeef (SHAL)

o Instructions for downloading and installing the ImageJ plugin: Using ImageJ with OMERO

Save or move the .zip archive to the FlJI

> plugins folder.
http://help.openmicroscopy.org/imagej.html




Accessing OMERO using Imaged and FlJI

File Edit Image Process Analyze Window Help
EQG|Q9/,A.|+, '\|AH Macros ' |>>
agnifying glass (or use "+" and "-" keys) e »
Utilities p Fm—
New >
Compile and Run...
Install... Ctrl+Shift+M
3D >
Analyze )
Bio-Formats 13
Examples 13
Filters >
Graphics 13
Input-Output >
LOCI >
OMERO | 3 Connect to OMERO
Scripts 13 Save Image(s) to OMERO
Stacks ) Save ROIs to OMERO
Tools ) Save Results to OMERO
LAY LAY
“.,’ OM ERO.lﬂSlght .‘.,. OM EROAinsight
Starting Log Service
[
howe.openmicroscopy.org.uk [LAN] i % howe.openmicroscopy.org.uk [LAN] [§ %
Usemame: '7 —é Username: ’90"?’7
Password Password: "ﬂ
o ][ ] [CLoon | ~fmmmm— Login
%~ OME %~ OME

http://help.openmicroscopy.org/imagej.html

21
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|Label
1 Hoechst_ND - n000001.tif
2 Hoechst_ND - n000001.tif
3 Hoe(hsl ND n000001 nl

.openmicrosco

[Area [Mean [StdDev Mode

4.35556E-2 2.30549E3 4.88510E2 2.51500E3
1.21600€-1 3.33402E3 8.96595E2 4.09500E3
3.64444E-2 2.49201E3 5.14563E2 1.71900E3

.org/imagej.html

[Min Max X Y
1.51600E3 3.45700E3 1.97412E0 2
1.51600E3 4.09500E3 2.36955€0 2
1.55400E3 3.54300E3 9.42481E0 2

LX)

Hoechst ND -

0001-0009 Add [t]
{8 0002-0017 Viewing Options
0003-0011 Update 10 2T @Text LProview o vigiiey
0004-0010 .
0005-0008 Delete O 6051 00010009 “
It 0006-0016 Renamess O 82 00020017 ]
R 0007-0025 O 6053 0003-0011 ]
Measure £ 604 00040010 ]
O 6085 00050008 ]
. v
Desalect Line Plot 0 6056  0006-0016 4
0011-0037 Properties... Rendering Details {6057  0007:0025 )
0012-0033 Chamels - Edi O 6088 00080018 ]
0013-0034 Flatten [F] =
R 0014-0027 iaame e .
0015-0030 More » Grayscale 60680  0010-0025 )
= Rendering Settings 6061 00110037 4
0016-0032 ™ Show All e -
0017-0023 ot 6082 00120033 (
gl 0018-0037 ¥ Labels Interpolate O 606 00130034 ]
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Some useful links

o OMERO Downloads:

http://downloads.openmicroscopy.org/omero/

o OMERO Help Pages:

http://help.openmicroscopy.org/

o OMERO Forums:

https://www.openmicroscopy.org/community/viewforum.php?f=3




Thank to Funders
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\
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biotechnology and biological sciences
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OME Consortium

Dundee — Jason Swedlow, Colin Blackburn, Jean-Marie Burel, Mark Carroll, Gus Ferguson, Helen
Flynn, Kenny Gillen, Roger Leigh, Simon Li, Dominik Lindner, Josh Moore, Will Moore, Balaji
Ramalingam, Aleksandra Tarkowska, Petr Walczysko

University of Wisconsin, Madison (LOCI) - Kevin Eliceiri, Curtis Rueden, Mark Hiner
UT Southwestern — Gaudenz Danuser, Sebastian Besson

Oxford — llan Davis, Douglas Russell

CRS4 - Gianuigi Zanetti, Gianmauro Cucurru, Simone Leo, Luca Lianas

Edinburgh — Richard Baldock, Bill Hill, Jianguo Rao

Carnegie-Mellon — Robert Murphy, BK Cho, Ivan Cao-Berg

Imperial — Paul French, Chris Dunsby, lan Munro, Yuriy Alexandrov

NIA, NIH — llya Goldberg, Chris Coletta

Pasteur — Spencer Shorte, Sebastien Simard, Anne Danckaert

EBI — Gerard Kleywegt, Ardan Patwardhan, Ingvar Lagerstedt

Glencoe Software — Chris Allan, Joshua Ballanco, Andreas Knab, Melissa Linkert,
Chris MacLeod, Josh Moore, Emil Rozbicki, Liza Unson, Rebecca Walker, Wilma Woudenberg
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FIJI-OMERO Workflow Outline

o Setup OMEROIJ Plugin

o Manual Workflow:

ROl's and
Segmentation Results sent

using FlJI back to
OMERO

Loop Send
through Processed

Fetch all
Imageld’s
ina
Dataset

Some

and open I TQETES

Images in back to
FlJI OMERO

\




FIJI Scripts

FIJI : Script Editor

File Edit | Language
New_.py| - lava
1 O Javascript a
® pytho = FIJI : Grabbing an open Image
O Clojure
- ' File Edit Language Templates Run Tools Tabs
O BeanShell e
ew_.py
O !magej Macro 1 from ij import IJ =
O None 2
n 3 imp = IJ.getImage(}
4 print imp
— Ru I ............. | ,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, I _____ CI;; .....
__________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________________ Started New_vpy at Tue NOV 09 22:40:34 cEr 2010
imp [b: .gif
—~— I Kill l Clear imp[boats.gif 720x576x1]
N
[ - |

https://www.ini.uzh.ch/~acardona/fiji-tutorial/ 27




OMERO-FIJI Scripts : Accessory Methods

def omeroConnect():

# Omero Connect with credentials and simplelLogger
cred = LoginCredentials()
cred.getServer().setHostname(HOST)
cred.getServer().setPort(PORT)
cred.getUser().setUsername (USERNAME )
cred.getUser().setPassword(PASSWORD)

simpleLogger = SimpleLogger()

gateway = Gateway(simplelLogger)
gateway.connect(cred)

return gateway

# List all Imageld's under a Project/Dataset
def getImagelds(gateway, datasetId):

browse = gateway.getFacility(BrowseFacility)
user = gateway.getLoggedInUser()
ctx = SecurityContext(user.getGroupId())
ids = ArrayList(1)
val = Long(datasetId)
ids.add(val)
images = browse.getImagesForDatasets(ctx, ids)
j = images.iterator()
imagelds = []
while j.hasNext():
image = j.next()
imageIds.append(String.valueOf(image.getId()))
return imagelds

def

def

openImageP lus (HOST, USERNAME, PASSWORD, groupId, imageId):

options = ""

options += "location=[OMERO] open=[omero:server="
options += HOST

options += "\nuser="

options += USERNAME

options += "\npass="

options += PASSWORD

options += "\ngroupID="
options += groupId

options += "\niid="

options += imageld

options += "]"

options += " windowless=true "
print options

from ij import IJ

IJ.runPlugIn("loci.plugins.LociImporter", options);

uploadImage(path, gateway):

user = gateway.getLoggedInUser()
ctx = SecurityContext(user.getGroupId())
sessionKey = gateway.getSessionId(user)

config = ImportConfig()

config.email.set("")
config.sendFiles.set('true')
config.sendReport.set('false')
config.contOnError.set('false')
config.debug.set('false')
config.hostname.set(HOST)
config.sessionKey.set(sessionKey)
config.targetClass.set("omero.model.Dataset")
config.targetId.set(datasetId)

loci.common.DebugTools.enableLogging("DEBUG")

store = config.createStore()
reader = OMEROWrapper(config)

library = ImportLibrary(store,reader)
errorHandler = ErrorHandler(config)

library.addObserver(LoggingImportMonitor())

candidates = ImportCandidates (reader, path, errorHandler)
reader.setMetadataOptions(DefaultMetadataOptions(MetadataLevel.ALL))
success = library.importCandidates(config, candidates)

return success

28



FIJI Scripts : Client Side (DEMO

X ) — ist) Im . . : e OO0 sc;‘;rﬁidl?rgatc;me.tiﬁ
EQ I @‘/v AHn ‘\‘A‘ o\|{fr7“:|| I}Vv‘S[kv|LUTV‘ Vi |/ ‘& ’ ‘»’ c:1/4z:1/40 (c:1/4 z:1/40 - scram_01.r3d.ome.tiff); 33.30x33.30 microns (512x

*Rectangular* or rounded rectangular selections (right click to switch)

e 00 omero_batch_analysis.py (Running)

*omero_Image_open.js | elilS ol sEia eSS

*#

Setup

S # mmmmm

‘4
+#

1 Drop omero_client.jar and Blitz.jar under the jars folder of FIJI
109 # Parameters
[ ff ===mmmm—ee
112 # open Omero Image
| ff m=mmmeeeee——eee
115 HOST = "omero-balaji.docker.openmicroscopy.org"

116 USERNAME = "member-all-1"
117 PASSWORD = "ome"
8 PORT = 4064

120 datasetId = "2"
121 imageld = '
122 groupId = "-1"

124 # Prototype analysis example
) gateway = omeroConnect()
126 imageIds = getImagelds(gateway,datasetId);
127 imageIds.sort()
128 imageId = imageIds([2]
129 print imageld
130 openImagePlus(HOST,USERNAME, PASSWORD, groupId, imageId)
131 gateway.disconnect()

Run Show Errors Clear

12
location=[OMERO] open=[omero:server=omero-balaji.docker.openmicroscopy.org
user=member-all-1

pass=ome
groupID=-1
iid=12] windowless=true C

Started omero batch analysis.py at Wed Jun 22 10:24:12 BST 2016




