# Table Of Contents

1. Introduction .................................................................................................................. 1
2. Quick Start Guide ........................................................................................................ 2
   2.1. Installing OMERO.insight .................................................................................. 3
   2.2. Creating a place to store imported images ...................................................... 4
   2.3. Viewing images ................................................................................................. 5
3. Background Information ............................................................................................ 6
   3.1. What is OMERO? ............................................................................................... 7
   3.2. The OMERO Environment: Client and Server ................................................ 8
   3.3. 5-Dimensional images ...................................................................................... 9
   3.4. The OMERO Data Model and Hierarchies ....................................................... 10
4. Using OMERO.insight ............................................................................................... 11
   4.1. Starting OMERO.insight .................................................................................. 13
   4.2. A brief description of the Data Manager's user interface ................................. 14
   4.3. Projects and Datasets ...................................................................................... 15
      4.3.1. Creating a project .................................................................................... 16
      4.3.2. Creating a dataset ................................................................................... 18
      4.3.3. Renaming projects and datasets .............................................................. 20
      4.3.4. Removing projects and datasets ............................................................... 21
      4.3.5. Properties and Permissions .................................................................... 22
      4.3.6. Annotations ............................................................................................... 23
   4.4. Importing images ............................................................................................... 25
   4.5. Browsing projects, datasets and images ........................................................... 26
      4.5.1. Expanding a project to see constituent datasets ...................................... 27
      4.5.2. Expanding a dataset to see constituent images ....................................... 28
      4.5.3. The Project, Categories and Images tabs ................................................ 29
   4.6. Sorting and finding images .................................................................................. 30

Copyright © 2006-2007 University of Dundee. All Rights reserved.
4.6.1. Sorting images ................................................................. 31
4.6.2. Retrieving images .......................................................... 33
4.6.3. Finding images with Find in Tree ................................. 35

4.7. Categorising images .......................................................... 37
   4.7.1. Creating a Category Group ........................................... 38
   4.7.2. Creating a Category .................................................... 39
   4.7.3. Removing Categories and Category Groups ............... 40
   4.7.4. Categorising images .................................................. 41
      4.7.4.1. Adding an image to a category ......................... 42
      4.7.4.2. Categorising multiple images ......................... 43
      4.7.4.3. Viewing categorisation details ....................... 44
      4.7.4.4. Removing an image from a category ............... 45

4.8. Viewing images ............................................................... 46
   4.8.1. Viewing a single image .............................................. 47
   4.8.2. Using the Image Viewer ............................................ 48
      4.8.2.1. Adjusting channels ........................................ 49
         4.8.2.1.1. Viewing a specific channel .................... 50
         4.8.2.1.2. Additional Viewing options .................. 51
      4.8.2.2. Magnification ................................................ 54
         4.8.2.2.1. Magnifying the whole image .................. 55
         4.8.2.2.2. Magnifying an area of the image ............ 56
      4.8.2.3. Scale bar ...................................................... 58
      4.8.2.4. Viewing z-sections and timepoints ................ 59
         4.8.2.4.1. Manually viewing z-sections and timepoints . 60
         4.8.2.4.2. Automated viewing z-sections and timepoints . 61
      4.8.2.4.3. Additional Movie Player options for z-section and timepoint viewing .............................. 62
      4.8.2.5. Image Rendering options ................................. 64
1. Introduction

This document provides a comprehensive guide to the Beta version of the OMERO.insight software, released for general use in January 2007.

The software has been developed as part of the Open Microscopy Environment (OME) consortium. For more information on OMERO, including information on bugs and updated versions, visit http://www.openmicroscopy.org

The rest of the guide is arranged as follows:

- **Section 2 - Quick Start Guide.** Installing the software and a brief guide to performing some key image manipulation tasks using OMERO.insight.
- **Section 3 - Background information.** The concepts and models behind the OMERO suite of software.
- **Section 4 - Using OMERO.Insight.** A detailed guide to using the application.
- **Section 5 - Help and feedback.** How you can provide the development team with feedback to influence future development.

We hope you enjoy using the software.

The OMERO development team, University of Dundee, UK.
2. Quick Start Guide

2.1. Installing OMERO.insight
2.2. Creating a place to store imported images
2.3. Viewing images
2.1. Installing OMERO.insight

Depending on your operating system, OMERO.insight will either come as a simple zipped archive file, or as a bundled installation package. If you have downloaded the archive file, you will need to extract it with a program capable of opening .zip files. If you have downloaded the install package, double-click it to start the installation process and then follow the steps presented.

One you have installed the software, you may prefer to get to know OMERO by quickly performing some key image manipulation tasks using OMERO.insight, use this Quick Start Guide as a reference.

However, to get the most out of the software, we recommend you familiarise yourself with:

- The background behind and core concepts of the OMERO suite of applications, in Section 3.
- The more in-depth guide to using OMERO.insight to organise, view and manipulate your images in Section 4.
2.2. Creating a place to store imported images

Before importing any images using OMERO.importer you must create somewhere to store the images. This means creating a project and one or more datasets:

However, to get the most out of the software, we recommend you familiarise yourself with:

1. Create a project.
   - Open the File menu, select Create New Project.
   - In the window that appears, enter the project name and, optionally, a textual description of the project.
   - Select Save to confirm.

2. Create a dataset for the project just created:
   - Open the File menu, select Add New Dataset.
   - In the window that appears, enter the dataset name and, optionally, a textual description of the dataset.
   - Select Save to confirm.

3. The dataset will now be listed under the parent project.
2.3. Viewing images

Once you have imported some images using OMERO.importer, return to OMERO.insight. You will see the image filenames listed under the relevant dataset. You can now:

1. View an image:
   - Double-click on the image filename.
   - The image opens in a new window.

2. View composite z-sections or timepoints for an image, in the Image Viewer window:
   - Use the Z slider to manually view individual z-sections.
   - Use the T slider to manually view individual timepoints.
   - Open the Controls menu and select the Movie option to open the Movie Player.
     Here you can play all z-sections or timepoints in sequence, as a movie.

3. Adjust channels for multi-channel images:
   - In the Image Viewer, use the colour buttons on the left-hand side of the image to turn on or off a colour channel.
   - Switch between colour and greyscale representations of the image by going into the Controls menu, selecting Models, and choosing Colour or Greyscale.

These tasks are by no means all that you can do with OMERO.insight. Go to to find out how you can:

- Categorise your images;
- Add annotations to your images;
- Set permissions for viewing and editing your images;
- Find specific images;
- View and compare thumbnails of groups of images;
- Magnify areas of interest of your images;
- Make adjustments to the visualisation of your images;
- Save images in a variety of formats.
3. Background Information

3.1. What is OMERO?
3.2. The OMERO Environment: Client and Server
3.3. 5-Dimensional images
3.4. The OMERO Data Model and Hierarchies
3.1. What is OMERO?

OMERO is a set of software tools that supports image data management, visualisation and annotation. OMERO tools include:

- an OMERO Server;
- and a series of client applications:
  - OMERO.admin;
  - OMERO.importer;
  - OMERO.insight.

This User Guide concentrates on OMERO.insight, but the following information in this section gives a brief outline of the principles and concepts used by OMERO.
3.2. The OMERO Environment: Client and Server

OMERO’s design follows a standard client-server architecture. A single installation of an OMERO Server will usually be used for an entire laboratory or imaging facility. Image data and metadata are typically stored on a central computer running the OMERO server software, and then accessed via a standard Ethernet network using OMERO client applications that run on a user's workstation or laptop computer.

The OMERO Server manages all image metadata (date, size, channel names, etc.) but also contains an image rendering facility that generates fully rendered images, ready for display in an OMERO client application.
3.3. 5-Dimensional images

OMERO allows handling of up to 5-dimensional images. As well as the conventional x and y dimensions, you may store, view and manipulate z-sections, channels, and timepoints. The relationship of these multiple dimensions is illustrated in Figure 3.3-1

Figure 3.3-1: Multi-dimensional images
3.4. The OMERO Data Model and Hierarchies

All information in OMERO revolves around a data structure called the object hierarchy. An understanding of this is core to efficient and effective use of OMERO. This hierarchy defines three kinds of objects:

1. Projects
2. Datasets
3. Images

and an organisational structure for grouping these objects together. This structure is shown in Figure 3.4-1

![OMERO Object hierarchy](image)

**Figure 3.4-1** : OMERO Object hierarchy

At the top of the object hierarchy is the **project**. Projects represent a large, long-term investigation, usually by either a single OMERO user or a small collection of users in the same research group.

Each project contains a number of **datasets**. Projects and datasets form a many-to-many relationship; a project can contain more than one dataset, and each dataset can belong to more than one project. Most analysis routines are performed at the dataset level. This provides both a convenient batch processing capability, and the ability to calculate aggregate information about the contents of a dataset.

Each dataset contains a number of **images**. Like projects, images form a many-to-many relationship with datasets. Images in OMERO are inherently multi-dimensional - they consist of pixels across the usual three spatial dimensions, and can include multiple colour channels and time series.
4. Using OMERO.insight

The central part of OMERO.insight, and the part of the application you will see once logged in, is known as the Data Manager. This is where you can organise your images into logical groups ready for viewing individually or in groups.

As you use the Data Manager, you will also become familiar with the other two main features of OMERO.insight:

1. The **Image Viewer** - for viewing and manipulating an individual image - including enabling multi-dimensional viewing.
2. The **Hierarchy Viewer** - for viewing and manipulating thumbnails of groups of images.

More information on using the Image Viewer and Hierarchy Viewer is provided in the appropriate sections of this User Guide.

4.1.Starting OMERO.insight
4.2.A brief description of the Data Manager's user interface
4.3.Projects and Datasets
4.3.1.Creating a project
4.3.2.Creating a dataset
4.3.3.Renaming projects and datasets
4.3.4.Removing projects and datasets
4.3.5.Properties and Permissions
4.3.6.Annotations
4.4.Importing images
4.5.Browsing projects, datasets and images
4.5.1.Expanding a project to see constituent datasets
4.5.2.Expanding a dataset to see constituent images
4.5.3.The Project, Categories and Images tabs
4.6.Sorting and finding images
4.6.1.Sorting images
4.6.2.Retrieving images
4.6.3.Finding images with Find in Tree
4.7.Categorising images
4.7.1.Creating a Category Group
4.7.2.Creating a Category
4.7.3Removing Categories and Category Groups
4.7.4.Categorising images
4.7.4.1.Adding an image to a category
4.7.4.2.Categorising multiple images
4.7.4.3.Viewing categorisation details
4.7.4.4. Removing an image from a category
4.8. Viewing images
4.8.1. Viewing a single image
4.8.2. Using the Image Viewer
4.8.2.1. Adjusting channels
4.8.2.1.1. Viewing a specific channel
4.8.2.1.2. Additional Viewing options
4.8.2.2. Magnification
4.8.2.2.1. Magnifying the whole image
4.8.2.2.2. Magnifying an area of the image
4.8.2.3. Scale bar
4.8.2.4. Viewing z-sections and timepoints
4.8.2.4.1. Manually viewing z-sections and timepoints
4.8.2.4.2. Automated viewing z-sections and timepoints
4.8.2.4.3. Additional Movie Player options for z-section and timepoint viewing
4.8.2.5. Image Rendering options
4.8.2.6. Saving images
4.8.3. Viewing a selection of images: The Hierarchy Viewer
4.8.3.1. Selecting multiple images for viewing
4.8.3.2. Viewing an image from the Hierarchy Viewer
4.8.4. Using the Hierarchy Viewer
4.8.4.1. Adjusting thumbnail display
4.8.4.2. Display Tree View of images
4.8.4.3. Sorting images
4.8.4.4. Managing images in the Hierarchy Viewer
4.8.4.5. Additional image information: the Clipboard
4.9. Managing windows in OMERO.insight
4.10. Closing OMERO.insight
4.1. Starting OMERO.insight

When you start OMERO.insight, you will be asked to log in (see Figure 4.1-1). Specify your user name and password (see the OMERO.admin User Guide for details of setting up user accounts).

You will also need to provide the path name of the OMERO server you will be accessing by selecting the button and entering the details in the form provided. Note that if you are running the OMERO Server locally on your own machine, enter localhost as the server name.

Figure 4.1-1 : OMERO.insight log-in
4.2. A brief description of the Data Manager's user interface

Once logged in, you will see the Data Manager's default screen (Figure 4). This screen consists of several areas of interest, each of which is worth becoming familiar with in order to use the Data Manager. Each is labelled in Figure 4.2-1

1. The left-hand pane shows projects and datasets, category groups, categories or images in a hierarchical manner. (Note that on first accessing OMERO.insight, this pane will be empty until you create a project.)
2. The right-hand pane shows information relating to the currently selected project, dataset, category group, category or image; and will be blank if none exists or none is selected.
3. Above the two panes are three distinct navigational areas. From the top of the page, these are:
4. Finally, there are five application menus, each offering options based on the current status of OMERO.insight. The menus available are File, Edit, View, Window and Help.

Figure 4.2-1: Data Manager, Default Screen with two projects listed

NB

If you wish to send a comment to the OMERO development team, open the Help menu and select Send Comment. Future versions of OMERO.insight will include Help documentation available here.
4.3. Projects and Datasets

In order for you to import and manage images, you must first create a place for them to go. In OMERO, this means creating a Project, which in turn can contain one or more datasets (see 3.4 The OMERO Data Model and Hierarchies).

Icons used in OMERO.insight:

- denotes a project.
- denotes a dataset.
- denotes an image.

4.3.1. Creating a project
4.3.2. Creating a dataset
4.3.3. Renaming projects and datasets
4.3.4. Removing projects and datasets
4.3.5. Properties and Permissions
4.3.6. Annotations
4.3.1. Creating a project

To create a new project:

1. Either:
   - In the File menu, select Create New project.
   - Or select the icon.

2. In the window that appears (see Figure 4.3.1-1), enter the name of the new project. You can optionally add a textual description of the project.
3. Select Save to confirm.
4. Your project should now be created (Figure 4.3.1-2 shows a new project created and named DemoProject).

![Add a new project window](image)

Figure 4.3.1-1: 'Add a new project' window
Figure 4.3.1-2: Data Manager showing details of a selected project
4.3.2. Creating a dataset

One you have a project, you can create datasets in which to store your images.

To create a new dataset:

1. Select the project in which you want to create the dataset. The right-hand pane now shows information about the selected project (Figure 4.3.1-2).
2. From the File menu, select Add New dataset. Or select the icon.
3. In the window that appears, enter the name of the new dataset, and a textual description if you wish (Figure 4.3.2-1).
4. Select Save to confirm the addition.
5. The dataset should now be listed in the left-hand pane, under the relevant project (Figure 4.3.2-2).

Figure 4.3.2-1: Adding a new dataset to an existing project
Figure 4.3.2-2: Data Manager showing one available project, containing one dataset
4.3.3. Renaming projects and datasets

To rename a project or dataset:

1. Select the project or dataset.
2. In the right-hand pane, edit the text in the Name field.
3. Select Save to confirm changes.
4.3.4. Removing projects and datasets

To remove a project or dataset:

1. In the left-hand pane of the Data Manager, select the project or dataset to be removed.
2. In the Edit menu, select Remove (or Remove from current project for a dataset). This removes the selected project or dataset.

NB

A dataset is only removed from a project - it is not deleted from the system. The ability to recall existing datasets that have been removed will be added to future releases of OMERO.insight.
4.3.5. Properties and Permissions

You can add and view additional information to a selected project or dataset. For a selected project or dataset, the right-hand pane of the Data Manager will show information. The default view is to show Properties - i.e. the name and description, as shown in Figure 4.3.1-2 (for a project) and Figure 4.3.2-2 (for a dataset).

However you can also view Permissions information for the selected project or dataset, by selecting the **Permissions** tab (see Figure 4.3.5-1).

![Figure 4.3.5-1 : Viewing Permissions information for a selected project](image)

If the right-hand pane appears blank when a project or dataset is selected, select the toolbar icon to view properties and permissions information in the right-hand pane.
4.3.6. Annotations

You can add annotations to a selected dataset or image. This will provide a user-specific text comment, which may be particularly useful when sharing datasets and images with other OMERO users.

1. Select the dataset to be annotated.
2. Make sure the Properties tab is selected in the right-hand pane. Or, select the toolbar icon.
3. Below the Description field is the Annotation field.
4. Type in your annotation in the left-hand area of the Annotation field (see Figure 4.3.6-1). You will automatically overtype any existing text. If necessary, the Data Manager window can be scrolled or resized to allow enough space to type the annotation.
5. On completing the annotation, select Save to confirm.

On saving, the annotation will be 'stamped' with the user who created the annotation.

The icon shows that a dataset has one or more annotation (see TestDataset1 in Figure 4.5.1-1 for an example).

The icon shows that an image has one or more annotations.
Figure 4.3.6-1: Adding an annotation to a dataset

If the right-hand pane appears blank when a project or dataset is selected, select the toolbar icon to view properties and permissions information in the right-hand pane.
4.4. Importing images

Now you have a destination defined, the next logical step is to import your images into the OMERO system. This involves moving from OMERO.insight to OMERO.importer. Make sure you select the correct project and dataset as the destination for the file to be imported.

For details on how to do this, refer to the OMERO.importer User Guide.
4.5. Browsing projects, datasets and images

On completing a successful import, you can return to the OMERO.insight and use the Data Manager to manage and view your images.

- 4.5.1. Expanding a project to see constituent datasets
- 4.5.2. Expanding a dataset to see constituent images
- 4.5.3. The Project, Categories and Images tabs
4.5.1. Expanding a project to see constituent datasets

In the left-hand pane you might see projects listed but not their datasets (Figure 4.5.1-1). The number in square brackets after the project name is the number of datasets belonging to the project.

To see all datasets belonging to a project, click the Expand icon ▶.

All datasets associated with the selected project will now be shown (Figure 4.5.1-2). This icon will change appearance to ▼ to show that the project has been expanded to show datasets - clicking the icon again will collapse the display to show just the project again. Note that in Figure 4.5.1-1, the AnotherDemoProject image has no datasets - so cannot be expanded.

Figure 4.5.1-1: Project listing without datasets

Figure 4.5.1-1: Project expanded to show datasets
4.5.2. Expanding a dataset to see constituent images

The number in brackets after a dataset name is the number of images belonging to that dataset.

To see all images belonging to a dataset, click the **Expand** icon as above - the images will now be listed (Figure 4.5.2-1).

**Figure 4.5.2-1**: Expanded dataset showing images

<table>
<thead>
<tr>
<th>NB</th>
</tr>
</thead>
<tbody>
<tr>
<td>The file path name shown, in particular the number of directories preceding the filename, reflects the settings specified when importing using OMERO.importer. See Section 4.6.1 for additional display options for lists of image filenames.</td>
</tr>
</tbody>
</table>
4.5.3. The Project, Categories and Images tabs

You will see that in Figure 4.5.2-1, above the left-hand pane there are two tabs - Projects and Categories visible, plus an arrow tab. There should in fact be three tabs - the hidden one is the Images tab. If you only see two tabs, clicking on this tab gives you a menu showing all three options, allowing you to select the Images tab. Alternatively, hold down the mouse pointer in the space between the left and right-hand panes, and drag to the right to widen the left-hand pane until all three tabs appear (as in Figure 4.5.3-1).

<table>
<thead>
<tr>
<th>NB</th>
</tr>
</thead>
<tbody>
<tr>
<td>The arrow tab is reversed when only the Categories and Images tabs are shown. In this case, click the tab to access the Projects tab.</td>
</tr>
<tr>
<td>The Images tab is discussed further in Section 4.6, and the Categories tab is discussed further in Section 4.7.</td>
</tr>
</tbody>
</table>

![Expanded left-hand pane showing three tabs](Figure 4.5.3-1)

Figure 4.5.3-1: Expanded left-hand pane showing three tabs
4.6. Sorting and finding images

As you build up collections of images, you may wish to sort them into manageable groups, or find a specific image or group of images in your collection. OMERO.insight allows you to sort images by various techniques, and also to search for a specific image or images.

4.6.1. Sorting images
4.6.2. Retrieving images
4.6.3. Finding images with Find in Tree
4.6.1. Sorting images

A number of options are available for sorting a collection of images. These are provided in the context-specific toolbar (labelled as 3c in Figure 4.2-1) directly below the Projects, Categories and Images tabs (Figure 4.6.1-1), and are available to a list of images.

Figure 4.6.1-1: Toolbar providing sort options

These options are:

- Alphabetical sort. Select this option to sort image file names in alphabetical order. In the illustration in Figure 4.6.1-1, this option is selected, and hence the icon appears shaded.

- Date sort. Select this option to sort image file names in order of the date they were taken on the microscope - and if this information is not available, in order of the date of import into OMERO.

| NB | If the list of images shows more than one open Dataset or Category, images are sorted alphabetically or by date only within their parent dataset or category - although the order in which datasets or categories appear may change. |

| NB | This option allows you to toggle between showing a truncated path name and full path name for each listed image. Figure 4.6.1-2 and Figure 4.6.1-3 show the difference in image display names. |

| NB | The actual number of directories shown in the full image pathname depends on the option chosen when importing the image using OMERO.importer. |

- This option expands to reveal a menu with further options for viewing images, discussed in more detail in Section 4.6.2. It is only available when the Images tab is selected; otherwise it is greyed out: ▼.

- This option allows you to quickly collapse the current list of image filenames to show only parent Projects or Category Groups.
NB

If at any time the left-hand display appears not to be showing the information you expect, select *Refresh Current Tree* from the File menu to refresh the display.
4.6.2. Retrieving images

You can retrieve images from your collection of imported data by filtering out images based on the categories they belong to or by datasets.

![Filter images retrieval window](Figure 4.6.2-1)

Clicking the **Images** tab (see Section 4.5.3) results in a new window being displayed - the **Filter Images Retrieval** window (Figure 4.6.2-1). This allows you to specify which image filenames you would like to see listed in the left-hand pane. You have three choices:

1. Select images from chosen datasets.
2. Select images from chosen categories.
3. Select all images in your collections.

Select the **Image** menu button ‣ to see the **Image** menu (shown in Figure 4.6.2-2). This allows you to specify how Filter Images Retrieval will work.

On choosing either of the first two options in the list above, the **Filter Images Retrieval** allows you to select those datasets or categories from which you wish to retrieve images. All image filenames found will then appear in the left-hand pane.
Figure 4.6.2-2: Menu for configuring Filter Images Retrieval
4.6.3. Finding images with Find in Tree

The \textit{Find in Tree} feature works in a similar way to the 'Find in Page' feature provided by many Web browsers. It allows you to search for a text string within all items displayed in the left-hand pane (Figure 4.6.3-1).

To conduct a search:

1. In the \textit{Edit} menu, select \textbf{Find in Tree}. A form will appear at the bottom of the Data Manager window.
2. Type the text string you wish to search for in the \textbf{Find} text box.
3. Use the arrow icon to select whether you wish to search in image names or descriptions.
4. The \textbf{Match Case} checkbox can be checked if you want to ensure that image filenames are returned only if they match the case of the text string you specify.
5. The search will be dynamically conducted, reporting how many images were found that match your search criteria. The first image found will be highlighted (Figure 4.6.3-1); use the \textbf{Find Next} or \textbf{Find Previous} buttons to move through each image found. If no images are found, a Phrase Not Found message is shown.

![Figure 4.6.3-1: Showing results of a Find in Tree request](image)

Copyright © 2006-2007 University of Dundee. All Rights reserved.
NB

The Find in Tree feature can also work with datasets, projects, categories and category groups - i.e. whatever is currently listed in the left-hand pane.
4.7. Categorising images

OMERO.insight allows you to create categories for use in managing your images, as a separate means of organisation from the Project/Dataset structure. To do this, first you create a Category Group, and then create one or more Categories within the Category Group. Once you have some Categories, you can then use these to categorise your images.

Icons used:

- denotes a Category Group.
- denotes a Category.
- denotes a categorised image.
- denotes a categorised image that also has one or more annotations.

4.7.1. Creating a Category Group
4.7.2. Creating a Category
4.7.3. Removing Categories and Category Groups
4.7.4. Categorising images
4.7.4.1. Adding an image to a category
4.7.4.2. Categorising multiple images
4.7.4.3. Viewing categorisation details
4.7.4.4. Removing an image from a category
4.7.1. Creating a Category Group

Creating a Category Group is a similar process to creating a Project:

1. Select the Categories tab. This will bring up a list of existing Category Groups (or will be empty if none exist).
2. Then:
   - Either click the Create Category Group toolbar button.
   - Or go to the File menu, and select the New Category Group... option.
3. In the right-hand pane, enter the Category Group name, and an optional textual description (Figure 4.7.1-1).
4. Select Save to confirm.
5. Your Category Group should now be listed in the left-hand pane.

![Adding a Category Group](image)

**Figure 4.7.1-1** : Adding a Category Group
4.7.2. Creating a Category

Creating a Category is a similar process to creating a Dataset:

1. Select the Category Group in which the category should go (i.e. make sure it is highlighted in the left-hand pane).
2. Then:
   - Either click the Create Category toolbar button.
   - Or go to the File menu, and select the New Category... option.
3. In the right-hand pane, enter the Category name, and an optional textual description.
4. Select Save to confirm.
5. Your Category should now be listed in the left-hand pane, under the appropriate Category Group.

Figure 4.7.2-1 shows a list of Category Groups with Categories.

![Figure 4.7.2-1: List of Category Groups with Categories](image)

Figure 4.7.2-1: List of Category Groups with Categories
4.7.3. Removing Categories and Category Groups

To remove a Category from a Category Group:

1. Select the category to be removed.
2. In the *Edit* menu, select *Remove from current category group*.
3. The Category will be removed from the Category Group (though it will not be deleted).

Similarly, to remove a Category Group, select the Category Group to be removed, and remove using the *Edit* menu as above.
4.7.4. Categorising images

Once you have created one or more categories, you can categorise your images.

4.7.4.1. Adding an image to a category
4.7.4.2. Categorising multiple images
4.7.4.3. Viewing categorisation details
4.7.4.4. Removing an image from a category
4.7.4.1. Adding an image to a category

To categorise an individual image:

1. Select the image filename.
2. Then:
   - Either in the **Edit** menu, select **Categorise**.
   - Or select the ![Image] toolbar button and then **Categorise** from the pop-up menu that appears.
3. In the right-hand pane, you will initially see a list of available Category Groups. Select the appropriate Category Group and expand it by selecting the **Expand** button.
4. Now, tick all categories you wish to add the selected image to. (**Select All** and **Deselect All** buttons are available to speed up the task of selection).
5. Once the desired categories have been selected, select **Save** to confirm the categorisation.
4.7.4.2. Categorising multiple images

If you wish to add more than one image to the same category or categories, the steps described in Section 4.7.4.1 can be applied for multiple selected images. However in the current version of OMERO.insight you cannot select a dataset and then categorise all images within the dataset - you must select each image within the dataset.
4.7.4.3. Viewing categorisation details

You can see categorisation details for a selected image by selecting the **Categorisation** tab in the right-hand pane (Figure 4.7.4.3-1).

![Figure 4.7.4.3-1 Viewing categorisation details for an image](image)

**Figure 4.7.4.3-1** Viewing categorisation details for an image
4.7.4.4. Removing an image from a category

To decategorise an individual image:

1. Select the image filename.
2. Then:
   - Either in the Edit menu, select Decategorise.
   - Or select the toolbar button and then Decategorise from the pop-up menu that appears.
3. In the right-hand pane, you will initially see a list of available Category Groups. Select the appropriate Category Group and expand it by selecting the Expand button: ▼.
4. Now, tick all categories from which you wish to remove the selected image. (Select All and Deselect All buttons are available to speed up the task of selection).
5. Once the desired categories have been selected, select Save to confirm the de-categorisation.
4.8. Viewing images

Viewing images is a core function of OMERO.insight. Images are viewed in a separate window, using the Image Viewer. You can also view thumbnails of a selection of images you have individually chosen, or thumbnails of all images in one or more datasets, categories, category groups or projects, using the Hierarchy Viewer.

4.8.1. Viewing a single image
4.8.2. Using the Image Viewer
4.8.2.1. Adjusting channels
4.8.2.1.1. Viewing a specific channel
4.8.2.1.2. Additional Viewing options
4.8.2.2. Magnification
4.8.2.2.1. Magnifying the whole image
4.8.2.2.2. Magnifying an area of the image
4.8.2.3. Scale bar
4.8.2.4. Viewing z-sections and timepoints
4.8.2.4.1. Manually viewing z-sections and timepoints
4.8.2.4.2.Automated viewing z-sections and timepoints
4.8.2.4.3. Additional Movie Player options for z-section and timepoint viewing
4.8.2.5. Image Rendering options
4.8.2.6. Saving images
4.8.3. Viewing a selection of images: The Hierarchy Viewer
4.8.3.1. Selecting multiple images for viewing
4.8.3.2. Viewing an image from the Hierarchy Viewer
4.8.4. Using the Hierarchy Viewer
4.8.4.1. Adjusting thumbnail display
4.8.4.2. Display Tree View of images
4.8.4.3. Sorting images
4.8.4.4. Managing images in the Hierarchy Viewer
4.8.4.5. Additional image information: the Clipboard
4.8.1. Viewing a single image

To view a single image, you can:

- Double-click on the image filename, or:
- Select the image filename by clicking once, and then select the View Image button.

In either case the image will be displayed in a new window (Figure 4.8.2.1-1).
You can view more than one image at the same time - each will open in a separate Image Viewer window.
4.8.2. Using the Image Viewer

Once an image is displayed in the Image Viewer, there is a range of tools available to you for configuring how the image and its constituent sections are displayed, performing basic measurements, and saving images.

These options are described below.

- 4.8.2.1. Adjusting channels
  - 4.8.2.1.1. Viewing a specific channel
  - 4.8.2.1.2. Additional Viewing options
- 4.8.2.2. Magnification
  - 4.8.2.2.1. Magnifying the whole image
  - 4.8.2.2.2. Magnifying an area of the image
- 4.8.2.3. Scale bar
- 4.8.2.4. Viewing z-sections and timepoints
  - 4.8.2.4.1. Manually viewing z-sections and timepoints
  - 4.8.2.4.2. Automated viewing z-sections and timepoints
  - 4.8.2.4.3. Additional Movie Player options for z-section and timepoint viewing
- 4.8.2.5. Image Rendering options
- 4.8.2.6. Saving images
4.8.2.1. Adjusting channels

For multi-channel images, the Channel toolbar (Figure 4.8.2.1-2) enables you to adjust the channels used to form the display of the image.

Figure 4.8.2.1-1: Image Viewer

Figure 4.8.2.1-2: Channel Buttons

4.8.2.1.1. Viewing a specific channel
4.8.2.1.2. Additional Viewing options
4.8.2.1.1. Viewing a specific channel

The four channel buttons (457, 528, 617, 685 in Figure 4.8.2.1-2) enable you to turn on or off specific channels for multi-channel images. Turning on or off a channel will result in an immediate visual change to the image shown in the Image Viewer.

The colour band selected for a given channel corresponds to the emission wavelength of the channel. If this information is not available, the channels will be mapped to red, green and blue. The colour used to display any channel can be customised using the Colour Picker (Section 4.8.2.1.2).

Channels can be turned on or off by clicking the relevant channel selection button, aligned vertically on the left edge of the Image Viewer window. Buttons show the colour associated with the channel, plus wavelength in nanometres (if this information is available).
4.8.2.1.2. Additional Viewing options

The top two toolbar buttons change appearance depending on the current state of the image:

.enable toggling between colour model and greyscale display:

- To switch from colour display to greyscale, select [Colour].
- To switch from greyscale to colour display, select [Greyscale].

NB

The above options can also be chosen by opening the Controls menu and selecting the Models option. This allows you to choose between Colour and Greyscale options.

.enable viewing single-channel views of the image, as a movie:

1. To start the movie, select [Start]. This will display the image for a short period using each of the currently selected channels in turn.
2. The movie runs on a loop, and will continue until you stop it. To stop the movie, select [Stop]. The image then reverts to its appearance before the movie started.

The Colour Picker button allows you to configure the channel corresponding to a specific channel button. To associate a specific channel with a channel button:

1. Click on the Colour Picker button.
2. In the menu that appears, choose which channel to adjust.
3. The Colour Picker window opens (Figure 4.8.2.1.2-1).
4. You can then select a colour in one of three ways, each available by selecting one of the toolbar buttons at the top of the window. These options are:
   a. Using the HSV colour wheel;
   b. Using RGB colour sliders (shown in Figure 4.8.2.1.2-1);
   c. Showing the colour list.
5. Once happy with your settings, select Accept to confirm the changes, or Revert to ignore the setting changes you have just made.
6. You should now see the channel change applied to the relevant channel button.
The Colour Picker can also be accessed by double-clicking on a channel button. Right-clicking on a channel button gives access to a menu from which you can choose to bring up the Colour Picker or to display additional information about the channel (Figure 4.8.2.1.2-2).
Figure 4.8.2.1.2-2: Channel Info window
4.8.2.2. Magnification

It is also possible to view areas of the image in more (or less) detail by setting the magnification of the image or by using the lens feature.

4.8.2.2.1. Magnifying the whole image
4.8.2.2.2. Magnifying an area of the image
4.8.2.2.1. Magnifying the whole image

To magnify the whole image, use the Zoom feature:

- Open the **Zoom** menu.
- Choose from one of the predefined magnification levels.
- The display of the Image Viewer will change to show the selected image (Figure 4.8.2.2.1-1).

For increased magnification, you may need to use the Image Viewer's scroll bars to view all parts of the image; to avoid this, you can resize the **Image Viewer** window to show an increased area of the image.

![Image Viewer showing magnified image](image)

**Figure 4.8.2.2.1-1** : Image Viewer showing magnified image
4.8.2.2.2. Magnifying an area of the image

The Lens feature allows you to see an area of the image at a greater magnification level than the Zoom feature. It also allows you to see the magnified section alongside the image as a whole.

1. Open the Zoom window:
   - Either select the Lens toolbar button: 🕵️.
   - Or open the Controls menu and select the Lens option.

2. The Zoom window will now appear beside the Image Viewer window, and shows a magnified area of the image.

Below the image is additional information on the dimensions of the magnified image. The area of the magnified image is outlined in the main Image Viewer window (Figure 4.8.2.2.2-1).

To redefine the area of the image being magnified:

1. Click the mouse pointer on the highlighted area in the main Image Viewer.
2. Drag the highlighted area to the area of the image you wish to see magnified.
3. The Zoom window will be updated to reflect the change in area.

To change the size of the magnified area:

1. In the Zoom window, select the Lens menu.
2. Choose from one of the predefined window sizes.

   **NB**
   You may need to scroll or resize the Zoom Window to see all of the magnified area.

To change the magnification level:

1. In the Zoom window, select the Zoom menu.
2. Choose from the predefined list of magnification options.
3. The dimensions shown will be updated to reflect your choice.

To change the units of the dimensions shown in the Zoom Window, select the Units menu and choose between microns and pixels. You can also zoom using the mouse.
wheel, if your operating system supports this.

Figure 4.8.2.2.2-1 : Image Viewer and Zoom window
4.8.2.3. Scale bar

The Image Viewer by default includes a scale bar in the bottom right corner of the image. In Figure 4.8.2.2.1-1, the scale bar shows a length of 5 nanometres - the default setting. You can configure how the scale bar is displayed, using the View menu.

To remove the scale bar from the current image display:

1. Select the View menu.
2. Select the Show Scale bar option.

To show the scale bar, repeat the steps above.

To change the length of the scale bar:

1. Select the View menu.
2. Select Scale bar length (in microns)
3. Then:
   - Either choose a length from the options available,
   - Or choose Custom, and in the pop-up window that appears, enter your preferred length in the Value field and press Enter.
4. The scale bar length and label will now be adjusted.

To change the colour of the scale bar:

1. Select the View menu.
2. Select Scale bar colour option.
3. Choose from one of the colour options available.
4. The scale bar colour will now be adjusted.

**NB**

If there is not enough space to show the scale bar, it will not be shown.
4.8.2.4. Viewing z-sections and timepoints

For images with multiple z-sections and/or timepoints, the Image Viewer can allow manual or automated viewing of each section. The z-sections and timepoints can be viewed separately or together. Viewing is controlled using the relevant sliders to the right of the Channel toolbar (Figure 4.8.2.1-1).

The information in the status bar at the bottom of the Image Viewer window shows which z-section and timepoint is currently being displayed.

NB

If the current image has only one z-section or timepoint, viewing options are disabled (greyed out).

4.8.2.4.1.Manually viewing z-sections and timepoints
4.8.2.4.2.Automated viewing z-sections and timepoints
4.8.2.4.3.Additional Movie Player options for z-section and timepoint viewing
4.8.2.4.1. Manually viewing z-sections and timepoints

To **manually** change the z-section or timepoint being viewed, use the mouse to select and drag the slider up or down; or use the mouse wheel, if supported. The image will change to show the currently selected z-section or timepoint.
4.8.2.4.2. Automated viewing z-sections and timepoints

You can also view each of the image’s composite z-sections or timepoints as a movie. Each z-section or timepoint is displayed in sequence for a short time period to form the movie.

![Movie Player](image)

**Figure 4.8.2.4.2-1** Movie Player
To play z-sections or timepoints as a movie:

1. In the *Image Viewer* window:
   - Either select the *Play Movie* button: 
   - Or open the *Controls* menu and select the *Movie* option.

2. The *Movie Player* window appears ([Figure 4.8.2.4.2-1](#)).
3. Select the *Play* button to play the movie.
4. Select the *Stop* button to stop the movie.
5. When a movie is playing, the *Play* button becomes a *Pause* button.
4.8.2.4.3. Additional Movie Player options for z-section and timepoint viewing

The Movie Player allows you to make additional adjustments to the movie being played.

To configure how the movie is played, the *Play* menu gives you several choices:

- **Forward** shows each z-section or timepoint in turn, once only.
- **Backward** shows each z-section or timepoint in turn, once only, but in the opposite order to *Forward*.
- **Loop** shows each z-section or timepoint in turn *Forward*, but continuously until you choose to stop the movie.
- **Back and Forth** shows each z-section or timepoint in turn, *Forward* and then *Backward*, until you choose to stop.

Table 4.8.2.4.3-1 shows the difference in the Play options for an example image with 5 z-sections numbered 1, 2, 3, 4, 5.

<table>
<thead>
<tr>
<th>Play option</th>
<th>Frame order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forward</td>
<td>1, 2, 3, 4, 5</td>
</tr>
<tr>
<td>Backward</td>
<td>5, 4, 3, 2, 1</td>
</tr>
<tr>
<td>Loop</td>
<td>1, 2, 3, 4, 5, 1, 2, 3, 4, 5, 1, 2...</td>
</tr>
<tr>
<td>Back and forth</td>
<td>1, 2, 3, 4, 5, 4, 3, 2, 1, 2...</td>
</tr>
</tbody>
</table>

**Table 4.8.2.4.3-1**: Movie Player Play options

To specify which sections or timepoints should be included in the movie:

1. Make sure the appropriate option is selected (*Across Z* for z-sections only; *Across T* for timepoints only, and *Across Z and T* to play a movie showing all z-sections for each timepoint).
2. To specify which individual z-section or timepoint is respectively the first and last to be shown in the movie sequence:
   - Either move the left-hand slider button to select the first z-section (or timepoint) and the right-hand slider button to select the last z-section (or timepoint);
   - Or use the *Start* and *End* fields to type the number of the first z-section (or timepoint) and last z-section (or timepoint).
4.8.2.5. Image Rendering options

Options are also available to adjust rendering properties. Here, you adjust how the raw pixels' intensity values are mapped to the image displayed on your monitor. These are available by:

- Selecting the Rendering Options toolbar button: ![Rendering Options](image.png).
- Or opening the Controls menu and selecting the Renderer option.

This brings up the Display Settings window (shown in Figure 4.8.2.5-1).

![Display Settings](image.png)

**Figure 4.8.2.5-1**: Display Settings

Adjusting the rendering parameters will result in an immediate visual change to the image shown in the Image Viewer, except when adjusting the values of the horizontal slider. By default, the image shown in the Image Viewer will be updated when the knobs of the horizontal slider are released. For an immediate update, check the Immediate Update check box.
The horizontal slider allows you to specify start and end values for the interval of the raw data you wish to map. This is specified separately for each channel. Alternatively you can manually enter values in the **Start** and **End** fields.

**NB**

Currently you can only select values between the displayed **Min** and **Max** values (0 and 2484 in Figure 4.8.2.5-1)

The vertical slider allows you to specify a range of the colour space i.e. a sub-interval of [0, 255]. This allows you to increase or decrease the overall brightness of the image.

**Figure 4.8.2.5-2** : Display Settings window showing advanced options

Advanced image rendering options are available by selecting the **Show Advanced Options**
button (Figure 4.8.2.5-2), This expands the **Display Settings** window to include options to:

- Select the mapping curve (from a choice of linear, polynomial, exponential or logarithmic) for a channel.
- For polynomial or exponential curves, you can modify the shape of the curve for a channel, by adjusting the gamma value.
- Adjust bit depth.
- Turn on or off noise reduction.

**NB**

Bit depths and values for the vertical slider are the same across all channels; the other parameters are specified for each channel.

**NB**

The **Device Settings** tab is not functional in the current version of OMERO.insight, but will in future versions enable features such as reverse intensity and plane slicing.

Use the **Save** button to save rendering settings back to the database for future use.

Use the **Undo All** button to reset to the default rendering settings. Note that the default rendering settings are not the ones previously saved but the internal defaults of the rendering facility.
4.8.2.6. Saving images

You can save a copy of the image in its currently displayed form, in a number of different image formats.

1. Open the Controls menu and select the Save As option.
2. Here you can:
   - Specify the name of the saved image file.
   - Select the destination of the saved image file.
   - Select the saved image file format from a choice of BMP, JPEG, TIFF or PNG.
   - Remember the destination folder you save the image to for future use.
4.8.3. Viewing a selection of images: The Hierarchy Viewer

One of the most powerful features of OMERO.insight is the ability to view groups of images together on the same screen.

4.8.3.1. Selecting multiple images for viewing
4.8.3.2. Viewing an image from the Hierarchy Viewer
4.8.3.1. Selecting multiple images for viewing

A selection of images for viewing can be made at different levels:

- Selecting one or more Projects/Category Groups - this selects all images in each dataset/category belonging to the selected projects/category groups.
- Selecting one or more Datasets/Categories - this selects all images in the selected datasets/categories.
- Selecting one or more images, by using the keyboard and, or mouse to select more than one image filename from the list shown in the left-hand pane.

**NB**
You can select individual datasets (resp. categories) from different projects (resp. category groups) if desired.

To make the selection, for example using the Data Manager:

1. Select the first project, dataset, category group, category or image you wish to view by clicking once to highlight it.
2. Use the appropriate keys for your operating system to select subsequent projects, datasets, category groups, categories or images.

**NB**
In a selection, you can only select multiple objects of the same type - for example you can select 5 images, but not one dataset plus 5 images.

3. Once you have your selection select the **Browse** button.
For viewing a selection of images, the selection initially appears as a set of thumbnails in a new window - the Hierarchy Viewer. What you see in the Hierarchy Viewer depends on what you selected. Table 4.8.3.1-1 summarises how thumbnails are displayed in the Hierarchy Viewer by default - using the **Hierarchical Layout** option.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Hierarchy Viewer shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>One or more images individually selected</td>
<td>All images in a flat view layout (Figure 4.8.3.1-1)</td>
</tr>
<tr>
<td>One dataset/category</td>
<td>All images in one container</td>
</tr>
<tr>
<td>Multiple datasets (resp. categories)</td>
<td>Multiple thumbnail containers, one for each dataset in the project (resp. category group)</td>
</tr>
<tr>
<td>Multiple projects (resp. category groups)</td>
<td>Multiple thumbnail containers; one for each dataset in each project (resp. category group) (Figure 4.8.3.1-2)</td>
</tr>
</tbody>
</table>

**Table 4.8.3.1-1** Image selection method and Hierarchy Viewer display

The Hierarchy Viewer offers an alternative layout - **Flat Layout** option. This is a flat grid
display of all displayed thumbnails, with no containers.

To select your preferred layout option, open the View menu, select Layout and choose between Flat and Hierarchical.

![Hierarchy Viewer showing multiple containers](image)

**Figure 4.8.3-2** Hierarchy Viewer showing multiple containers
4.8.3.2. Viewing an image from the Hierarchy Viewer

Once you see thumbnails in the Hierarchy Viewer, you can view an individual image in more detail in the Image Viewer.

To view a specific image you have several options:

1. Double-click on the image’s thumbnail.
2. Select the image thumbnail and then select View from the Edit menu.
3. Right-click on the image thumbnail to display the Edit menu as for option 2.

The Image Viewer will then display the image as shown in Figure 4.8.2.1-1
4.8.4. Using the Hierarchy Viewer

The Hierarchy Viewer has many additional features to allow access to information about the current image selection.

4.8.4.1. Adjusting thumbnail display
4.8.4.2. Display Tree View of images
4.8.4.3. Sorting images
4.8.4.4. Managing images in the Hierarchy Viewer
4.8.4.5. Additional image information: the Clipboard
4.8.4.1. Adjusting thumbnail display

You can adjust the way the sets of thumbnails are displayed in the Hierarchy Viewer in a number of ways:

Moving a container: Select the container and drag it with the mouse to wherever you wish within the Hierarchy Viewer window.

Resizing a container: Click a corner of the container and drag the mouse to resize the container.

NB

You cannot resize an image by dragging it, nor drag an image from one container to another.

Magnifying an individual thumbnail: To enlarge a single thumbnail:

1. Select the Magnify button.
2. Move the mouse pointer over the thumbnail to be magnified. An enlarged version appears.
3. If you have a mouse wheel, you can increase or decrease the magnification factor by scrolling the wheel.

Continuous movement of the mouse pointer will magnify in turn each image the pointer passes over.

To keep a specific thumbnail on screen:

1. Select the pin-up icon.
2. The thumbnail will now remain on screen regardless of the position of the mouse pointer.

If you have a mouse wheel, you can increase or decrease the magnification factor of the pinned thumbnail by scrolling the wheel.

To remove a pinned-up thumbnail:

1. Select the Close button at the top of the thumbnail window.
2. The pinned up thumbnail is removed from display.
Change the size of all thumbnails in a container: You can enlarge or reduce the size of each thumbnail in a selected container (this includes all thumbnails in sub-containers).

To increase the size of all thumbnails:
1. Select the container.
2. Select the Zoom In All Images... button.

To decrease the size of all thumbnails:
1. Select the container.
2. Select the Zoom Out All Images... button.

To reset the size of all thumbnails:
1. Select the container.
2. Select the Reset Thumbnail Size... button.
3. Thumbnails will return to the default size.

View one thumbnail at a time in a container: Click on the Switch to Single-view mode button. The display changes to show only one thumbnail in the selected container.

To change the thumbnail currently in view:
1. Click the Switch to Single-view mode button again.
2. Choose the Select option from the menu appears.
3. Then select the filename of the image you wish to view from the submenu that appears.
4. The displayed thumbnail changes.

To return to viewing multiple thumbnails:
1. Click the Switch to Single-view mode button again.
2. Choose the Multi-view mode option from the menu that appears.
3. You will now see all thumbnails in the container.

Collapse a container: Click on the Collapse button at the top of the container you wish to collapse. This will temporarily remove all thumbnails from view and reduce the size of the container. Click on the same icon again (it is now an Expand button) to bring the thumbnails back.
4.8.4.2. Display Tree View of images

Selecting the **Display Tree View** option opens a pane where you can view the files currently shown in the Hierarchy Viewer as a tree structure - much like the left-hand pane of the Data Manager.

When the Tree View is visible, select the **Display Tree View** button again to remove this pane.
4.8.4.3. Sorting images

Like the Data Manager, images in the Hierarchy Viewer can be sorted within a set by date or name (see Section 4.6.1).

- Alphabetical sort. Select this option to sort image file names in alphabetical order.

- Date sort. Select this option to sort image file names in order of the date they were taken on the microscope - and if this information is not available, in order of the date of import into OMERO.
4.8.4.4. Managing images in the Hierarchy Viewer

In the Hierarchy Viewer, you can perform management actions on a single image or multiple images:

- Categorise or decategorise an image or selection of images.
- View and edit annotations for an image or selection of images.
- View property information of an individual image.
- Remove an image from its current dataset.

To perform any of these tasks, you can:

- Select one or more images in a container, and then open the **Edit** menu to select the operation of your choice.
- Or, right-click on a single image to see the **Edit** menu as above.

Icons are used to indicate the presence of category and annotations for any image appearing as a thumbnail in the Hierarchy Viewer; this iconic information is preserved for pinned up thumbnails.

Clicking on an icon will bring up the corresponding tab in the Clipboard (see Section 4.8.4.5)
4.8.4.5. Additional image information: the Clipboard

The Clipboard is an area at the bottom of the Hierarchy Viewer window where detailed information about the currently selected image is available. Any image with a thumbnail shown in the Hierarchy Viewer can be selected by single-clicking or double-clicking the image.

To show the Clipboard (Figure 4.8.4.5-1):

1. Select the **Clipboard** toolbar button to show the Clipboard; when the Clipboard is visible, select this button again to hide it;
2. Use your mouse to drag the Clipboard to the desired size.

![Hierarchy Viewer showing Clipboard](image)

Figure 4.8.4.5-1: Hierarchy Viewer showing Clipboard
The Clipboard (illustrated in Figure 4.8.4.5-1) provides similar information to the right-hand panel of the Data Manager. There are five tabs, each providing access to a specific Clipboard feature, and each described below.

1. **Find**: This feature enables you to search within the selection of images shown in the Hierarchy Viewer. The find works in a similar way to the Data Manager Find feature (discussed in Section 4.6.2). Results are displayed in the **Results** panel to the right of the Find form.
2. **Annotation**: Selecting this tab views all current annotations for the selected image. You
can add additional annotations or delete an annotation you have previously entered. For more details see Section 4.3.6. This tab is selected if you click on the **Annotation** icon for a thumbnail.

3. **Categorisation**: This enables you to see the categories the currently selected image belongs to. You can then declassify the image’s categorisation in a similar way to the Data Manager (see Section 4.7). This tab is selected if you click on the **Categorisation** icon for a thumbnail.

   **NB**
   
   To categorise an image or collection of images you need to use the *Edit* menu.

4. **Editor**: This enables you to view and edit Properties and Permissions information (see Section 4.3.5 for more details).

5. **Info**: Shows additional information about the image, including:

   a. Number of pixels along X and Y axes;
   b. Number of z-sections;
   c. Number of timepoints;
   d. Size of a pixel in microns;
   e. Emission wavelengths (if available).
4.9. Managing windows in OMERO.insight

As you work with images in OMERO.insight, you may end up with several open windows. The Windows menu, available at all times, shows all windows you have currently open in OMERO.insight, and allows you to jump between windows.

This means you can, for example, move between the Data Manager and any open Hierarchy Viewer windows or Image Viewer windows by selecting from the available options in the Windows menu.
4.10. Closing OMERO.insight

To end a session using OMERO.insight, open the File menu in the Data Manager and select Quit the Application; or, close the Data Manager window.

NB

Whenever you attempt to start a new action without saving edits or additions, you will be prompted to save or cancel the changes you made.
5. Feedback reporting

5.1. Help Information
5.2. Feedback Facility
5.1. Help Information

Help information is not currently available through the Data Manager Help menu; but you can send feedback by opening the Help menu and select Send Comment.
5.2. Feedback Facility

This Beta version of OMERO.insight has been rigorously tested to ensure it works as expected. As development is ongoing, however, it is possible that an error may occur when using the OMERO suite of applications. In such a case, a window will appear (Figure 5.2-1) inviting you to submit feedback about what you were doing when the error occurred.

Providing this information is not required, but submitting as much information as you are able to provide will help the development team identify and overcome the cause of the error. You may include an email address - if you do, this will only be used to contact you for more information about the error you experienced. This is optional, and you can choose to submit feedback anonymously if you prefer.

![Error feedback form]

Figure 5.2-1 : Error feedback form