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Using ImageJ with OMERO
This covers all OMERO versions from 5.1.0 and newer, and assumes you have never installed ImageJ or Fiji before.

You can tell what version your OMERO is from the fine print at the bottom of the login screen.
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OMERO is distributed under the terms of the GNU GPL. For more information, visit openmicroscopy.org
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In order to connect to an OMERO server and use the data stored there directly in ImageJ and Fiji, plugins have to be installed. The following instructions guide you through the download and installation and use of ImageJ, Fiji and the plugins.

Note:
The OMERO.insight-ij plugin requires Java 1.7 or later to function.
Downloading and installing ImageJ

insert link in web page
1
Download the latest version of ImageJ for your platform from the website:


http://rsbweb.nih.gov/ij/download.html
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Platform Independent

To install ImageJ 1.49 on a computer with Java pre-installed, or to upgrade to the latest
full distribution (including macros, plugins and LUTS), download ij149.zip (4MB) and
extract the Image]J directory. Use the Help>Update ImageJ command to upgrade to
newer versions.

Mac OS X
Download ImageJ 1.49 (6MB) as a double-clickable Mac OS X application. Also
available bundled with Java 1.8.0_60 (requires OS X 10.8 or later). Instructions.

Linux
Download Image]J 1.49 bundled with Java 1.6.0_24 (40MB) or bundled with Java
1.8.0_45 (62MB) Instructions.

Windows

Download ImageJ 1.49 bundled with Java 1.6.0_24 (37MB), bundled with 32-bit
Java 1.6.0_24 (44MB), bundled with Java 1.8.0_60 (70MB) or without Java (4MB).
Instructions.

Documentation

Tiago Ferreira's comprehensive ImageJ User Guide is available as an 8MB PDF
document and as a ZIP archive. The online JavaDoc API documentation is also
available as a ZIP archive.
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2
On Windows, run the set-up programme (either from the Downloads folder or when prompted by the download Wizard) and follow instructions, and security prompts as appropriate, to install ImageJ.

On Mac OS X, extract the .zip archive and drag the ImageJ folder to your applications folder.


On Linux, extract the .gz archive and double click the “run” script.


Further installation instructions can be found on the ImageJ web site (URL above).
Downloading and Installing Fiji

insert anchor in web page
Fiji (Fiji is Just ImageJ) is a distribution of ImageJ together with Java, Java3D and a lot of plugins organized into a coherent menu structure.

1
Download the latest version of Fiji for your platform from the website:




http://imagej.net/Fiji/Downloads
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2
The Fiji downloads page includes installation instructions.


On Windows it is recommended you install the Fiji executable within your user space cyfor example: C:\Users\[your name]\Fiji.app, not in the normal C:\Programs directory, otherwise future updating may fail.


On Mac OS X, mount the .dmg and drag the Fiji folder to your applications folder.


On Linux extract the .gz archive and double click the “run” script.

3
On Windows, depending on how the downloaded archive was expanded, the ImageJ executable can appear one level deeper in the Fiji.app folder than in ImageJ.


On Mac OS X, Fiji.app appears as a single .app.
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Installing Plugins for ImageJ and Fijiinsert anchor in web page
The location for the plugins in ImageJ and Fiji are essentially the same, with the following differences in gaining access to them:
· on Windows, Fiji sometimes has an additional level of hierarchy, depending on how the downloaded archive was expanded, for example:
ImageJ - Windows (32 bit):
Local Disk (C:) > Program Files (x86) > ImageJ > plugins
Fiji - Windows (32 bit):
Local Disk (C:) > username > Fiji-win32  > Fiji.app > plugins
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· on Mac OS X, Fiji is an .app package, so to see the plugins folder you must right-click the Fiji.app and select **Show Package Contents**:
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Note:
After installing or upgrading plugins, you need to restart ImageJ or Fiji to be able to use the plugins.

Using ImageJ with OMERO

insert link in web page
Two plugins are required:

· bioformats_package.jar

· OMERO.insight-ij

1
Download the latest 5.1.x version of the **Bioformats Package** plugin from:



http://downloads.openmicroscopy.org/latest/bio-formats5
Check there is a “Bio-Formats 5.1.x Downloads” heading on the page.
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* Full documentation is available as web documentation or PDF documentation.

« Internet Explorer sometimes renames JAR files to ZIP (e.g., bioformats_package.jar becomes
bioformats_package.zip); if this happens to you, simply rename the file back to its original name after the download is

complete.

« For some browsers, you may need to right-click or control-click the link and choose "Save link as..." or a similar
option to download the file.

Bio-Formats tools downloads
Clients Size File Name Checksum
« § Bio-Formats Package u‘L 2948MB  bioformats_packagejar  9dc74091 (SHAI)
g Command Line Tools '{; 2798 MB  bftools.zip 3d8fb109 (SHAL)
g MATLAB Toolbox ' 2799MB  bfmatlab.zip e31cc8bl (SHAL)

&

* bioformats_package.jar is the complete bundle (for end users) containing everything needed to read images into
Image] using Bio-Formats. Instructions for installing Bio-Formats in Image] are available in the user guide.
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2
Save or move the downloaded file into the ImageJ > plugins folder.
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3
Download the latest 5.x.x version of the OMERO.insight-ij plugin from:



http://downloads.openmicroscopy.org/latest/omero5
Check there is a “OMERO 5.x.x Downloads” heading on the page.
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* Information on this release of OMERO is in the release announcement

« Full documentation is available as web documentation or PDF documentation and there are user guides for the clients
on our Help website

« A standard OMERO user just needs to download the client package with the same major version as their institutional
server e.g. 5.0 clients with the 5.0 server

* If you do not have an institutional server, you can apply for an account on our Demo server or download the Virtual
Appliance to install your own version locally.

OMERQO client downloads

Client Size File Name Checksum
== Windows |$ 83.02 MB boll\gfi{v%_czlii;ms_s'l'o_ims_ 5&;
[T §) oo pEosmuoes T
B tnw ) none gurosmsees

* OMERO.web is part of the server package, so individual users do not need to install it locally.

« Full instructions for installing the client are on the Help website: Getting Started with OMERO.insight Version 5.2.0

OMERUO plugin downloads
Plugins Size File Name Checksum
« i ImageJ / Fij '{L 7528MB NI INSENt 32 0-ee33- G
‘ Matlab '& 21.14 MB Sf‘gﬁi‘;-mmab'i1-°'i°e35‘ 9f9dfeef (SHA1)

o Instructions for downloading and installing the ImageJ plugin: Using ImageJ with OMERO
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4
Save or move the .zip archive to the ImageJ > plugins folder.


Extract the archive into the plugins folder to give a folder named “OMERO.insight-ij-x” where x is the version number.


Leave the complete OMERO.insight-ij plugin folder with its components in the ImageJ > plugins folder.
Note: 
Some Windows unzip apps create a double folder enclosing the plugin.


Check, and if this has happened, copy the inner OMERO.insight-ij-5.x.x folder into the ImageJ > plugins folder.
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The OMERO.insight-ij-5.x.x.zip archive can be left in the plugins folder or deleted.
Using Fiji with OMERO

insert link in web page
As Fiji comes bundled with the components of Bioformats Package, there is no need to download and install this plugin.

Two actions are required for an installation:
· select the Bio-Formats jars using the update menu

· add the OMERO.insight-ij plugin
1
Select **Help > Update Fiji**.


Fiji will check for updates and after following prompts you will end up at the ImageJ Updater Window.


Click on **Manage update sites**.
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2
In the Manage update site window, select **Bio-Formats 5**.

Click **Close**.


Click **Apply Changes**.


Fiji will fetch and install the updates.
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3
Download the latest 5.x.x version of the OMERO.insight-ij plugin from:



http://downloads.openmicroscopy.org/latest/bio-formats5
Check there is a “OMERO 5.x.x Downloads” heading on the page.
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* Information on this release of OMERO is in the release announcement

« Full documentation is available as web documentation or PDF documentation and there are user guides for the clients
on our Help website

* A standard OMERO user just needs to download the client package with the same major version as their institutional
server e.g. 5.0 clients with the 5.0 server

* If you do not have an institutional server, you can apply for an account on our Demo server or download the Virtual
Appliance to install your own version locally.

OMERO client downloads

Client Size File Name Checksum
rrem 1 & OMERO.clients-5.1.0-ice35- £210c8ea
Waindows ) BEOMB 01 winzip (SHA1)
(K 1 & OMERO.clients-5.2.0-ice35- d456ad44
&‘ jyMac OS X (avaTy) N | IS C e e gt (SHA1)
(L 1 & OMERO.clients-5.2.0-ice35- Sec801a8
\I' Mac OS X (avas) V) 8205 MB b101.mac_Java6.zip (SHA1)
( H |&\ OMERO.clients-5.2.0-ice35-b101- 46909fd
A Ll i ) B e e (SHAD)

e Users of Mac OS X should use the client matching their installed Java version. Users of Mac OS X 10.7 and later
should install the latest Java Runtime Environment (JRE) and use the Java 7+ downloads. Users of Mac OS X 10.6 can
only use the Java 6 download.

* OMERO.web is part of the server package, so individual users do not need to install it locally.

« Full instructions for installing the client are on the Help website: Getting Started with OMERO.insight Version 5.1.4

OMERUO plugin downloads
Plugins Size File Name Checksum
( o OMERO.insight—ij-5.2.0-ice35- 3c79fb7e
« é Imaged / Fiji & 754MB PNERO lanil
4 ] OMERO.matlab-5.1.0-ice35- 352dbc98
L Matiab & U (o iy (SHAD)

o Instructions for downloading and installing the ImageJ plugin: Using ImageJ with OMERO

o Instructions for using the Matlab plugin are at: OMERO Matlab language bindings
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4
Save or move the .zip archive to the Fiji.app > plugins folder.


Extract the archive into the plugins folder to give a folder named “OMERO.insight-ij-x” where x is the version number.


Leave the complete OMERO.insight-ij plugin folder with its components in the Fiji.app > plugins folder.

Note: 
Some Windows unzip apps create a double folder enclosing the plugin.


Check, and if this has happened, copy the inner OMERO.insight-ij-5.x.x folder into the Fiji.app > plugins folder.
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Delete the OMERO.insight-ij-5.x.x.zip archive from the plugins folder.

Accessing OMERO using ImageJ and Fiji

1
Launch the ImageJ or Fiji application and click on the **Plugins** menu.


Select **OMERO > Connect to OMERO**.


A version of OMERO.insight will open and can be used as normal.
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2
As ImageJ needs to load the plugin software, it can take a minute or two for the OMERO login screen to appear, and then another minute for the progress bar to start moving and complete.


Enter your OMERO server address, if needed, and **Username** and **Password**.


Click **Login**.
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You will then be taken to the OMERO.insight Data Manager screen.

**Note: **
If you quit OMERO.insight and then connect again during the same ImageJ session, logging in and launching the OMERO plugin will be much quicker. So if you intend using the OMERO plugin through ImageJ again soon, it may be worth leaving your ImageJ application running.

If you receive the following error message in a dialogue box, this indicates there is a different Java version being used by Fiji from the version required by the OMERO plugin.
	(Fiji Is Just) ImageJ 2.0.0-rc-38/1.50b; Java 1.6.0_65 [64-bit]; Mac OS X 10.8.5; 33MB of 1171MB (2%)

java.lang.UnsupportedClassVersionError: org/openmicroscopy/shoola/MainIJPlugin : Unsupported major.minor version 51.0

This plugin requires Java 1.7 or later.




Update your operating system to the latest version of the Java Development Kit (JDK) using the Java Control Panel (Windows) or the Java System Preference Pane (Mac).
If the message persists after you have updated your operating system’s JDK, download the latest version of Fiji from the website, which is bundled with Java 8, and this should work with the latest OMERO.insight plugin.
http://downloads.imagej.net/fiji/latest/
3
Double click on the image in the data tree or select the image and **View > View in ImageJ** in the contextual menu.


Select the check box to set Bio-Formats to automatically check for updates.


Click **OK** and the Bio-Formats Import Options window opens.


Set parameters and click **OK**.


Your image will open in the ImageJ viewer.
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Bio-Formats Import Options

You can toggle this behavior later in the LOCI Plugins Configuration's "Upgrade” tab.

OK Cancel

Stack viewing

View stack with: Hyperstack bl

Stack order. czT

Dataset organization

-
-

[~ Swap dimensions
I~ Open all series

I™ Concatenate series when compatible

[” stitch tiies
Color options

Color mode:

Defautt ~|

[V Autoscale

2/3(c:2/3 - 31914-GAPDH staining of vehicle-treated C3H hepatocy); 1024x1024 pixels; 8-bit; 3MB

Metadata viewing

[ Display metadata
I™ Display OME-XML metadata

[~ Display ROIs

Memory management

I” Use virtual stack
[~ Specify range for each series

I™ crop on import

Split into separate windows

[~ Spiit channels
I~ spit focal planes

I~ spit timepoints

Information

View stack with - The type of
image viewer to use when
displaying the dataset.

Possible choices are:

# Metadata only - Display
no pixels, only metadata.

# Standard ImageJ - This
option is deprecated (i.e.
intended for use by old
macros only). Please use
Hyperstack instead.

# Hyperstack - Display the
pixels in ImageI's built-in
5D viewer.

# Data Browser - Display
the pixels in LOCT's
multidimensional Data

Cancel
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Saving images from ImageJ to OMERO

With OMERO version 5.1.0 and newer, it is possible to save images directly from ImageJ or Fiji to your OMERO server.
Use ImageJ or Fiji to open an image from a local disk.
Select    
**Plugins   >  OMERO   >   Save Image(s) to OMERO
A version of OMERO.insight will open automatically.
The image will be imported into OMERO in its original format.
If the image has been modified, e.g. a cropped image, it will be imported as an OME-TIFF. 
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Note:
Normal ImageJ conventions with respect to overlays and ROIs are respected when saving to the OMERO server.

Saving ROIs drawn in ImageJ to OMERO

Use ImageJ or Fiji to open an image from a local disk or from the OMERO server as described above.

Draw ROIs in ImageJ or Fiji as normal.

If the image is from a local disk select   
**Plugins   >   OMERO   > Save Image(s) to OMERO
A version of OMERO.insight will open automatically and the image, including the ROIs, will be imported.
If the image is from the OMERO.server select 
**Plugins   >   OMERO   >   Save ROIs to OMERO**
Once saved to the OMERO server the ROIs become standard OMERO ROIs and can be used as normal.
Any existing ROIs on an image in the OMERO server will be displayed and can be manipulated as normal in ImageJ.

Note:
There is no duplication of data, new or existing ROIs are saved back to the original image on the OMERO server.

To save analysis results back to OMERO select

**Plugins   >   OMERO   >   Save Results to OMERO**
The results will be uploaded and attached to the image in OMERO as a CVS file.
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