1 *+OMERO
Using ImageJ with OMERO

This covers all OMERO versions from 5.1.0 and newer, and assumes you have never
installed Imaged or Fiji before.

You can tell what version your OMERO is from the fine print at the bottom of the login
screen.

In order to connect to an OMERO server and use the data stored there directly in Imaged
and Fiji, plugins have to be installed. The following instructions guide you through the
download and installation and use of Imaged, Fiji and the plugins.

Note: The OMERO.insight-ij plugin requires Java 1.7 or later to function.

Downloading and installing ImageJ

1 Download the latest version of Imaged for your platform from the website:

http://rsbweb.nih.gov/ij/download.html

home | news | docs | download | plugins | resources | list | links

Download

Platform Independent

To install Image]J 1.49 on a computer with Java pre-installed, or to upgrade to the latest
full distribution (including macros, plugins and LUTSs), download ij149.zip (4MB) and
extract the ImageJ directory. Use the Help>Update ImageJ command to upgrade to
newer versions.

Mac OS X

Download Image]J 1.49 (6MB) as a double-clickable Mac OS X application. Also
available bundled with Java 1.8.0_60 (requires OS X 10.8 or later). Instructions.

Linux
Download Image]J 1.49 bundled with Java 1.6.0_24 (40MB) or bundled with Java
1.8.0_45 (62MB) Instructions.

Windows

Download Image] 1.49 bundled with Java 1.6.0_24 (37MB), bundled with 32-bit
Java 1.6.0_24 (44MB), bundled with Java 1.8.0_60 (70MB) or without Java (4MB).
Instructions.

Documentation

Tiago Ferreira's comprehensive ImageJ User Guide is available as an 8MB PDF
document and as a ZIP archive. The online JavaDoc API documentation is also
available as a ZIP archive.

2 On Windows, run the set-up programme (either from the Downloads folder or when
prompted by the download Wizard) and follow instructions, and security prompts as
appropriate, to install ImageJ.

On Mac OS X, extract the .zip archive and drag the ImagedJ folder to your applications
folder.

On Linux, extract the .gz archive and double click the “run” script.

Further installation instructions can be found on the Imaged web site (URL above).
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Downloading and Installing Fiji

Fiji (Fiji is Just ImageJ) is a distribution of ImageJ together with Java, Java3D and a lot of
plugins organized into a coherent menu structure.

1 Download the latest version of Fiji for your platform from the website:

http://imagej.net/Fiji/Downloads

Page Discussion View source History

Fiji/DowNLOADS

Fiji is a distribution of Image] which includes many useful plugins

contributed by the community.

6 ~ Download Fiji for your OS ~ 6

Contents [hide]
1 System requirements
2 Installation
3 Troubleshooting
4 Source code
5 Other downloads

5.1 Life-Line Fiji versions

5.2 See also
64-bit 0SX 64-bit
Other downloads
f‘ 32-bit i) NoJRe /3 32-bit
2 The Fiji downloads page includes installation instructions.

On Windows it is recommended you install the Fiji executable within your user space
cyfor example: C:\Users\[your name]\Fiji.app, notinthe normal
C:\Programs directory, otherwise future updating may fail.

On Mac OS X, mount the .dmg and drag the Fiji folder to your applications folder.
On Linux extract the .gz archive and double click the “run” script.

3 On Windows, depending on how the downloaded archive was expanded, the ImageJ

executable can appear one level deeper in the Fiji.app folder than in Imaged.
On Mac OS X, Fiji.app appears as a single .app.

erguson » fiji-win32 » Fijiapp » 8 06 (2] /Applications
: e e ) (<> ] m ] (=] [ = | (O] [B~] oMe 0 »
Name Date modified Type T T A Tr e
Contents FAVORITES @0 FaceTime.app
) & Desktop [U' Fiji.app r
images || FileOpen
jars (3] rkferguson @ Firefox.app
e [ A applicaions DR e
= Font Book.app
luts 1 OME -
l,:l [ Free Ruler 1.7b5.app e Fjlapp
meetes [LJ 1 Training @ Game Center.app . ‘ ’:‘1’:':;:‘:’"
pligee [C] 1 Help Site Version 1 | ¢ GarageBand.app i 27 Jan 2014 22.24
retro & 2 scoping &5 GitHub.app d Today 15:01
scripts = € Google Chrome.app ed Today 15:00
dbxml.gz E—J 3 Testing & Google Drive.app —
= | Imagel-win32.exe (] 4 Data & Google Earth.app

Ganale Sketchlin 8

1 of 164 selected, 206.48 GB available
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Installing Plugins for ImagedJ and Fiji

The location for the plugins in ImageJ and Fiji are essentially the same, with the following
differences in gaining access to them:

* on Windows, Fiji sometimes has an additional level of hierarchy, depending on how the
downloaded archive was expanded, for example:

ImageJ - Windows (32 bit):
Local Disk (C:) > Program Files (x86) > Imaged > plugins

Fiji - Windows (32 bit):
Local Disk (C:) > username > Fiji-win32 > Fiji.app > plugins

mputer » Local Disk (C:) » Program Files (x86) » Image) » zrguson » fiji-win32 » Fiji.app
Name Date modified Type Name Date modified ize
jre 1/28/201410:44 AM  File folder Contents

luts File folder images

macros jars

java

plugins

&) ij.jar luts

2 Imagel.cfg macros

g Imagel.exe plugins

£ | README.html retro

= unins000.dat scripts

j:.'}-‘ unins000.exe || .checksums KB
db.xml.gz 7KB

"7 Imagel-win32.exe

* on Mac OS X, Fiji is an .app package, so to see the plugins folder you must right-click
the Fiji.app and select Show Package Contents:

@0 FaceTime.app

FI. Open

g Show Package Contents _ |
@ Fire Show Package Contents N »

Fg Folc  Move to Trash

Fon
[ Free GetInfo b 5 3D_Blob_S...APSHOT jar
— wpe el checksums 3 A 9. o
o | . £ Contents » 13 3D_Object.. APSHOT.jar
UH ar - Jl.app ¥ db.xml.gz # 3D_Viewer.jar
= gl”’ Muz 'C':It_e (] images = Algorithm_Launcher.jar
€ Goo ake Alias j
] . L jars ] Analyze
& Goc  Quick Look “Fiji.app ——q (1 java % Analyze_R...APSHOT jar
= goo Share > & luts @ AnalyzeSk...APSHOT jar
oc ; 2 d
-~ P " .| macros = Anisotropi...APSHOT jar
§ ca  Copy ‘Fijiapp LT = Arrow2.. APSHOTjar
b | Show View Options [ retro ¥ Auto_Thre... APSHOT jar
- Gro [ scripts = BalloonSeg...PSHOT jar
s y
& Cro ) abel:
% Han
X

[ 1BM

_ @ v

Services > |

Note: After installing or upgrading plugins, you need to restart ImageJ or Fiji to be able to
use the plugins.
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Using ImagedJ with OMERO

Two plugins are required:

* bioformats_ package. jar
* OMERO.insight-ij

1 Download the latest 5.1.x version of the Bioformats Package plugin from:

http://downloads.openmicroscopy.org/latest/bio-formats5

Check there is a “Bio-Formats 5.1.x Downloads” heading on the page.

Bio-Formats 5.1.5 Downloads

Tools | API | Components | Code | Previous versions
¢ Full documentation is available as web documentation or PDF documentation.

o Internet Explorer sometimes renames JAR files to ZIP (e.g., bioformats_package.jar becomes
bioformats_package.zip); if this happens to you, simply rename the file back to its original name after the download is
complete.

* For some browsers, you may need to right-click or control-click the link and choose "Save link as..." or a similar
option to download the file.

Bio-Formats tools downloads

Clients Size File Name Checksum
el < Bio-Formats Package W/ 2948MB  bioformats_packagejar 9474091 (SHAD)
? Command Line Tools '{ 2798 MB  bftools.zip 3d8fb109 (SHAL)
< MATLAB Toolbox '{ 2799MB  bfmatlab.zip e31ce8bl (SHAL)

o bioformats_package.jar is the complete bundle (for end users) containing everything needed to read images into
Image]J using Bio-Formats. Instructions for installing Bio-Formats in Image]J are available in the user guide.

2 Save or move the downloaded file into the ImageJ > plugins folder.

Computer » Local Disk (C:) » Program Files (x86) » Image) » plugins b—

Name : Date modified Type Size
3D 28/20
Analyze 1/28
Examples 1/28/201
Filters 1/28
Graphics 1/28
Input-Output 1/28
jars 1/28
Scripts 1/28
Stacks 1/28/201
Tools 1/28

| £/ bioformats_package.jar

| README.txt
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http://downloads.openmicroscopy.org/latest/omero5

Check there is a “OMERO 5.x.x Downloads” heading on

*+*OMERO

Download the latest 5.x.x version of the OMERO. insight-1ij plugin from:

the page.

OMERO 5.2.0 Downloads

Clients | Plugins | Additional | Servers | API | Python | Java | Code | Components | Previous versions

o Information on this release of OMERO is in the release announcement

* Full documentation is available as web documentation or PDF documentation and there are user guides for the clients

on our Help website

server e.g. 5.0 clients with the 5.0 server

Appliance to install your own version locally.

A standard OMERO user just needs to download the client package with the same major version as their institutional

If you do not have an institutional server, you can apply for an account on our Demo server or download the Virtual

OMERUO client downloads
Client Size File Name Checksum
25 Windows | s302mp OMEROclients-s.1.0rceds- “RHAD,
B wacosx R
A unw ) morvm guEmoctemsasics s

* OMERO.web is part of the server package, so individual users do not need to install it locally.

o Full instructions for installing the client are on the Help website: Getting Started with OMERO .insight Version 5.2.0

OMERO plugin downloads
Plugins Size File Name Checksum
# {4 ImageJ /Fiji \{ 75.28 MB :’)lh(/]lﬁi{i;).il1sighlfij—5.2.0—icc35— 4(@&218)8
#\ Matiab ‘{ Ll 21.14MB S}‘gﬁﬁ‘;-m"“abé'1-°'i°535' 9f9dfeef (SHAL)

o Instructions for downloading and installing the ImageJ plugin: Using ImageJ with OMERO

Save or move the .zip archive to the ImageJ > plugins folder.

Extract the archive into the plugins folder to give a folder named “OMERO. insight-

ij-x" where x is the version number.

Leave the complete OMERO. insight-ij plugin folder with its components in the

Imaged > plugins folder.

Note: Some Windows unzip apps create a double folder enclosing the plugin.
Check, and if this has happened, copy the inner OMERO. insight-ij-5.x.x

folder into the ImageJ > plugins folder.

nputer » Local Disk (C:) » Program Files (6@6) » Imagel » plugins » b—

Name ate modified Type Size

3D
Analyze
Examples

Filters

Graphics Computer » Local Disk (C9) »
Input-Output

jars
OMERO.insight-ij-5.1.0-ice35-b24
Seripts

Stacks

——#

config
libs

(£ omero_jjar
Tools

£ toci_tools jar 28/2
i OMERO.insight-ij-4.4.10-ice35-b112.zip 2014 11:22 AM Compre 1 (zip
README txt 56 P Text D

Program Files (x26) » Ima

gel » plugins » OMERO.insight-ij-44.10-ice35-b112 »

odified

The OMERO.insight-ij-5.x.x.zip archive can be left in the plugins folder or deleted.

e OME
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Using Fiji with OMERO
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As Fiji comes bundled with the components of Bioformats Package, there is no need to
download and install this plugin.

Two actions are required for an installation:

* select the Bio-Formats jars using the update menu
* add the OMERO.insight-1ij plugin

Select Help > Update Fiji.

Fiji will check for updates and after following prompts you will end up at the Imaged
Updater Window.
Click on Manage update sites.

el

(Fiji Is Just) ImageJ

File Edit Image Process Analyze Plugins Window

Paintbrush Tool

-n“"

EO,‘G U‘/,‘A_ «},“’\‘A Q‘%’V“:” Dwv‘s‘* ImageJ Website...

ImageJ News.
Documentation. Name
Installation

Mailing List

Dev. Resources.
Plugins
Macros.

Macro Functions.

__.....*

Update Image.J
Refresh Menus

About Plugins »
About ImageJ

Report a Bug
Upload Sample Image
Help on Menu tem
Licenses

Switch to Modern Mode
Filj Wiki

—d Manage update sites

—ﬁ

Click Close.

In the Manage update site window, select Bio-Formats 5.

Click Apply Changes.
Fiji will fetch and install the updates.

c
(CMCI-EWBL

L [CHP-BiA tools
LI FFIPEG

e OME

Manage update sites

Image) Updater =

Status/Action

Advanced mode Close.

URL
]

Image) Updater

Manage update sites.

Apply changes Advancet

Close

www.openmicroscopy.org

Apply changes
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3 Download the latest 5.x.x version of the OMERO. insight-ij plugin from:

http://downloads.openmicroscopy.org/latest/bio-formats5

Check there is a “OMERO 5.x.x Downloads” heading on the page.

OMERO 5.2.0 Downloads

Clients | Plugins | Additional | Servers | API | Python | Java | Code | Components | Previous versions

« Information on this release of OMERO is in the release announcement

e Full is available as web or PDF and there are user guides for the clients
on our Help website

« A standard OMERO user just needs to download the client package with the same major version as their institutional
server e.g. 5.0 clients with the 5.0 server

« If you do not have an institutional server, you can apply for an account on our Demo server or download the Virtual
Appliance to install your own version locally.

OMERQO client downloads

Client Size File Name Checksum

- 13 OMERO.clients-S.1.0-ice35- 210c8ea

=m Windows V) BPMB 0 winaip (SHAD)

. 1) OMERO.clients-5.2.0-ice35- d4s6adds

E Macosx waary & 4 | B | e et (SHAI)

. I3 OMERO.clients-5.2.0-ice35- 5ec801a8

E Macosx waase N B2OSMB 01 mac Javab.zip (SHAD)

. 13 OMERO.clients-5.2.0-ice35-b101-  4690f9fd

A Linux & 4 | B (SHA1)

* Users of Mac OS X should use the client matching their installed Java version. Users of Mac OS X 10.7 and later
should install the latest Java Runtime Environment (JRE) and use the Java 7+ downloads. Users of Mac OS X 10.6 can
only use the Java 6 download.

* OMERO.web is part of the server package, so individual users do not need to install it locally.

* Full instructions for installing the client are on the Help website: Getting Started with OMERO.insight Version 5.1.4

OMERO plugin downloads
Plugins Size File Name Checksum
_ﬁ } 13 OMERO.insight—ij-5.2.0-ice35- 3¢79fb7e
&£ ImageJ / Fiji Ny 74s4MB o 4ip (SHAD)
) OMERO.matlab-5.1.0-ice35- 352dbc98
4\ Matlab V| DAMB (SHAD

o Instructions for downloading and installing the ImageJ plugin: Using ImageJ with OMERO

o Instructions for using the Matlab plugin are at: OMERO Matlab language bindings

4 Save or move the .zip archive to the Fiji.app > plugins folder.
Extract the archive into the plugins folder to give a folder named “OMERO. insight-
ij-x" where x is the version number.
Leave the complete OMERO. insight-i7j plugin folder with its components in the
Fiji.app > plugins folder.

Note: Some Windows unzip apps create a double folder enclosing the plugin.

Check, and if this has happened, copy the inner OMERO. insight-ij-5.x.x
folder into the Fiji.app > plugins folder.

rguson » fij-win32 » Fij.app » plugins » h—

Name Date modifie Type Size
Analyze 2/7/2014 5:44 P
Examples G «folde Computer » Local Disk (C) » Program Files («86) » Image) » plugins » OMERO.insight-ij-44.10-ice35-6112 »
JRuby 712014 5449
Macros 4544 File folde Name Date modified Type Size
OMERO.insight-i-5.1.0-ice35-624 27/2014550PM__ File folde —— config 28/2014 11:23 File folde
Scripts /17204 A4 P e libs 28/201411:24 AM  File fo
Utilities 45:44P (&) omero_ijar Bt i

£ 3D_Blob_Segmentation-2.0.0-SNAPSHOT... z
| 30_Objects_Counter-2.0.0-SNAPSHOT jar 45:44P Executable Jar File K8

Delete the OMERO. insight-ij-5.x.x.zip archive from the plugins folder.
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Accessing OMERO using ImagedJ and Fiji

1 Launch the ImagedJ or Fiji application and click on the Plugins menu.

Select OMERO > Connect to OMERO.
A version of OMERO.insight will open and can be used as normal.

¢ Image) - o [lEW

File Edit Image Process Analyze Ngltlic Window Help

’E[QGQQ/,A.#,‘\A‘ Macros >

Magnifying glass (or use "+" and "-" keys) Dl »
Utilities )
New )
Compile and Run

Install.. Ctrl+Shift+M

3D

Analyze
Bio-Formats
Examples
Filters
Graphics
Input-Output
LOCI

vV vVVvVvvVvvVvveYyywy

|
9
g

Scripts ) Save Image(s) to OMERO
Stacks | 2 Save ROIs to OMERO
Tools ) Save Results to OMERO
2 As ImageJ needs to load the plugin software, it can take a minute or two for the

OMERQO login screen to appear, and then another minute for the progress bar to start
moving and complete.

Enter your OMERO server address, if needed, and Username and Password.

Click Login.

“¢*OMERO *s» OMERO

tarting Log Se

rouk [LAN] (8] S howe.openmicroscopy.orguk [LAN] [ ~

(1o | | | ogin

You will then be taken to the OMERO.insight Data Manager screen.

Note: If you quit OMERO.insight and then connect again during the same ImageJ session,
logging in and launching the OMERO plugin will be much quicker. So if you intend
using the OMERO plugin through ImagedJ again soon, it may be worth leaving your
Imaged application running.

(X J
oo OME www.openmicroscopy.org



9 o+ OMERO

If you receive the following error message in a dialogue box, this indicates there is a different
Java version being used by Fiji from the version required by the OMERO plugin.

(Fiji Is Just) ImagedJ 2.0.0-rc-38/1.50b; Java 1.6.0_65 [64-bit]; Mac OS X 10.8.5; 33MB of
1171MB (2%)

java.lang.UnsupportedClassVersionError: org/openmicroscopy/shoola/MainlJPlugin :
Unsupported major.minor version 51.0

This plugin requires Java 1.7 or later.

Update your operating system to the latest version of the Java Development Kit (JDK) using
the Java Control Panel (Windows) or the Java System Preference Pane (Mac).

If the message persists after you have updated your operating system’s JDK, download the
latest version of Fiji from the website, which is bundled with Java 8, and this should work with
the latest OMERO.insight plugin.

http://downloads.imagej.net/fiji/latest/

( X J
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10 o+ OMERO

3 Double click on the image in the data tree or select the image and View > View in
ImageJ in the contextual menu.
Select the check box to set Bio-Formats to automatically check for updates.
Click OK and the Bio-Formats Import Options window opens.
Set parameters and click OK.
Your image will open in the Imaged viewer.

image) = Bio-Formats Upgrade Checker
File Edit Image Process Analyze Plugins Window Help
OO0/~ 4 N A|Q | OO|  |oes| 4 |& | # > LOCI plugins for Im: tomatically check for upgrades
n. If you wish to di eck the

Unused Tool o Polly Stack ¢ vior later in the
File Edit
O W {Check for upgrades to the LOCI piugins
" Projects Bl &7 v [ fiter mages Okl Cancal
¥ x 1% [Workspace: 8 of 8 image:
&' Laws (Collab) [1] 31914-GAPDH stain
2 i
o | view
> d Viewin Imagel b—_
)l Tmportin-f negatively re, Bio-Formats Import Options
1k Jason Data [1] Create New »
: alanalysisreves gy » Metadata viewing Information
: erst - isplay metad: ~
419 Orphaned Images H Delete Hyperstack Display metadata
Moveto Group ~ » Display OME-XHL metadata
J Tag Display ROls
A\ New Experiment. P I
( Dataset organization Memory management Possible choices are
Rendering Settings »
- Use vitual stack # Metadata only - Display
10 pixels, only metadata
D Attockemeots Specify range for esch series
A # Standard Tmage] - This
*J Tags Swap dmensions Crop on import option is deps
I~ Open all series
Concatenate series when compatible Split into separate windows
Stichties Spit channels
Color options [ Spit focal planes
Color made: Defaut <] T Spittmepoints
¥ Autoscale v
» [k cancel
31914-GAPDH staining of vehicle-treated C3H hepatocytes.omeiff = =

C3H h 1024x1024 pixels; 8-bit, 3MB

www.openmicroscopy.org
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Saving images from ImageJ to OMERO

With OMERO version 5.1.0 and newer, it is possible to save images directly from Imaged or
Fiji to your OMERO server.

Use ImagedJ or Fiji to open an image from a local disk.

Select
Plugins > OMERO > Save Image(s)to OMERO

A version of OMERO.insight will open automatically.
The image will be imported into OMERQO in its original format.

If the image has been modified, e.g. a cropped image, it will be imported as an OME-
TIFF.

[ Image) - o IEl
File Edit Image Process Analyze Nglielucll Window Help
EQ‘G‘@‘/,‘A.‘-#:“\‘A} Macros

Shortcuts

Utilities

>>
ImageJ 1.49r / Java 1.6.0_20 (64-bit)
e

v vew

New
Compile and Run
Install Ctrl+Shift+M

3D

Analyze
Bio-Formats
Examples
Filters
Graphics
Input-Output
LOCI

vV vVVVvVvVvvVeYywy

Connect to OMERO
Scripts ) Save Image(s) to OMERO
Stacks ) Save ROIs to OMERO
Tools 13 Save Results to OMERO

Note: Normal Imaged conventions with respect to overlays and ROls are respected when
saving to the OMERO server.
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Saving ROIs drawn in ImageJ to OMERO

Use ImagedJ or Fiji to open an image from a local disk or from the OMERO server as
described above.

Draw ROls in ImageJ or Fiji as normal.
If the image is from a local disk select
Plugins > OMERO > Save Image(s)to OMERO

A version of OMERO.insight will open automatically and the image, including the
ROls, will be imported.

If the image is from the OMERO.server select
Plugins > OMERO > Save ROIs to OMERO

Once saved to the OMERO server the ROIs become standard OMERO ROIs and can
be used as normal.

Any existing ROls on an image in the OMERO server will be displayed and can be
manipulated as normal in ImagedJ.

Note: There is no duplication of data, new or existing ROIs are saved back to the original
image on the OMERO server.

To save analysis results back to OMERO select
Plugins > OMERO > Save Results to OMERO

The results will be uploaded and attached to the image in OMERO as a CVS file.

Connect to OMERO

Scripts ) Save Image(s) to OMERO
Stacks ) Save ROIs to OMERO
Tools ) Save Results to OMERO

|
a

Connect to OMERO
Scripts Save Image(s) to OMERO

4
Stacks ) Save ROIs to OMERO
4

Tools Save Results to OMERO

BEEEY comnectto OMERO
Scripts > Save Image(s) to OMERO
Stacks ) Save ROIs to OMERO
Tools 13 Save Results to OMERO

Videos are available demonstrating the Fiji-OMERO workflows:

Fiji-OMERO workflow

(http://downloads.openmicroscopy.org/movies/omero-5-2/mov/fiji_omero_manual_workflow.mov)

Scripting with Fiji and OMERO
(http://downloads.openmicroscopy.org/movies/omero-5-2/mov/fiji_scripting_demo.mov)
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