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Using ImageJ with OMERO 4.4

This covers and version 4.4.x and the initial section assumes you have never installed
ImagedJ or Fiji before.

For OMERO versions 5.1.x and 5.0.x see the Using Imaged with OMERO 5.1 web page
(http://help.openmicroscopy.org/imagej.html).

You can tell what version your OMERO is from the fine print at the bottom of the login
screen.

‘ Login Quit

ey

Upgrading from OMERQO version 4.4.x to OMERO version 5.1.x is dealt with in a later
section.

In order to connect to an OMERO server and use the data stored there directly in ImageJ
and Fiji, plugins have to be installed. The following instructions guide you through the
download and installation and use of Imaged, Fiji and the plugins.

Downloading and installing ImageJ

1 Download the latest version of Imaged for your platform from the website:

http://rsbweb.nih.gov/ij/download.html

home | news | docs | download | plugins | resources | list | links

Download

Platform Independent

To install Image]J 1.48 on a computer with Java pre-installed, or to upgrade to the latest
full distribution (including macros, plugins and LUTs), download ij148 zip (3MB) and
extract the ImageJ directory. Use the Help>Update ImageJ command to upgrade to
newer versions.

Mac OS X

Download Image] 1.48 (4.7MB) as a double-clickable Mac OS X application. Includes
ImageJ64, which uses Java 1.6 in 64-bit mode on Intel Macs running OS X 10.5 or
later. Instructions.

Linux

Download Image] 1.48 bundled with 64-bit Java (40MB) or with 32-bit Java (46MB).

Both versions include Java 1.6.0_24 from Oracle. Instructions.

Windows

Download ImageJ 1.48 bundled with 64-bit Java (25MB; requires 64-bit Windows),
32-bit Java (28MB) or without Java (SMB). Can't use an installer because you lack
administrator privileges? Image] is also available as a ZIP archive (ij148-jdk6-64.zip
or 1j148-jdk6-32 zip). Instructions.

Documentation

Tiago Ferreira's comprehensive ImageJ User Guide is available as an 8MB PDF
document and as a ZIP archive. The online JavaDoc API documentation is also
available as a ZIP archive.

2 On Windows, run the set-up programme (either from the Downloads folder or when

prompted by the download Wizard) and follow instructions, and security prompts as
appropriate, to install ImageJ.

On Mac OS X, extract the .zip archive and drag the ImagedJ folder to your applications
folder.

On Linux, extract the .gz archive and double click the “run” script.

Further installation instructions can be found on the Imaged web site (URL above).
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Downloading and Installing Fiji

Fiji (Fiji is Just ImageJ) is a distribution of ImageJ together with Java, Java3D and a lot of
plugins organized into a coherent menu structure.

1 Download the latest version of Fiji for your platform from the website:

http://fiji.sc/Downloads

Downloads

ImageJ

ImageJ development snapshot
You can download the latest DEVELOPMENT, UNSTABLE application bundle of ImageJ. This build includes the latest changes on
the master branch of the source repository 2. It has not been thoroughly tested and may contain new bugs.

!ﬁ Al platforms (no JREs) &

See also

« ImageJ2 development releases for early versions of ImageJ2
« ImageJ1 download archive & for old versions of ImageJ 1.x.

Fiji
The Fiji distribution of ImageJ is focused on the life sciences. Fiji Is Just ImagedJ, batteries included (some assembly required).

Fiji continuous release
The latest version of Fiji is automatically and continuously built by the ImageJ Jenkins server 2.

My Windows (32-0it)@

Linux (32-bit) &
Al platforms (no JRES) & A 0S X&? A

Windows (64-bit) & 82 |Linux (64-bit) &

Fiji Life-Line version, 2014 November 25
Many Fiji plugins have been updated i to facilitate reproducible builds. The packages below reflect Fiji from just prior to these
updates.

My |Windows (32-6it)@

Al platforms (no JRES) & & 0s X&

A Linux (32-bit) &
Windows (64-bit) & -2 |Linux (64-bit) &

Fiji Life-Line version, 2014 June 2
We updated ImageJ2 with some rather dramatic changes under the hood. The packages below reflect Fij from just prior to these

updates.
Windows (32-bit) @ Linux (32-bit) &
g osxe |
Linux (64-bit) &7

Al platf JRE:
it b Windows (64-bit)

Fiji Life-Line version, 2013 July 15
We incorporated some extensive changes to reconcile Fij with ImageJ2 &. The packages below reflect Fiji from just prior to these
updates.

My Windows (32-bit)&

Linux (32-bit) &2
Al platforms (no JRES) & & 0S X A

Windows (64-bit) & 32 | Linux (64-bit) &

See also

« Fiji downloads archive ¢ for old versions of i

2 The Fiji downloads page includes installation instructions.
On Windows it is recommended you install the Fiji executable within your user space
for example: C:\Users\[your name]\Fiji.app, notin the normal
C:\Programs directory, otherwise future updating may fail.
On Mac OS X, mount the .dmg and drag the Fiji folder to your applications folder.
On Linux extract the .gz archive and double click the “run” script.

3 On Windows, depending on how the downloaded archive was expanded, the ImageJ

executable can appear one level deeper in the Fiji.app folder than in ImagedJ.
On Mac OS X, Fiji.app appears as a single .app.

erguson » fiji-win32 » Fijiapp » 8 006 (] /Applications
. . (el>] [ 22 gm""f“g'”g\ | © |[Re~|ome . »
Name Date modified pe = _— _
c FAVORITES @l FaceTime.app
ontents i =
f 7 pM || Desktop 1'_Fiji.app
images P ; [] FileOpen
jars 07 PM (il rkferguson @ Firefox.app
joe PAEARITE IR | B Foderbrander.app
. . = Font Book.app
luts 28/2014 P 1 OME :
e o t,_J [ Free Ruler 1.7b5.app vame Fiji.app
meshes EER F [ 1 Training # Game Center.app y ?;’:I;:i;;)"
plugins 28/2014 5:05 PM = 0 . i L
i e (] 1 Help Site Version 1 UH GarageBand.app Created 27 Jan 2014 22:24
28/2 5:0 & 2 Scoping GitHub.app Modified Today 15:01
scripts 1/28/2014 5:07 PM = & Google Chrome.app t ed Today 15:00
dbaxml.gz 28/2014 5:05 P G {J 3 Testing & Google Drive.app fSion —
=7 Imagel-win32.exe 1/28/20145:05PM  Application [ 4 Data & Google Earth.app

71 Ganale Sketchlin 8
1 of 164 selected, 206.48 GB available
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Installing Plugins for ImageJ and Fiji

The location for the plugins in ImageJ and Fiji are essentially the same, with the following
differences in gaining access to them:

* on Windows, Fiji sometimes has an additional level of hierarchy, depending on how the
downloaded archive was expanded, for example:

ImageJ - Windows (32 bit):
Local Disk (C:) > Program Files (x86) > Imaged > plugins

Fiji - Windows (32 bit):
Local Disk (C:) > username > Fiji-win32 > Fiji.app > plugins

mputer » Local Disk (C) » Program Files (x86) » Imagel » zrguson » fiji-win32 » Fiji.app
Name : Date modified Type Name : Date modified Type Size
jre File folder Contents 7
luts File folder images 7
macros File folder jars 7,
plugins File folder java 7,
|2/ ij.jar luts 7,
B Imagel.cfg CFG File macros
g Imagel.exe o plugins 7
2 | README.html HTML Documet retro 7,
= unins000.dat DAT File scripts 7
j%-‘ unins000.exe Application |_| .checksums 2/7/2 3 KB
db.xml.gz 2/7/2014 5:54 KB

" ImageJ-win32.exe

* on Mac OS X, Fiji is an .app package, so to see the plugins folder you must right-click
the Fiji.app and select Show Package Contents:

@0 FaceTime.app

FI. Open

i Show Package Contents _ |
o3 Show Package Contents N »

Fg Folc  Move to Trash
Fon
[ Frec Getlnfo

s = checksums = 3D_Blob_S...APSHOT jar
W Gan Comarelfs FIJ"I-aDD. (1] Contents b = 3D_Object...APSHOT jar
& Gf“ Burn. Fiji.app" to Disc... 5 db.xml.gz 3 3D_Viewer.jar

:1 Gitk Duphcat_e (] images = Algorithm_Launcher.jar
€ Goc Make Alias & jars [ Analyze

# Analyze_R...APSHOT jar

& Goc Quick Look “Fiji.app” — 2
& Goa  Share [

c L luts * AnalyzeSk...APSHOT jar
f 00 § : ;
. P " .| macros * Anisotropi...APSHOT jar
4 g’a‘ CopyE5lapp 5 Arrow_-2... APSHOT. jar
#| Gral 3 ' 3 .
} ‘GroJ Show View Options ] retro * Auto_Thre.. APSHOT jar
- .l scripts = BalloonSeg...PSHOT jar
s 1
& Gro ) abel:
% Han =
[ 1BM
& iov

Services > |

Note: After installing or upgrading plugins, you need to restart ImageJ or Fiji to be able to
use the plugins.
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Using ImageJ with OMERO version 4.4.x

Two plugins are required:

* loci tools.jar
* OMERO.insight-ij

1 Download the latest 4.4.x version of the LOCI Tools plugin from:

http://downloads.openmicroscopy.org/latest/bio-formats4

Check there is a “Bio-Formats 4.4.x Downloads” heading on the page.

Bio-Formats 4.4.12 Downloads

Tools | Components | Code | Legacy

* Full ion is available as web ion or PDF d

e The Bio-Formats API documentation is available to read on the web here.

.

Internet Explorer sometimes renames JAR files to ZIP (e.g., loci_tools.jar becomes loci_tools.zip); if this happens to you,
simply rename the file back to its original name after the download is complete.

For some browsers, you may need to right-click or control-click the link and choose "Save link as..." or a similar option
to download the file.

Bio-Formats tools downloads

Clients Size File Name Checksum
—ﬁ '{; g LOCI Tools 1001 MB  loci_tools.jar dbbf3c (MD5)
I{; g Command Line Tools 1742KB bftools.zip 15d697 (MDS)
I {; g\ MATLAB Toolbox 1374KB  bfmatlab.zip b0e7bl (MD5)

* loci_tools.jar is complete bundle (for end users) containing everything needed to read images into Image] using Bio-
Formats. Instructions for installing Bio-Formats in Image] are available in the user guide.

« bftools.zip is a bundle of scripts for using Bio-Formats on the command line.

* bfmatlab.zip is a bundle of functions for using Bio-Formats from MATLAB.

2 Save or move the downloaded file into the ImageJ > plugins folder.

omputer » Local Disk (C:) » Program Files (x86) » Imagel » plugins » b—

Name Date modified Type

3D 1/28/2014 10:44
Analyze

Examples 1/28
Filters 28
Graphics 28
Input-Output 28
jars 1/28
Scripts 1/28
Stacks 28
Tools 1/28

| £ loci_toolsjar 1/28
| README.txt
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Download the latest 4.4 .x version of the OMERO. insight-1i7j plugin from:

http://downloads.openmicroscopy.org/latest/omero4

Check there is a “OMERO 4.4.x Downloads” heading on the page.

OMERO 4.4.12 Downloads

Clients | Plugins | Additional | Servers | Virtual Appliance | API | Code | Artifacts | Legacy

 Information on this release of OMERO is in the release announcement

e Full is available as web or PDF ion and there are user guides for the clients on ¢

« A standard OMERO user just needs to download the client package with the same major version as their institutional servi
OMERQO client downloads
Clients

I 3 { ’ Windows

l@ ‘L Mac 0S8 X
I@ C\ Linux

¢ Each client package includes OMERO.insight, OMERO .importer and OMERO .editor and requires Java Version 1.6 or hi
package, so individual users do not need to install it locally.

Size File Name Checksum

63.37MB  OMERO.clients-4.4.11-ice35-b9.win.zip ~ 35¢607 (MDS)

18489 MB OMERO.clients-4.4.11-ice35-b9.mac.zip  ¢29db6 (MDS)

10272 MB  OMERO clients-4.4.11-ice35-b9.linux zip 178900 (MDS)

« Full instructions for installing the clients are on the Help website: Getting Started with OMERO .insight Version 4.4.10

OMERQO plugin downloads
Plugins Size File Name Checksum
—ﬁ I@ é ImageJ/Fiji 4867MB  OMERO.insight-4.4.11-ice35-b9.zip £11b02 (MDS)
I@ ‘\ Matlab 7978 MB  OMERO.matlab-4.4.11-ice35-b9.zip fe4f7d (MDS

* Instructions for downloading and installing the ImageJ plugin: Using ImageJ with OMERO

o Instructions for using the Matlab plugin are at: OMERO Matlab language bindings

Save or move the .zip archive to the ImageJ > plugins folder.

Extract the archive into the plugins folder to give a folder named “OMERO. insight-
ij-x" where x is the version number.

Leave the complete OMERO. insight-i7j plugin folder with its components in the
Imaged > plugins folder.

Note: Some Windows unzip apps create a double folder enclosing the plugin.
Check, and if this has happened, copy the inner OMERO.insight-ij-4.4.x
folder into the ImageJ > plugins folder.

nputer » Local Disk (C) » Program Files (x86) » Image) » plugins » P—

Name Date modified
3D

Analyze

Examples
Filters

Graphics
Input-Output
jars
OMERO.insight-ij-4.4.12-ice35-b112
Scripts
Stacks
Tools

[ leci_tools.jar

1) OMERQ.insight-ij-4.4.10-ice35-b112.zip

README bt

The OoMERO.

Computer » Local Disk (C:) » Program Files (26) » Image) » plugins » OMERO.insight-ij-4.4.10-ice35-b112 »

1
1
1
201410:44 AM  File folde
410:44 AM  File folde
! -
: Name Date modified Type
1

=

411:25 AM config

libs

2] omero_ijjar

insight-ij-4.4.x.zip archive can be left in the plugins folder or deleted.

www.openmicroscopy.org
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Using Fiji with OMERO 4.4.x

Fiji changed the way it bundles and updates the plugins and jars needed to work with
OMERQO version 4.4.x in April 2014. Versions of Fiji since require the following steps to work
with OMERO version 4.4 .x.

Two plugins are required:

* loci tools.jar
* OMERO.insight-ij

and incompatible Bio-Formats and SCIFIO plugins and jars need to be deleted.

1 Using a new or existing Fiji app download, start the app and allow it to go through and

complete the update procedure, or from the menu select Help > Update Fiji.
In the ImagedJ Updater window, click Manage update sites.

Highlight the Bio-Formats entry in the list.

Click Remove, and then Close.

] ImageJ Updater

Name Status/Action Update Site

ndamyste || ada | [ Remove |[ close h—_ Close

Manage update sites Advanced mode cancel

Remove
Manage update sites

(X J
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2 Quit Fiji.
Gotothe Fiji app > plugins folder on your hard drive and delete bio-
formats plugins.jar

Inthe Fiji app > jars folder, select and delete the five jars with the prefix
scifio-.

Searc

rguson » Fiji.app » plugins » v ¢

5 e S A . . .
Name ) ) Date modified bloAformats_pluglnSAS,O-TJar

%) BalloonSegmentation_-2.0.0-SNAPSHOT....

) |

Executable Jar File

Bug_Submitter-2.0.0-SNAPSHOT jar 5
%) bUnwarp)_-2.6.1-SNAPSHOT jar 5

| £ BeanShell_Interpreter-2.0.0-SNAPSHOT jar 5
—« 2| bio-formats_plugins-5.1.0,jar 5

| £ blockmatching_-2.0.0-SNAPSHOT jar 5 __(E >

@ =

|£| Calculator_Plus-2.0.0-SNAPSHOT jar Date modified: 5/23/2014 4:33 PM

| CLI_-2.0.0-SNAPSHOT jar Size: 225 KB

%) Clojure_Interpreter-2.0.0-SNAPSHOT jar Date created: ~ 5/23/2014 4:33 PM
rguson » Fiji.app » jars » v & S¢

Name Date modified 5 items selected

| £/ rsyntaxtextarea-2.0.4.1,jar 3/2014 4:33 PP

| £ scifio-0.12.0,jar 5

2014 4:33 P!
| £ scifio-bf-compat-1.7.0,jar 5/23/2014 4:33 P}
_ﬁ | £ scifio-lifesci-0.5.0 jar 5/23/2014 4:33 P} ’ ¢
2| scifio- —xml- i 5 .33 P} —>
| £ scifio-ome-xml-0.8.0,jar 5 14 4:33 P} 5 |
| £ scifio-tools-0.12.0.jar 5

| £ scijava-common-2.19.2 jar

| £ scijava-plugins-commands-0.1.1 jar

| £ scijava-plugins-platforms-0.1.1,jar

3 Download and install the latest 4.4.x version of the OMERO. insight-1ij plugin and
loci tools.jar as described in Using ImageJ 4.4.x above.

Subsequent automatic Fiji updates should not affect these installations.

e OME

www.openmicroscopy.org
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Accessing OMERO using ImageJ and Fiji

1 Launch the ImagedJ application and click on the Plugins menu.

Select OMERO > Connect to OMERO.
A version of OMERO.insight will open and can be used as normal.

¢ Image) E‘_Iﬂ—hj
File Edit Image Process Analyze m Window Help
’E[O,Q|O/,A_ -#-,‘\|A|°\ Macros JJJJiI

Magnifying glass (or use ™+ and ™" keys) Rlolclii=
Utilities
New

vy v v v

Compile and Run...

3D
Analyze
Examples
Filters
Graphics
Input-Output
LOCI
Macros
N | < —
Stacks ’ .
Tools ’

vy v v v v v v v

2 As ImageJ needs to load the plugin software, it can take a minute or two for the

OMERQO login screen to appear, and then another two or three minutes for the
progress bar to start moving and complete.

Enter your OMERO server address (if needed) and Username and Password.
Click Login.

"2* OMERO 's: OMERO

howe.openmicroscopy.orguk [LAN] [B S howe.openmicroscopy.orguk [LAN] [ =y

[Loon | Login

(X ]
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3 You will then be taken to the OMERO.insight Data Manager screen.

+=+ Polly Stack's Data Manager

File Edit View Window Help

CI)m E & & S ows (coleb)

\— Projects 2 N
v EExe [FHok
=83 Laws (Collab) [1]
= & Polly Stack

+)- @l Gilia and Centrosomes 201108088 [1]

) el Disease [3]

+- @l Importin-B negatively regulates multiple aspec|
7 ‘al Structural analysis reveals features of the spin|
)l Timelapse [3]

#-(§ Orphaned Images

« m »

® Screens
@ Attachments
P Tags

&) Images

&b Administration

] search

Note: If you quit OMERO.insight and then connect again during the same ImageJ
session, logging in and launching the OMERO plugin will be much quicker. So if
you intend using the OMERO plugin through ImageJ again soon, it may be worth
leaving your ImagedJ application running.

4 Double click on the image in the data tree or selecting the image and View > View

in ImageJ in the contextual menu.
The Bioformats Import Options window opens.
Select parameters and click OK.

{4 Image) = =
File Edit Image Process Analyze Plugins Window Help
B olz|o|<l4|+/A[Ala[0]2] [ofsss]a] | | |=]
4 Bio-Formats Import Options [
& Polly Stack's Data Manager Stack viewing Metadata viewing Information
File Edit View Window Help View siackwili: | Hyperstack  ~| [l Display mefndeta Autoscale - Stretches the channel
& 3 — histograms to each channel's
5\ m % A& B Laws (Colab Stack order c ™ Display OME-XHL metadata
EZ)m | & || 55 Laws (colab) global minimum and maximum
; S mages FERERE | ™ Daplay RO value throughout the stack. Does
= | 2 1% O | &y : I
~TT -~ 2 X T not alter underlying values in the
ERXS B G - taset organization Memory management =
(38 Laws (Collab) [1] d DAPI (blug) in vehicle- [mi I Use virtual stack
& Polly Stack B Browse w/o thumbnails Ir I - I
S @ Disease [5] = | ] e r I Specify range for each series | If unselected, all channel
i ew... N
% B 200908150 Figure 6 [0] | I~ Swap dimensions I crop on import istograms st scaled o the
o B 011021427 1 12 || Open with » § ViewinImagel.. ——* image's digitzation bit depth. Note
—
=5 201102142-Fig 4 [6] \ Editor. = I~ Open all series that this range may be narrower
a
j . reated CSTEL hepatocyte ® Downlosd I™ Concatenate series when compatle  Spit into separate windows than the bit depth of the file. For
3] ...-treated C3H hepatocyte B New Dataset From Selection.. example, 2 16-bit file may contain
3] ...reated CS7RL hepatocyte & [mport ™ stich tles I” Spit channels intensities digitized to 16-bits
(3] ...-treated C3+ hepatocyte . (0-65,335), to 12-bits (0-4,095),
3] .. reated Cs78L hepatocyte ¥ N Color options I Splt focal planes to 10-5its (0-1,023), etc.
@ g Z°”°[2}“2“° el (e Color mode: Defaut + I Spit timepoints
4 ) PTRE 3] .
c gy .
(-l Structural Analysis [2] = ”upy v {Autsscaiel ;\‘ozt that _\? can use th i
O K | ~ oK | _cancel

(X ]
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Upgrading ImageJ from 4.4.x to 5.1.x

To upgrade Imaged for use with an OMERO version 5 server, you need to:

1 Go to the ImageJ > plugins folder.

Delete the loci_ tools.jar and the OMERO.insight-ij-4.4.x folder.
Download the latest 5.1.x version of the Bioformats Package plugin from:

http://downloads.openmicroscopy.org/latest/bio-formats5

Check there is a “Bio-Formats 5.1.x Downloads” heading on the page.
Save or move the downloaded file into the ImageJ > plugins folder.

2 Download the latest 5.1.x version of the OMERO. insight-ij plugin from:

http://downloads.openmicroscopy.org/latest/omero5

Check there is a “OMERO 5.1.x Downloads” heading on the page.
Save or move the downloaded file into the ImageJ > plugins folder.

Note: The bioformats package.jar you need, to use Imaged with OMERO version
5.1.x, is incompatible with loci_tools. jar, and Imaged will not work with OMERO
if both are in the plugins folder.

We suggest that if you wish to access both 4.4.x and 5.1.x versions of OMERO from ImageJ
that you run two appropriately named copies of ImagedJ each with the appropriate plugins for
the version.

For more information on using ImageJ with OMERO versions 5.1.x and 5.0.x see:

Using ImagedJ with OMERO (http://help.openmicroscopy.org/image;j.html).
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