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Using ImageJ with OMERO 4.4
This covers and version 4.4.x and the initial section assumes you have never installed ImageJ or Fiji before. 
For OMERO versions 5.1.x and 5.0.x see the Using ImageJ with OMERO 5.1 web page (http://help.openmicroscopy.org/imagej.html).
You can tell what version your OMERO is from the fine print at the bottom of the login screen.
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OMERO is distributed under thé terms of the GNU GPL. For more information, visit openmicroscopy.org
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Upgrading from OMERO version 4.4.x to OMERO version 5.1.x is dealt with in a later section.
In order to connect to an OMERO server and use the data stored there directly in ImageJ and Fiji, plugins have to be installed. The following instructions guide you through the download and installation and use of ImageJ, Fiji and the plugins.

Downloading and installing ImageJ

insert link in web page
1
Download the latest version of ImageJ for your platform from the website:


`http://rsbweb.nih.gov/ij/download.html<http://rsbweb.nih.gov/ij/download.html>`
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Platform Independent

To install ImageJ 1.48 on a computer with Java pre-installed, or to upgrade to the latest
full distribution (including macros, plugins and LUTs), download ij148.zip (3MB) and
extract the Image] directory. Use the Help>Update ImageJ command to upgrade to
newer versions.

Mac OS X

Download ImageJ 1.48 (4.7MB) as a double-clickable Mac OS X application. Includes
ImageJ64, which uses Java 1.6 in 64-bit mode on Intel Macs running OS X 10.5 or
later. Instructions.

Linux
Download Image]J 1.48 bundled with 64-bit Java (40MB) or with 32-bit Java (46MB).
Both versions include Java 1.6.0_24 from Oracle. Instructions.

Windows

Download Image]J 1.48 bundled with 64-bit Java (25MB; requires 64-bit Windows),
32-bit Java (28MB) or without Java (SMB). Can't use an installer because you lack
administrator privileges? Image]J is also available as a ZIP archive (ij148-jdk6-64 zip
or ij148-jdk6-32.zip). Instructions.

Documentation

Tiago Ferreira's comprehensive ImageJ User Guide is available as an 8MB PDF
document and as a ZIP archive. The online JavaDoc API documentation is also
available as a ZIP archive.
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2
On Windows, run the set-up programme (either from the Downloads folder or when prompted by the download Wizard) and follow instructions, and security prompts as appropriate, to install ImageJ.

On Mac OS X, extract the .zip archive and drag the ImageJ folder to your applications folder.


On Linux, extract the .gz archive and double click the “run” script.


Further installation instructions can be found on the ImageJ web site (URL above).
Downloading and Installing Fiji

insert anchor in web page
Fiji (Fiji is Just ImageJ) is a distribution of ImageJ together with Java, Java3D and a lot of plugins organized into a coherent menu structure.

1
Download the latest version of Fiji for your platform from the website:




`http://fiji.sc/Downloads<http://fiji.sc/Downloads>`
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2
The Fiji downloads page includes installation instructions.


On Windows it is recommended you install the Fiji executable within your user space for example: C:\Users\[your name]\Fiji.app, not in the normal C:\Programs directory, otherwise future updating may fail.


On Mac OS X, mount the .dmg and drag the Fiji folder to your applications folder.


On Linux extract the .gz archive and double click the “run” script.

3
On Windows, depending on how the downloaded archive was expanded, the ImageJ executable can appear one level deeper in the Fiji.app folder than in ImageJ.


On Mac OS X, Fiji.app appears as a single .app.
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Installing Plugins for ImageJ and Fijiinsert anchor in web page
The location for the plugins in ImageJ and Fiji are essentially the same, with the following differences in gaining access to them:
· on Windows, Fiji sometimes has an additional level of hierarchy, depending on how the downloaded archive was expanded, for example:
ImageJ - Windows (32 bit):
Local Disk (C:) > Program Files (x86) > ImageJ > plugins
Fiji - Windows (32 bit):
Local Disk (C:) > username > Fiji-win32  > Fiji.app > plugins
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· on Mac OS X, Fiji is an .app package, so to see the plugins folder you must right-click the Fiji.app and select **Show Package Contents**:
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Note:
After installing or upgrading plugins, you need to restart ImageJ or Fiji to be able to use the plugins.

Using ImageJ with OMERO version 4.4.x

insert link in web page
Two plugins are required:

· loci_tools.jar

· OMERO.insight-ij

1
Download the latest 4.4.x version of the LOCI Tools plugin from:



`http://downloads.openmicroscopy.org/latest/bio-formats4<http://downloads.openmicroscopy.org/latest/bio-formats4>`
Check there is a “Bio-Formats 4.4.x Downloads” heading on the page.
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« Full documentation is available as web documentation or PDF documentation.

o The Bio-Formats API documentation is available to read on the web here.

« Internet Explorer sometimes renames JAR files to ZIP (e.g., loci_tools.jar becomes loci_tools.zip); if this happens to you,
simply rename the file back to its original name after the download is complete.

« For some browsers, you may need to right-click or control-click the link and choose "Save link as..." or a similar option

to download the file.
Bio-Formats tools downloads
Clients Size File Name Checksum
——@ ‘ a g LOCI Tools ; 1001 MB  loci_tools.jar dbbf3c (MDS5)
‘ l“ a Command Line Tools ‘ 1742KB  bftools.zip 15d697 (MDS)
‘ Ii ’ MATLAB Toolbox F 13.74KB bfmatlab.zip b0e7bl (MDS5)

* loci_tools.jar is complete bundle (for end users) containing everything needed to read images into ImageJ using Bio-
Formats. Instructions for installing Bio-Formats in Image]J are available in the user guide.

« bftools.zip is a bundle of scripts for using Bio-Formats on the command line.

« bfmatlab zip is a bundle of functions for using Bio-Formats from MATLAB.
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2
Save or move the downloaded file into the ImageJ > plugins folder.
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3
Download the latest 4.4.x version of the OMERO.insight-ij plugin from:



`http://downloads.openmicroscopy.org/latest/omero4<http://downloads.openmicroscopy.org/latest/omero4>`
Check there is a “OMERO 4.4.x Downloads” heading on the page.
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* Information on this release of OMERO is in the release announcement
« Full documentation is available as web documentation or PDF documentation and there are user guides for the clients on ¢

* A standard OMERO user just needs to download the client package with the same major version as their institutional servs

OMERQO client downloads

Clients Size File Name Checksum
‘ .‘ ﬂ Windows 6337MB  OMERO.clients-4.4.11-ice35-b9.win.zip  35e607 (MD5)
\ -‘ ‘L Mac 08 X 184.89 MB  OMERO clients-4.4.11-ice35-b9.mac.zip  €29db6 (MDS5)
’ “ b Linux 10272MB  OMERO.clients-4.4.11-ice35-b9.linux.zip 178900 (MD5)

* Each client package includes OMERO .insight, OMERO .importer and OMERO .editor and requires Java Version 1.6 or hi
package, so individual users do not need to install it locally.

o Full instructions for installing the clients are on the Help website: Getting Started with OMERO .insight Version 4.4.10

OMERO plugin downloads
Plugins Size File Name Checksum
———q ’ " é ImageJ/Fiji 4867MB  OMERO.insight-4.4.11-ice35-b9.zip £11602 (MDS)
‘ " ‘ Matiab 7978 MB  OMERO.matlab-4.4.11-ice35-b9.zip fedf7d (MDS)

* Instructions for downloading and installing the ImageJ plugin: Using ImageJ with OMERO

« Instructions for using the Matlab plugin are at: OMERO Matlab language bindings
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4
Save or move the .zip archive to the ImageJ > plugins folder.


Extract the archive into the plugins folder to give a folder named “OMERO.insight-ij-x” where x is the version number.


Leave the complete OMERO.insight-ij plugin folder with its components in the ImageJ > plugins folder.

Note: 
Some Windows unzip apps create a double folder enclosing the plugin.


Check, and if this has happened, copy the inner OMERO.insight-ij-4.4.x folder into the ImageJ > plugins folder.
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The OMERO.insight-ij-4.4.x.zip archive can be left in the plugins folder or deleted.

Using Fiji with OMERO 4.4.x

insert link in web page
Fiji changed the way it bundles and updates the plugins and jars needed to work with OMERO version 4.4.x in April 2014. Versions of Fiji since require the following steps to work with OMERO version 4.4.x.

Two plugins are required:

· loci_tools.jar

· OMERO.insight-ij

and incompatible Bio-Formats and SCIFIO plugins and jars need to be deleted.

1
Using a new or existing Fiji app download, start the app and allow it to go through and complete the update procedure, or from the menu select Help > Update Fiji.


In the **ImageJ Updater** window, click **Manage update sites**.


Highlight the **Bio-Formats** entry in the list.


Click **Remove**, and then **Close**.
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2
Quit Fiji.


Go to the Fiji app > plugins folder on your hard drive and delete bio-formats_plugins.jar

In the Fiji app > jars folder, select and delete the five jars with the prefix scifio-.
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3
Download and install the latest 4.4.x version of the OMERO.insight-ij plugin and loci_tools.jar as described in **Using ImageJ 4.4.x** above. insert internal link

Subsequent automatic Fiji updates should not affect these installations.

Accessing OMERO using ImageJ and Fiji

1
Launch the ImageJ application and click on the **Plugins** menu.


Select **OMERO > Connect to OMERO**.


A version of OMERO.insight will open and can be used as normal.
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2
As ImageJ needs to load the plugin software, it can take a minute or two for the OMERO login screen to appear, and then another two or three minutes for the progress bar to start moving and complete.


Enter your OMERO server address (if needed) and **Username** and **Password**.


Click **Login**.
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3
You will then be taken to the OMERO.insight Data Manager screen.
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**Note: **
If you quit OMERO.insight and then connect again during the same ImageJ session, logging in and launching the OMERO plugin will be much quicker. So if you intend using the OMERO plugin through ImageJ again soon, it may be worth leaving your ImageJ application running.

4
Double click on the image in the data tree or selecting the image and **View > View in ImageJ** in the contextual menu.


The Bioformats Import Options window opens.


Select parameters and click **OK**.
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Upgrading ImageJ from 4.4.x to 5.1.x

insert link in web page
To upgrade ImageJ for use with an OMERO version 5 server, you need to:

1
Go to the ImageJ > plugins folder.


Delete the loci_tools.jar and the OMERO.insight-ij-4.4.x folder.

Download the latest 5.1.x version of the Bioformats Package plugin from:



`http://downloads.openmicroscopy.org/latest/bio-formats5<http://downloads.openmicroscopy.org/latest/bio-formats5>`
Check there is a “Bio-Formats 5.1.x Downloads” heading on the page.

Save or move the downloaded file into the ImageJ > plugins folder.

2
Download the latest 5.1.x version of the OMERO.insight-ij plugin from:


`http://downloads.openmicroscopy.org/latest/omero5<http://downloads.openmicroscopy.org/latest/omero5>`
Check there is a “OMERO 5.1.x Downloads” heading on the page.

Save or move the downloaded file into the ImageJ > plugins folder.

Note:
The bioformats_package.jar you need, to use ImageJ with OMERO version 5.1.x, is incompatible with loci_tools.jar, and ImageJ will not work with OMERO if both are in the plugins folder.

We suggest that if you wish to access both 4.4.x and 5.1.x versions of OMERO from ImageJ that you run two appropriately named copies of ImageJ each with the appropriate plugins for the version.

For more information on using ImageJ with OMERO versions 5.1.x and 5.0.x see:

Using ImageJ with OMERO (http://help.openmicroscopy.org/imagej.html).
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